• problems installing, black screen after successful install.

    going straight to TLDR mode here.

    1. black screen on live USB.
    2. enabled no KMS under video mode works.
    3. installing and successful.
    4. after grub black screen.
    5. tried adding nomodeset, and rebuilding grub.
    6. still black screen.
    7. isn’t nomodeset suppose to disable kms? why did it work during live USB and not after install?

    useful info:
    disabled secure boot
    disabled fast boot

    full system specs:
    MOB: Asus Strix b350-f gaming
    CPU: Ryzen 7 1700
    GPU: AMD Vega 64
    SSD 240gb

    need more info call me out! and please tell me how to acquire such info or link me howto. I’m linux noob trying to escape the windows ecosystem. all help appreciated!

    note: running antergos on ALL my other systems 4 total without these issues however they are all intel cpu based and nvidia gpus are being used on all.

  • @joekamprad

    oh was not aware of this. looks alittle complicated. ill wait a month or two and it should be working then right ?

  • not so complicated, but waiting is more easy ;) and will be sorted out soon…

  • @joekamprad

    i might try if i fail ill just wait. marking as solved.

  • Boot without graphical environment:


    Add the mesa-git repo to /etc/pacman/pacman.conf

    sudo nano /etc/pacman/pacman.conf

    add this line to the end of the file:

    SigLevel = PackageOptional
    Server = http://pkgbuild.com/~lcarlier/$repo/$arch

    save with [Ctrl+X]

    sudo pacman -Syu

    Install Linux 4.12 for AMD GPUs

    sudo pacman -S linux-amd-staging linux-firmware-git mesa-git
  • only keep in mind to revert the settings inside pacman.conf when support is up on standard mirrors!
    and greetings from 🇩🇪 to norway! 🇳🇴

  • @joekamprad

    thanks! will try this when i get home :)

installing128 install84 black83 successful5 Posts 8Views 1381
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.