• Como hacer funcionar un alias en Xampp


    Buenas tardes:

    Antes que nada, saludos a todos como recién llegado al foro de esta gran distro

    He instalado Xampp y en realidad he creado ya un alias editando httpd.conf siguiendo la wiki de Arch.

    Primero he indicado el directorio después del DocumentRoot:

    <Directory “/home/jaimechu/Documentos/php”>
    #Options Indexes FollowSymLinks ExecCGI Includes
    Options All
    AllowOverride All
    Require all granted
    </Directory>

    Y luego el alias:

    Alias /php “/home/jaimechu/Documentos/php”

    dentro del módulo correspondiente.

    Trato de acceder en localhost/php y me dice que no tengo acceso autorizado (error 403). Seguramente será una tontería pero no sé si tengo que hacer algo más o cambiar algún permiso de la carpeta.

    Espero que podáis ayudarme.

    Gracias de antemano

  • Buenas tardes:

    Antes que nada, saludos a todos como recién llegado al foro de esta gran distro

    He instalado Xampp y en realidad he creado ya un alias editando httpd.conf siguiendo la wiki de Arch.

    Primero he indicado el directorio después del DocumentRoot:

    <Directory “/home/jaimechu/Documentos/php”>
    #Options Indexes FollowSymLinks ExecCGI Includes
    Options All
    AllowOverride All
    Require all granted
    </Directory>

    Y luego el alias:

    Alias /php “/home/jaimechu/Documentos/php”

    dentro del módulo correspondiente.

    Trato de acceder en localhost/php y me dice que no tengo acceso autorizado (error 403). Seguramente será una tontería pero no sé si tengo que hacer algo más o cambiar algún permiso de la carpeta.

    Espero que podáis ayudarme.

    Gracias de antemano

  • Hola,

    Usted debe prestar mucha atención a todos los personajes cuando se trabaja con Apache. Trate de hacer los cambios siguientes. Además, asegúrese de que el servidor web tiene acceso al directorio mediante la ejecución de este comando:

    find /home/jaimechu/Documentos/php -type f -exec chmod 644 {} \\;  
    find /home/jaimechu/Documentos/php -type d -exec chmod 755 {} \\;
    
      
    <Directory "/home/jaimechu/Documentos/php"\>  
    Options All  
    AllowOverride All  
    Require all granted  
    </Directory\>  
      
    <IfModule alias\_module\>  
    Alias /php /home/jaimechu/Documentos/php/  
    </IfModule\>
    

    No se olvide de reiniciar apache con

    xampp restart
    

    Déjame saber cómo va

    Best Regards,
    Dustin

  • Hola buenas.

    Gracias por la ayuda. Lamentablemente no ha funcionado. Seguiré buscando alguna solución y si lo soluciono os lo hago saber.

    Gracias

  • Buenas:

    He podido solucionarlo. Aunque he instalado otras distros (sé que en eso no está el problema), resulta que el problema era que el alias lo tenía que poner después de la línea del script CGI dentro de las etiquetas del módulo. Al menos así he conseguido que me funcionase.

    Gracias por la ayuda

  • Gracias por publicar tu

    ¡Salud!

Posts 6Views 1767
Log in to reply