• Install screen is unreadable. What can I try next?


    Doing fresh install on a desktop pc with dual boot for win 10. I already installed windows and now I’m trying to install antergos along side. When I try to tell it to run the live image even when I tell it non graphical install I get an unreadable screen. See attached photo

    0_1505729099202_IMG_20170918_035234.jpg

    What do I try next? Thanks

    Jason

  • may shake your monitor ;)

    May you need to choose a screen resolution, or nomodeset to kernel parameter…
    But without knowing on what you want to install Antergos t is like looking in a glass ball, without electricity connection :)

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • Sorry for the vague post. It was a late night of computer problems and I was hoping there was a quick known fix.

    I reformatted my disks and installed windows 10 with an enlarged boot partition to accommodate dual booting. This is what led me to reinstall as my previous dual boot of arch and win10 had a full boot partition.

    I’m running this on a desktop. Parts list:
    https://pcpartpicker.com/user/p2ranger/saved/#view=6YhBD3

    MB - Asus Z97 pro
    CPU - Intel core i7 4790k
    GTX 970 ( 2 cards in SLI with 3 monitors)

    I’m installing from a thumb drive using antergos 17.9-x86_64

    I am including a link to a google photo album to show what I have tried and what it has gotten me.
    https://photos.app.goo.gl/E8yokR3gm9TfnnQs1

    I know when I tried installing Arch a couple of years ago, I had to add acpi=off
    to the end of the line for startup during install. I tried this here and still no luck.

    Thanks for any help

  • I am not shure, but may your nvidia card does not run with the included open source driver (nouveau) or the SLI is the problem…
    You can try the nvidia enabled ISO here:
    https://sourceforge.net/projects/antergos-nvidia-iso/

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • Thank you for your help

    I was able to get the nvidia ISO to work. It installed and I followed the How To install Dual boot Antergos and Windows tutorial from the Antergos website.

    When it was done and I reboot, I get no option to boot into Antergos, just windows. Even when I bring up the boot menu pressing F8 when it reboots, I don’t see the option.

    Any ideas why that would be happening?

    Thanks

  • @saltymedic said in Install screen is unreadable. What can I try next?:

    When it was done and I reboot, I get no option to boot into Antergos, just windows.

    Do you recall if you chose to install Grub or systemd-boot when installing?

    Thanks!

    Keep trying, never give up. In the end, you will find that it was all worth it

    My ISO:
    https://rebornos.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • @saltymedic
    Maybe this could help:
    https://antergos.com/wiki/miscellaneous/how-to-fix-grub-with-efi-boot/

    If you have a BIOS boot instead of EFI, in the end of that link there is a link to that case, too.

  • I would do what @manuel suggest, reinstall grub from the liveiso, by chrooting into Antergos installation…
    But it unusual that grub fails with only one other OS installed.

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • @Keegan I didn’t choose either one. I don’t recall seeing an option during the install process.

  • 0_1505945933146_cnchi-11.png

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • @manuel Thanks for the suggestion

    When I tried following the steps on that page, i was met with:

    [[email protected] /]# os-prober
      WARNING: Failed to connect to lvmetad. Falling back to device scanning.
    grub-probe: error: cannot find a GRUB drive for /dev/sdd1.  Check your device.map.
    

    I wasn’t quite sure what my boot partition was. I have root on one SSD and the EFI (where windows is) on another drive.

    Disk /dev/loop0: 1.2 GiB, 1295228928 bytes, 2529744 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    
    
    Disk /dev/sda: 465.8 GiB, 500107862016 bytes, 976773168 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disklabel type: gpt
    Disk identifier: 48474011-7646-483D-8D07-2A2CDAE86FB7
    
    Device       Start       End   Sectors   Size Type
    /dev/sda1     2048   1026047   1024000   500M EFI System
    /dev/sda2  1026048   1058815     32768    16M Microsoft reserved
    /dev/sda3  1058816 976773119 975714304 465.3G Microsoft basic data
    
    
    Disk /dev/sdb: 2.7 TiB, 3000592982016 bytes, 5860533168 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 4096 bytes
    I/O size (minimum/optimal): 4096 bytes / 4096 bytes
    Disklabel type: gpt
    Disk identifier: E11D436B-ED6D-47AD-BCD0-F043A4ED50B8
    
    Device          Start        End    Sectors  Size Type
    /dev/sdb1        2048 2807683071 2807681024  1.3T Linux filesystem
    /dev/sdb2  2807683072 2825146367   17463296  8.3G Linux swap
    /dev/sdb3  2825146368 5860532223 3035385856  1.4T Microsoft basic data
    
    
    Disk /dev/sdc: 465.8 GiB, 500107862016 bytes, 976773168 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disklabel type: gpt
    Disk identifier: DA9A6AF9-066B-4C1A-8778-93CCE5A68D97
    
    Device     Start       End   Sectors   Size Type
    /dev/sdc1   2048 976773134 976771087 465.8G Linux filesystem
    
    
    
    
    Disk /dev/sdd: 7.3 GiB, 7798784000 bytes, 15232000 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disklabel type: dos
    Disk identifier: 0x428eb0ac
    
    Device     Boot Start     End Sectors  Size Id Type
    /dev/sdd1  *        0 2744447 2744448  1.3G  0 Empty
    /dev/sdd2         224  131295  131072   64M ef EFI (FAT-12/16/32)
    
    

    sda is the SSD where I installed windows. sda1 is where I mounted both boot and boot/efi
    sdb is for my linux home partition and windows media files
    sdc is for where I installed antergos and is my root parition
    sdd is the thumb drive for the life ISO

  • @joekamprad My install screens didn’t show that. I think that would have been the “Erase disk and install Antergos” option. I chose the “Choose exactly where Antergos should be installed” option. I have a home partition I am trying to preserve.

    Here is screenshots of how I chose my partitions for installation:

    0_1505946954945_IMG_20170920_163041.jpg
    0_1505947074166_IMG_20170920_163304.jpg

  • @saltymedic said in Install screen is unreadable. What can I try next?:

    [[email protected] /]# os-prober
    WARNING: Failed to connect to lvmetad. Falling back to device scanning.
    grub-probe: error: cannot find a GRUB drive for /dev/sdd1. Check your device.map.

    normal warnings if the disks are data disks only …

    On what you say i can see one failure…
    The efi drive from windows need to be mounted into the root filesystem from Antergos under /boot/efi
    where /boot is under / (root) on /dev/sdc1 if you do not have an extra partition for /boot

    /dev/sdc1 2048 976773134 976771087 465.8G Linux filesystem
    This is your Antergos root (/) so needs to be mounted under /mnt

    /dev/sda1 2048 1026047 1024000 500M EFI System
    is what you need to mount under /boot/efi so for the chroot under /mnt/boot/efi
    /dev/sdc1 2048 976773134 976771087 465.8G Linux filesystem

    mount /dev/sdc1 /mnt
    mount /dev/sda1 /mnt/boot/efi
    arch-chroot /mnt
    grub-mkconfig -o /boot/grub/grub.cfg
    grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=Antergos-grub
    

    grub-mkconfig will invoke os-prober afaik so no need to run it double.
    And know i can see why bootloader installation fails while the installation of Antergos, a lot of disks and huge space, grub/os-prober has some problems with such things at the moment it helps to mount all disks before starting grub commands, or you need to wait long time till command ends and get ready…

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • @joekamprad Thanks for the explanation

    After following those instructions I got this:

    [[email protected] /]# grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=Antergos-grub
    Installing for x86_64-efi platform.
    EFI variables are not supported on this system.
    EFI variables are not supported on this system.
    Installation finished. No error reported.
    

    Will see what happens. Thank you

  • Well that didn’t seem to fix it. Still no option on boot menu for Antergos. I’ll add this to see if it makes a difference. I noticed that I couldn’t install through the UEFI option on the boot menu when I installed Antergos. I will include photos to show you what I mean and what I did. To install I wound up choosing the SandDisk option in the boot menu without UEFI:
    0_1505948718413_IMG_20170920_141345.jpg 0_1505948750368_IMG_20170920_141413.jpg
    0_1505948852835_IMG_20170920_141416.jpg

    Don’t know if this might make a difference

  • @saltymedic said in Install screen is unreadable. What can I try next?:

    @joekamprad My install screens didn’t show that. I think that would have been the “Erase disk and install Antergos” option. I chose the “Choose exactly where Antergos should be installed” option.

    0_1505996405226_Yb1KlXb.jpg
    there you can see bootloader installed to /dev/sda

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • so as i can see you do not start installation on EFI and it try to install legacy Bios with installation to the mbr…

    EFI variables are not supported on this system.

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • I don’t understand why. I have previously dual booted Windows 10 and Arch on this system before using EFI. Hmmmmm

  • this new efi stuff sucks a bit ;)

    What i want to say is: the iso seems to startup only on legacy mode, without EFI and so it installs also in legacy mode…

    @saltymedic said in Install screen is unreadable. What can I try next?:

    before using EFI

    what do you mean here ARch works with EFI ???

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • And i do not want to say that your system is not able to run EFI it is an EFI-Bios so it is a problem with the ISO
    (Oh no! it is my ISO :) )

    It mostly works but every EFI-System is different.

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

unreadable1 Posts 27Views 757
Log in to reply