• Error: no such device: UID (after grub)


    Hello,
    I have been trying to install Antergos (64 bits) on a new machine with openSUSE and Ferdora already installed on the internal hard drive in legacy bios mode. No UEFI, no Windows. All I want to do is install Antergos onto an external hard drive. When using Cnchi I mark the bootloader to be also installed onto the same device, sdb (sda corresponds to the internal). I use only two partitions on this drive for the installation: / and swap. That’s all. Everything goes smoothly during installation but when booting to the newly installed Antergos firtstly appears grub with only two lines (for Antergos only, no other OS are mentioned) and then a message error: “no such device”: and next to it there is a UID number that I think it corresponds to no existing partition.
    I have tried it twice, the second time without removing the usb with the installation iso and nothing changes. So it seems that there is something wrongly configured in grub or initramfs during the installation process. Is it due to more than one possible destination target device? I think what I am trying to achieve is a very easy and an almost default configuration.
    Thanks,

  • Hello,
    I have been trying to install Antergos (64 bits) on a new machine with openSUSE and Ferdora already installed on the internal hard drive in legacy bios mode. No UEFI, no Windows. All I want to do is install Antergos onto an external hard drive. When using Cnchi I mark the bootloader to be also installed onto the same device, sdb (sda corresponds to the internal). I use only two partitions on this drive for the installation: / and swap. That’s all. Everything goes smoothly during installation but when booting to the newly installed Antergos firtstly appears grub with only two lines (for Antergos only, no other OS are mentioned) and then a message error: “no such device”: and next to it there is a UID number that I think it corresponds to no existing partition.
    I have tried it twice, the second time without removing the usb with the installation iso and nothing changes. So it seems that there is something wrongly configured in grub or initramfs during the installation process. Is it due to more than one possible destination target device? I think what I am trying to achieve is a very easy and an almost default configuration.
    Thanks,

  • Hi,

    This issue is caused by an upstream bug in grub, well actually osprober. However, because you have Antergos on an external drive, you should stick with the your existing grub install from openSUSE or Fedora. You’ll need to run the command below from whichever OS owns your current grub loader.

    sudo grub-mkconfig -o /boot/grub/grub.cfg
    

    Let me know if it resolves the issue for you

    Best Regards,
    Dustin

  • Thanks for the reply,
    More details:
    I intend to use Antergos’ grub to boot Antergos, nothing else. In the installation I perform, the grub from Opensuse, which is the one that boots Fedora too, is not used in the process. I swich on the computer and at the bios prompt I press F11 (in my case) to select the device where Antergos and its grub are. Then Antergos’ grub appears and then the error.
    On other occasions when I have installed other Linux systems this way, for example LMDE, CentOS or Manjaro, and its grub also ofers to boot whatever is on the internal hard drive, which I don’t need to use because there is another grub there to do it. I don’t care if Antergos’ grub sees other systems because I want it only to boot Antergos.
    If I understand properly, do you propose to install Antergos choosing not to install its grub and then use the grub from the internal disc to boot it? This doesn’t seem logical at all… What does cause the bug of OSprober? Having any other installed system? Another grub? If there was no other system on another drive (which I make the installer ignore) would Antergos grub boot Antergos?
    If I now try to make Opensuse’s grub to boot Antergos as it is the chain would be: swich on > Suse’s grub > Antergos’ grub > Antergos…?
    Is there a way to fix this from the running Antergos iso after the installation and before the first reboot?
    Another thing: I have had this issue from Antergos only and always that I tried. I tried to install it this way the two previous isos and even the recent RC… and this error puzzles me.
    Thanks,

  • Okay, I understand what setup/layout you want. YOu are doing everything correctly. The problem is that the wrong UUID is placed in grub.cfg by osprober which caused the error. If you look in /boot/grub you should see one or both of these files:

    grub.cfg.example  
    grub.cfg.example.new
    

    You need to replace grub.cfg with whichever one of those files contains the correct UUID (will likely be grub.cfg.example.new) It should boot properly after that. Please let me know how it goes.

    Best Regards,
    Dustin

  • Thanks a lot for your response,
    I will try to do it.
    Another thing I did not remember to mention yesterday:
    This OSprober bug reminds me of the one that affects Debian stable 64 bits (not 32) and it’s very well explained in their site. If you try to install Debian from a USB stick and therefore there is more than one device available, the installed system will not boot. A part from a solution that consists in chroot to the installed system and reconfigure grub there’s another very simple one that I used: using a DVD and not a USB stick. Is it the same bug? Would it be useful to also try it or, given the fact that there would still be more than one target device besides the DVD, the problem would not be avoided?
    Thanks again,
    I will let you know…

  • Well, thanks a lot! It worked!
    I’m writing this from the installed Antergos system! (Although the keyboard layout setting from the installer has not been kept and I have set it manually.)
    What I have done:
    From another linux system (Opensuse, but I think the Antergos iso would have been equally userful) I have accessed Antergos’ drive and entered /boot/grub. Then, after perusing its contents, I have finally copied everything that was in grub.cfg.new (there where only grub.cfg. example and grub.cfg.new, not grub.cfg.example.new) into grub.cfg. Then rebooted and selected to boot from the external device: what a beautiful grub splash screen Antergos have!
    Once logged in, I wondered if the manual change would stick and survive the future process of updating, for instance, a new kernel… As I had seen, grub had offered only two options from Antergos, no mention of any of the other Linux systems in the internal drive. So I ran the command sudo grub-mkconfig to update grub’s configuration and everything else was detected. Rebooted again for confirmation and happily here I am!
    Despite all this, it is my view that if there is a known bug of Osprober it would be nice to have it mentioned in some kind of release notes, and I still would like to know in which circumstances this bug is triggered: if installing on a different device than sda, if having more than one possible target device, if it is related to some options of the installer… It would be useful to know to plan future installations.
    Thanks a lot! You have a new user!

  • Hi,

    I am glad to see this is resolved for you

    Best Regards,

Posts 8Views 1961
Log in to reply