• playonlinux missing some font dependencies?


    When I try to run my some of my programs I installed through playonlinux it gives me this error: Wine cannot find the FreeType font library. To enable Wine to use TrueType fonts please install a version of FreeType greater than or equal to 2.0.5.

    I have all these installed and everything is updated:

    lib32-sdl_ttf 2.0.11-3
    perl-font-ttf 1.06-2
    sdl2_ttf 2.0.14-1
    sdl_ttf 2.0.11-4
    ttf-bitstream-vera 1.10-11
    ttf-dejavu 2.37-1
    ttf-liberation 2.00.1-7
    
  • @MachinaeWolf
    Hi!
    I never had this problem. Do you have freetype2 installed?

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • @fernandomaroto Yep, both of these:

    freetype2 2.8-2
    lib32-freetype2 2.8-2
    
  • @MachinaeWolf
    ok, try this:
    *this will install the dependencies in case some is missing.
    sudo pacman -S $(pactree -u freetype2) --needed

    or even
    sudo pacman -S $(pactree -u wine) --needed
    sudo pacman -S $(pactree -u playonlinux) --needed

    Can you tell me if stopped working or was your first time using playolinux?
    Next tip i’d tell you to reinstall wine and playonlinux…

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • @fernandomaroto I get loads of is up to date -- skipping for all of those commands. Well this is my first time using playonlinux on this install, yes.

  • @MachinaeWolf
    Ok…
    Did you update your system lately?

    Try uninstalling wine and playonlinux and reinstalling again:
    sudo pacman -Rns wine playonlinux
    sudo pacman -S wine playonlinux

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • @fernandomaroto Yes I did update the system earlier today a few hours ago. I tried those 2 commands and it’s still behaving the same way :/

  • @MachinaeWolf i have no more ideas…
    But this post may help you https://bbs.archlinux.org/viewtopic.php?pid=1700283#p1700283

    or even search the web link text

    Unless someone else has more ideas…

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • @fernandomaroto That worked, thank you :) Now I can use the kindle app again. One of the games I had installed has a different issue but I think a reinstall would fix it, I can scrap that wineprefix and start again at any time anyway.

  • @MachinaeWolf I’m glad you fixed it.
    If you could post here what you did that worked to help future users (so they won’t need to go to internet or other sites)…
    Also please mark the post as solved (Down the page in “TOPIC TOOLS”)

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • @fernandomaroto I deleted the libz.so library files in the ~/.PlayOnLinux/wine/linux-x86/<wine-version>/lib directories to fix it.

font19 playonlinux4 missing28 dependencies5 Posts 11Views 402
Log in to reply