• usb permisions, can't write


    Hi everyone,
    I’ve just formated (ext4) and usb, and I can’t write anything.
    I tried chown, chmod and lots of tips I found. No success.

    Please could you tell me how can I write into my usb???

    I’ve even tried gksudo nautilus, but once it opens it dosent show me the usb devices.

    I need help please…

    Cheers.

  • how do you format it? is it a stick or a external hd?

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • It is a 8gb usb stick formated using gparted in ext4 format.

  • what do you have onto the stick before?

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • @fgcaipe
    Please show the output of commands:
    df
    sudo blkid
    sudo fdisk -l

  • $ sudo fdisk -l
    identify your usb stick and copy the /dev…

    $ sudo dd if=/dev/zero of=/dev/sd**X** bs=1 count=446 conv=notrunc
    where /dev/sdX should be replaced with the devicename of your stick!
    to erase may some boot entrys from usb stick…

    and use fat32 to format it so you will be able to use it everywhere… (gparted should be good here)
    first create partitiontable (msdos) then fat32 partition and give a name if you want…

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • You need to mount the stick properly.
    man mount

    Then, as root, you need to give suitable permissions and/or change owner.
    man chmod
    man chown

    For example, as root:

    # assumes stick partition is /dev/sdb1
    mount /dev/sdb1 /mnt 
    cd /mnt
    mkdir myfolder
    chown user:group myfolder
    chmod 0755 myfolder
    

    Later when you insert the stick, “activate” it with your file manager just by clicking it.

  • documents images etc… why?¿

  • @fgcaipe only ask what was on it before because may it was a bootable stick for a LiveIso and needs to be cleaned up before… EXT4 will only work for Linux FAT32 works for all OS and is more easy to mount…

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • @joekamprad I was wrong, today my girl told me in that stick there was a Linux ISO before, so what do u mean with clean up before?

    Thanks.

  • overwrite the stick with zeros:

    $ sudo dd bs=4M if=dev/zero of=/dev/sdX status=progress && sync
    where /dev/sdX needs to be replaced with the device of your stick.

    then stick is completely empty, and it will run fine after putting a dos partition table and format with fat32 or also ext4 if you want to use it linux only… this will work with gparted as you do before…

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

write4 usb66 permisions1 Posts 11Views 241
Log in to reply