• [SOLVED] Struggling to get wifi working with a Broadcom wireless chip


    Hey there!

    So I’m currently struggling to get my wifi working. I’m sure it’s a simple fix, but I haven’t found anything on the Arch Wiki or online to explain my issues.

    Before I go into the actual issue, I’d like to try and provide as many details about my laptop and what I have installed so far as possible. I have Antergos installed on a Dell Vostro 2520 with the Broadcom Limited BCM43142 802.11b/g/n. I installed the wl driver for the Broadcom card, and it seems to have installed correctly when I check it with lspci -k:

    Network controller: Broadcom Limited BCM43142 802.11b/g/n (rev 01)
    Subsystem: Dell Wireless 1704 802.11n + BT 4.0
    Kernel modules: bcma, wl

    I also went ahead and installed dialog so I’d have access to wifi-menu, as well as iw and wireless_tools

    Now, as for the actual problems I’ve encountered:

    I immediately notice there is no kernel driver, only two modules, for the chip. I’m praying that’s the problem, and if it is, how do I get a driver in there? It’s probably selective blindness or something but I haven’t seen it when looking through the Arch Wiki page on Wireless Network Configuration.

    While following the wiki’s guide, I got a bit stuck at when I make sure the firmware is loaded. I type “dmesg | grep firmware” and I get:

    [ 3.751044] bluetooth hci0: Direct firmware load for brcm/BCM.hcd failed with error -2

    I’ve also spent a bit of time looking through the different databases suggested by the Arch Wiki to see if my wireless card has a driver. I’m not seeing one, but I had Linux Mint installed on this machine a few days ago and I’m fairly certain the wifi was working (could be wrong, and I might reinstall Mint just to confirm. My laptop did not often leave my desk, and since the wi-fi is so poor here I just use an ethernet cable regardless of OS).

    Again, I’m sure it’s obvious what I did wrong, and I’m just not seeing it. Or it’s just as simple as my wifi-card is unsupported in Linux. Either way, any help would be appreciated. Thanks!

    Oh, and I can also provide any other info needed if I left something out.

    EDIT: Got it working, the broadcom-wl driver did not work for me, but installing the broadcom-wl-dkms driver did!

    EDIT 2: Sorry, new to the forums and I could not change the Unsolved tag, so I went ahead and added [SOLVED] to the title!

  • Nice to hear that you find a solution!

    It was reported by manyusers that the dkms driver package working!

    As the broadcom-wl is from Antergos Repo we need to think about what is wrong here maybe? @developers

    @heshakomeu mark as solved then please!

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • I suspect this might be a kernel issue. If you are using different kernel than default linux, broadcom-wl may not work. Broadcom-wl-dkms is kernel independent version.

    But, this might be related to the wifi card as well. Not all broadcom cards supposed to work with broadcom-wl. See arch wiki for details.

    In general, it is better to pay 15 bucks to get intel card, live like a king!

  • But if we integrate the driver inside the ISO it should work, if the other one is working better, may check why it is so… to get the best solution on the Installer.

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • The main difference in between is (or should be) the dkms, that is what I am trying to say. This is true for broadcom-wl AUR, I have no knowledge about antergos/broadcom-wl.

    From, arch wiki:

    Tip: The DKMS variant broadcom-wl-dkms
    -is kernel agnostic. This means it supports different kernels you may use (e.g. linux-ckAUR).
    -is kernel release agnostic, too. It will be automatically rebuilt after every kernel upgrade or fresh installation. If you use broadcom-wlAUR or another kernel release dependant variant (e.g. broadcom-wl-ckAUR), it may happen that kernel upgrades break wireless from time to time until the packages are in sync again.

    Also another point, antergos controls the broadcom-wl package but not the kernel itself so it is important that they are in sync.

  • yes i understand dkms ;) but we have only the main kernel on the ISO.

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • @psscnp142 said in Struggling to get wifi working with a Broadcom wireless chip:

    broadcom-wl

    but as i can see here:
    https://github.com/Antergos/antergos-packages/blob/master/antergos/broadcom-wl/PKGBUILD
    it looks like the PKGBUILD for archpackage broadcom-dkms-wl:
    https://git.archlinux.org/svntogit/community.git/tree/trunk/PKGBUILD?h=packages/broadcom-wl-dkms

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • Yes, you are right. Then, our broadcom-wl(-dkms) doesn’t work as opposed to broadcom-wl-dkms from arch.

    Just skimming the PKGBUILDs, I see that the main difference is antergos version doesn’t have linux412.patch.

  • Yeah, to clarify, I just did a standard, vanilla installation of Antergos with the Gnome 3 desktop environment. I saw the option to install the LTS Linux kernel, but I did not install it. I’m very new to Linux in general, so I apologize if my knowledge of what kernels are is wrong, but I assume that means I don’t have a custom kernel?

    Also as clarification: I used the broadcom-wl-dkms package from the AUR, and that was what did the trick!

    Thanks for all the suggestions and help. Even though I figured it out not too long after making my post, I’m glad I can see why my wifi didn’t work at first!

  • @heshakomeu yes, main kernel called linux (as the package) and this one you have installed also if you check to insztall linux-lts this will install both then and you have the lts-kernel as a failsave option.

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • @joekamprad Rad, and these two kernels won’t ever conflict? It would remain just a failsafe if the main kernel broke somehow?

  • You can choose the LTS Kernel under advanced options on bootup then system starts with the LTS Kernel.
    So if a kernel update (for main kernel) brake some stuff you can bootup with LTS Kernel, instead.

    The kernels are present as images under /boot and will be loaded on bootup as this.

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • Oh, that’s handy! Thanks for the explanation, I’ll keep that in mind in the future :)

    Thanks again for all the help, everybody!

  • welcome here!

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

Posts 14Views 219
Log in to reply