• Wireless problems


    Hi everyone,
    I have the ASUS PCE-AC68 wlan card.
    I follow this website https://wikidevi.com/wiki/ASUS_PCE-AC68 and I tried ton install broadcom-wl/broadcom-wl-dkms, but it doesn’t work…
    By doing ip link show, I find the LOOPBACK and my ethernet card. But I want to connect my computer with Wi-Fi.

    Any solutions ?

    Thanks for your help !
    *Sorry for my english, I’m from Switzerland, I speak french *


    com002 / aurele
    https://com002.ch/ and https://aurele.ch/
    Please excuse my English, I'm from Switzerland, my main language is French

  • @aurele said in Wireless problems:

    *Sorry for my english, I’m from Switzerland, I speak french *

    To be honest, your English sounds great! I would have never guessed it wasn’t your native language.

    Any solutions ?

    I’m not the most experienced user around, but perhaps this video might help? (it’s custom made for Antergos, so the instructions should be spot on).

    Hope this helps and good luck!

    Keep trying, never give up. In the end, you will find that it was all worth it

    Community ISO: https://antergoscommunityeditions.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • @aurele said in Wireless problems:

    ASUS PCE-AC68

    i would say that this adapters, needs a firmware to work… sudo pacman -S b43-firmware

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • Hi @Keegan & @joekamprad ,
    First, thank you for your help.
    I tried to install broadcom-wl and b43-firmware, but no way to connect to a WiFi network.

    I’m using xfce I don’t know if I do something wrong, or if I forgot something…

    I read some thread about that, but I found no solution :/

    So, any other idea ?

    Sorry and thank you for your help ;)


    com002 / aurele
    https://com002.ch/ and https://aurele.ch/
    Please excuse my English, I'm from Switzerland, my main language is French

  • @aurele said in Wireless problems:

    So, any other idea ?

    Sadly, I’m not actually that experienced in this field:disappointed: so I do not know if I can really help you further. I had just hoped that perhaps the link I posted might have your answer. If it does not, then I’m out of ideas.

    Keep trying, never give up. In the end, you will find that it was all worth it

    Community ISO: https://antergoscommunityeditions.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • @Keegan Hey ! Sorry, I forgot to said that the video tell that you need to install the packages I wrot in my last post. So unfortunaly the problem is not solved with the video.

    Thanks anyway


    com002 / aurele
    https://com002.ch/ and https://aurele.ch/
    Please excuse my English, I'm from Switzerland, my main language is French

  • @aurele said in Wireless problems:

    So unfortunaly the problem is not solved with the video.

    :disappointed:.I don’t know what to say then…

    Sorry, and good luck! May your problem be resolved shortly.

    Keep trying, never give up. In the end, you will find that it was all worth it

    Community ISO: https://antergoscommunityeditions.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • @aurele do you try to get wifi aviable with any other adapter?
    May you do not have the full setup for wifi, if you say that it does not show up in settings, may you need some stuff installed first:

    check driver status:

    lspci -k
    

    check if firware is loaded:

    dmesg | grep firmware
    

    check packages:

     pacman -S wireless_tools wpa_supplicant networkmanager network-manager-applet
    

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • Hi @joekamprad,
    Yes, i try with other older adapter but maybe 8 month ago, and it wasn’t working…

    My antergos installation is 1 week old. The card I use is working on Windows 10.

    lspci -k
    

    I have this line

    07:00.0 Network controller: Broadcom Limited BCM4360 802.11ac Wireless Network Adapter (rev 03)
    	Subsystem: ASUSTeK Computer Inc. BCM4360 802.11ac Wireless Network Adapter
    	Kernel modules: bcma
    
    

    The response of

    dmesg | grep firmware
    

    is empty

    And the package you say is alredy installed.

    I think the driver is correctyl installed, but the problem is the “virtual wireless card” because if I list the cards (ip link show) I only have lo who is the loopback, and enp3s0 who is my ethernet card.


    com002 / aurele
    https://com002.ch/ and https://aurele.ch/
    Please excuse my English, I'm from Switzerland, my main language is French

  • dmesg | grep bcma
    

    may this will give you a interface name:

    iw dev
    

    otherwise we can not try to get it up …

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • @joekamprad said in Wireless problems:

    otherwise we can not try to get it up …

    No response on the commands

    Unfortunaly, no return of the commands


    com002 / aurele
    https://com002.ch/ and https://aurele.ch/
    Please excuse my English, I'm from Switzerland, my main language is French

  • @aurele said in Wireless problems:

    Kernel modules: bcma

    this should be wl as we where sure it is the right driver…

    Device with broadcom-wl driver not working/showing
    Be sure the correct modules are blacklisted and occasionally it may be necessary to blacklist the brcm80211 drivers if accidentally detected before the wl driver is loaded. Furthermore, update the modules dependencies depmod -a, verify the wireless interface with ip addr

    https://wiki.archlinux.org/index.php/Kernel_modules#Blacklisting

    you can try vlacklisting this module on bootup to test if it change something by using this kernel parameter:

    modprobe.blacklist=bcma

    simple press"e" on the boot menu and add this right after quiet

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

wireless25 Posts 13Views 322
Log in to reply