• Can't control brightness through DE.


    Hello,

    I cannot control brightness with hardware buttons, nor with DE (lightdm) brightness slider.
    I cannot control using any packages (xbacklight …). -xbacklight is changing some values but without effect.

    I can control them the following way:

    sudo su
    echo 250 > /sys/class/backlight/radeon_bl0/brightness

    What I tried: everything in this https://forum.antergos.com/topic/2815/can-t-adjust-screen-brightness/5

    What is propably the cause: systemctl --failed output:

    UNIT                                                     LOAD   ACTIVE SUB       DESCRIPTION                                                   
    ● [email protected]:acpi_video0.service loaded failed failed Load/Save Screen Backlight Brightness of backlight:acpi_video0
    

    I know that I can set my keyboard brightness control to echo values, but I would really like this error to dissapear and to control it through xbacklight and DE slider.

    One interesting fact: lightdm’s night mode does work precise even with DE button.
    Another: Sound hardware buttons work, they even show an icon popup with slider.
    Another: External monitor modes hardware button works pretty good.
    Another: I had Ubuntu for some months and brigthness hard. buttons were working in Gnome and Unity.

    Can someone help me set the PC to control it as it should?

    Specs:
    Graphics: ATI Radeon r5 graphics (drivers installed - even some additional for games) , AMD® Mullins
    Base system: Antergos Linux 64-bit
    All packages and system are up to date
    Kernel version: 4.12.12-1-ARCH

    Thanks in advance. If more details needed, please ask.

  • @chazecka said

    I cannot control brightness with hardware buttons

    Is there an auto control brightness hardware switch. Just asking because I once faced the same issue till I noticed there was such a switch on my Dell Latitude.

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • REPORT HERE!
    I just reinstalled my Antergos, with different DE and whole problem is solved.

    I am not 100% sure, but maybe I didn’t choose to include Kernel app update (or something similar to this, it was a choice within installation process).
    Anyway, I did choose to install it this time. Do not know if it WAS the actual solution or just reinstallation or just switching to KDE (which I have choosen during installation process just to see if it brings change).

    Anyway, I can use hotkeys, I can see graphical response.

  • @anarch Although the problem is solved, the systembacklight fail message is still on, can I fix is somehow?
    EDIT: Can the error message cause the fact I am booting with external monitor connected, so he can’t restore any brightness settings for it?
    I tried booting without it, there was no error on startup black screen but after I did systemctl --failed, the error is still here… Maybe because the error persist here from previous boot with external monitor connected?

brightness13 control13 Posts 4Views 191
Log in to reply