• Error abriendo psensor.


    Hola, no consigo abrir[b:80rqet7b] “psensor”[/b:80rqet7b] , anteriormente me funcionaba correctamente, si me dirijo a la terminal:

    psensor: error while loading shared libraries: libgtop-2.0.so.7: cannot open shared object file: No such file or directory
    

    No sé si tiene algo que ver, pero hace un par de días al actualizar el sistema o instalar la libreria : [b:80rqet7b]lib32-simplescreenrecorder[/b:80rqet7b], no recuerdo bien, me salió lo siguiente:

    cat /var/log/pacman.log 
    

    [2014-05-25 11:52] [PACMAN] starting full system upgrade
    [2014-05-25 16:03] [PACMAN] Running ‘pacman -Syu’
    [2014-05-25 16:03] [PACMAN] synchronizing package lists
    [2014-05-25 16:03] [PACMAN] starting full system upgrade
    [2014-05-25 16:06] [PACMAN] Running ‘pacman --color auto -S --asdeps --needed multilib/gcc-multilib multilib/lib32-glu’
    [b:80rqet7b][2014-05-25 16:08] [PACMAN] removed gcc-libs (4.9.0-2)
    [2014-05-25 16:08] [PACMAN] removed gcc (4.9.0-2)
    [2014-05-25 16:08] [PACMAN] installed gcc-libs-multilib (4.9.0-2)
    [2014-05-25 16:08] [PACMAN] installed gcc-multilib (4.9.0-2)
    [2014-05-25 16:08] [PACMAN] installed lib32-glu (9.0.0-2)
    [2014-05-25 16:09] [PACMAN] Running ‘pacman --color auto -U /tmp/yaourt-tmp-antergos/PKGDEST.cvF/lib32-simplescreenrecorder-0.2.2-1-x86_64.pkg.tar.xz’
    [2014-05-25 16:09] [PACMAN] installed lib32-simplescreenrecorder (0.2.2-1)[/b:80rqet7b]

    Gracias y un saludos.

  • Hola, no consigo abrir[b:80rqet7b] “psensor”[/b:80rqet7b] , anteriormente me funcionaba correctamente, si me dirijo a la terminal:

    psensor: error while loading shared libraries: libgtop-2.0.so.7: cannot open shared object file: No such file or directory
    

    No sé si tiene algo que ver, pero hace un par de días al actualizar el sistema o instalar la libreria : [b:80rqet7b]lib32-simplescreenrecorder[/b:80rqet7b], no recuerdo bien, me salió lo siguiente:

    cat /var/log/pacman.log 
    

    [2014-05-25 11:52] [PACMAN] starting full system upgrade
    [2014-05-25 16:03] [PACMAN] Running ‘pacman -Syu’
    [2014-05-25 16:03] [PACMAN] synchronizing package lists
    [2014-05-25 16:03] [PACMAN] starting full system upgrade
    [2014-05-25 16:06] [PACMAN] Running ‘pacman --color auto -S --asdeps --needed multilib/gcc-multilib multilib/lib32-glu’
    [b:80rqet7b][2014-05-25 16:08] [PACMAN] removed gcc-libs (4.9.0-2)
    [2014-05-25 16:08] [PACMAN] removed gcc (4.9.0-2)
    [2014-05-25 16:08] [PACMAN] installed gcc-libs-multilib (4.9.0-2)
    [2014-05-25 16:08] [PACMAN] installed gcc-multilib (4.9.0-2)
    [2014-05-25 16:08] [PACMAN] installed lib32-glu (9.0.0-2)
    [2014-05-25 16:09] [PACMAN] Running ‘pacman --color auto -U /tmp/yaourt-tmp-antergos/PKGDEST.cvF/lib32-simplescreenrecorder-0.2.2-1-x86_64.pkg.tar.xz’
    [2014-05-25 16:09] [PACMAN] installed lib32-simplescreenrecorder (0.2.2-1)[/b:80rqet7b]

    Gracias y un saludos.

  • Hola,

    Es necesario instalar “libgtop” y posiblemente “lib32-libgtop”.

    ¡Salud!

  • Gracias por la respuesta, ya tenia instalado [b:26gwakt0]libgtop[/b:26gwakt0] e instalé [b:26gwakt0] lib32-libgtop[/b:26gwakt0] desde AUR. Pero me sigue dando el error.

    [[email protected] ~]$ psensor
    psensor: error while loading shared libraries: libgtop-2.0.so.7: cannot open shared object file: No such file or directory
    [[email protected] ~]$ whereis libgtop-2.0.so.7
    libgtop-2.0.so: /usr/lib/libgtop-2.0.so /usr/lib/libgtop-2.0.so.10
    [[email protected] ~]$ yaourt lib32-libgtop
    1 aur/lib32-libgtop 2.28.5-1 [installed] (28)
    A library that read information about processes and the running system (32-bit)
    ==> Introduzca el número de los paquetes que se instalarán (ejemplos: 1 2 3 ó 1-3)

    ¿ Alguna idea …?

    Saludos.

  • Le parece que se echa en falta algunos archivos. Intente volver a instalar con:

    sudo pacman -Syy libgtop
    

    Si eso no ayuda, publicar la salida del siguiente comando:

    pacman -Ql libgtop
    

    ¡Salud!

  • @“lots.0.logs”:1rbovh4k said:

    Le parece que se echa en falta algunos archivos. Intente volver a instalar con:

    sudo pacman -Syy libgtop
    

    Si eso no ayuda, publicar la salida del siguiente comando:

    pacman -Ql libgtop
    

    ¡Salud![/quote:1rbovh4k]

    Hola finalmente lo [b:1rbovh4k]SOLUCIONÉ !![/b:1rbovh4k]!. Este paquete ha recibido una actualización[b:1rbovh4k] libgtop 2.28.5-1 —>[/b:1rbovh4k][b:1rbovh4k] 2.30.0[/b:1rbovh4k]. Al actualizarse el paquete ya no se encuentra : [b:1rbovh4k]libgtop-2.0.so.7[/b:1rbovh4k]

    [b:1rbovh4k]libgtop 2.28.5-1
    [/b:1rbovh4k]

    libgtop /usr/lib/girepository-1.0/
    libgtop /usr/lib/girepository-1.0/GTop-2.0.typelib
    libgtop /usr/lib/libgtop-2.0.so
    [b:1rbovh4k]libgtop /usr/lib/libgtop-2.0.so.7[/b:1rbovh4k]
    libgtop /usr/lib/libgtop-2.0.so.7.2.0
    libgtop /usr/lib/pkgconfig/
    libgtop /usr/lib/pkgconfig/libgtop-2.0.pc
    libgtop /usr/share/

    [b:1rbovh4k]libtop 2.30.0[/b:1rbovh4k]

    libgtop /usr/lib/girepository-1.0/
    libgtop /usr/lib/girepository-1.0/GTop-2.0.typelib
    [b:1rbovh4k]libgtop /usr/lib/libgtop-2.0.so
    libgtop /usr/lib/libgtop-2.0.so.10
    libgtop /usr/lib/libgtop-2.0.so.10.0.0[/b:1rbovh4k]
    libgtop /usr/lib/pkgconfig/
    libgtop /usr/lib/pkgconfig/libgtop-2.0.pc
    libgtop /usr/share/

    La solución que , no sé realmente si es del todo correcta, ha sido hacer un [b:1rbovh4k]downgrade[/b:1rbovh4k] del paquete y volver a la versión[b:1rbovh4k] libgtop 2.28.5-1[/b:1rbovh4k]

    Después me he dirigido a

    /etc/pacman.conf

    IgnorePkg = libgtop

    ¿ Esta solución es correcta ?

    Gracias y un Saludo

Posts 6Views 947
Log in to reply