• Pulseaudio Plugin and Backlight Control Freezing


    Hi, I’m using Antergos + XFCE4, and both my backlight and my volume freeze for about a minute (as in they can’t be adjusted) after each adjustment when I use either function keys or applet (default PulseAudio Plugin + PavuControl). These issues do not occur when I adjust it using amixer and xbacklight from terminal, or pavucontrol. These worked fine yesterday; I don’t believe I made any significant changes to the system between now and yesterday.

    Thanks for your help.

  • logs we need logs ;)

    journalctl --since "20 minutes ago" | curl -F [email protected] https://ptpb.pw/?u=1
    

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • Or just open a terminal and run journalctl -f while you are doing the changes… you will see what happens (hopefully)

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • @joekamprad Thanks for taking your time to look at my issue. Here is the output of journalctl -f.

    [[email protected] ~]$ journalctl -f
    -- Logs begin at Sat 2017-09-09 14:17:41 EDT. --
    Sep 12 19:05:08 felixlaptop kernel: [UFW BLOCK] IN=wlp3s0 OUT= MAC=34:f6:4b:41:6e:0f:70:56:81:b9:8e:b1:08:00 SRC=10.24.220.155 DST=10.24.219.75 LEN=76 TOS=0x00 PREC=0x00 TTL=64 ID=61683 PROTO=UDP SPT=56462 DPT=161 LEN=56 
    Sep 12 19:05:35 felixlaptop dbus-daemon[798]: Activating service name='org.freedesktop.Notifications'
    Sep 12 19:05:38 felixlaptop wpa_supplicant[525]: wlp3s0: CTRL-EVENT-SIGNAL-CHANGE above=1 signal=-55 noise=9999 txrate=144400
    Sep 12 19:05:47 felixlaptop kernel: [UFW BLOCK] IN=wlp3s0 OUT= MAC=34:f6:4b:41:6e:0f:10:05:ca:9c:af:c0:08:00 SRC=10.24.128.117 DST=10.24.219.75 LEN=76 TOS=0x00 PREC=0x00 TTL=63 ID=45866 PROTO=UDP SPT=60370 DPT=161 LEN=56 
    Sep 12 19:06:35 felixlaptop plasma_waitforname[2248]: org.kde.knotifications: WaitForName: Service was not registered within timeout
    Sep 12 19:06:35 felixlaptop dbus-daemon[798]: Activated service 'org.freedesktop.Notifications' failed: Process org.freedesktop.Notifications exited with status 1
    Sep 12 19:08:11 felixlaptop dbus-daemon[798]: Activating service name='org.freedesktop.Notifications'
    Sep 12 19:09:11 felixlaptop plasma_waitforname[2268]: org.kde.knotifications: WaitForName: Service was not registered within timeout
    Sep 12 19:09:11 felixlaptop dbus-daemon[798]: Activated service 'org.freedesktop.Notifications' failed: Process org.freedesktop.Notifications exited with status 1
    Sep 12 19:11:17 felixlaptop kernel: [UFW BLOCK] IN=wlp3s0 OUT= MAC=34:f6:4b:41:6e:0f:10:05:ca:9c:af:c0:08:00 SRC=10.24.130.84 DST=10.24.219.75 LEN=76 TOS=0x00 PREC=0x00 TTL=63 ID=14314 PROTO=UDP SPT=62197 DPT=161 LEN=56 
    Sep 12 19:12:42 felixlaptop dbus-daemon[798]: Activating service name='org.freedesktop.Notifications'
    Sep 12 19:13:42 felixlaptop plasma_waitforname[2298]: org.kde.knotifications: WaitForName: Service was not registered within timeout
    Sep 12 19:13:42 felixlaptop dbus-daemon[798]: Activated service 'org.freedesktop.Notifications' failed: Process org.freedesktop.Notifications exited with status 1
    
    
    

    I pressed (on my laptop keyboard) Volume Up and then five seconds later Volume Down. The first press increased the volume and froze the applet (hovering does nothing), the second press didn’t register; it took maybe a minute to un-freeze.

    I forgot to mention that notifications don’t pop up anymore for anything. This issue may also affect my network manager applet since it sometimes seems to become unresponsive, specially after connecting to a network.

  • @HardDryPasta said in Pulseaudio Plugin and Backlight Control Freezing:

    Sep 12 19:13:42 felixlaptop plasma_waitforname[2298]: org.kde.knotifications: WaitForName: Service was not registered within timeout
    Sep 12 19:13:42 felixlaptop dbus-daemon[798]: Activated service ‘org.freedesktop.Notifications’ failed: Process org.freedesktop.Notifications exited with status 1

    looks like two notification servoces try to do the same thing and fail both…

    When you say you are on XFCE why kde noticiations are running? [plasma_waitforname[2298]: org.kde]
    Do you have kde/plasma related stuff installed?

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • @joekamprad That’s really strange, looking at my package manager I seem to have a bunch of plasma and KDE stuff. I haphazardly decided to remove PlasmaWorkspaces and everything works again. Thanks for pointing out that strangeness in the logs.

  • always willing to make user happy!

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

pulseaudio13 backlight5 control13 plugin2 Posts 7Views 105
Log in to reply