• Two issues with last Antergos installation


    Hi

    I’m trying to install Antergos with a BTRFS setup to improve my previous one but I keep running into the same problems.

    The first one is the smallest one and that is that Cnchi doesn’t offer to install the binary graphic drivers anymore. The option has disappeared and I can’t find anywhere that this was a developer’s choice in a new Cnchi version or something.

    The second is that I can’t install grub properly anymore with grub-install /dev/sda in chrooted mode. I get this error:

    warning: Attempting to install GRUB to a disk with multiple partition labels.  This is not supported yet..
    error: filesystem `btrfs' doesn't support blocklists.
    

    My drive /dev/sda has only one partition /dev/sda1, and for some reason 2 MB of empty space at the end, but that’s only visible in Gnome Disks and not Gparted.

    I tried adding empty space before the BTRFS partition, in case it was needed for the installation of GRUB2, but that didn’t solve anything.

    Any advice on this?

  • Sometimes Nvidia updates a package before the rest or something and can break the slipstream process. May depend on when you downloaded the installer/iso . Antergos now offers package nvidia-installer which allows you to install nvidia proprietary drivers after you have installed Antergos with ease.
    alt text

    Google says “Nuke the gap between the boot sector and the first partition.” Google Results

    All else fails you could write 0’s or format the drive and start over.

  • Thanks for the advice.

    Unfortunately, I tried what I could find on the internet. And nuking the gap isn’t possible as the drive is completely used by one BTRFS partition.

Posts 3Views 206
Log in to reply