• Black screen of DEATH, plain install.


    After successfully completing the installation (dual boot setup) and having selected Grub2, I rebooted and selected ‘antergos_grub’ as the boot priority option.
    When I boot I only see a white ‘_’ on a black screen, nothing else. :astonished:
    My device is a Beelink AP34 Intel Apollo Lake N3450.
    I created a /boot fat32 partition for Grub2 and pointed to the /boot/efi partition.
    Windows 10 boots normally when selecting the ‘Windows Boot Manager’ in the priorities.
    I also tried the option to use systemd-boot as bootmanager as explained here but with no success. In that case it boots straight into Windows 10.
    Basically I exactly followed this steps:

    • Created a first 256Mb fat32 partition on the SSD and mounted it to /boot
    • mounted the remaining partition to / (root)
    • tried both systemd-boot as bootmanager (I had no luck with grub2)
    • Changed the “hard disks boot priorities” to 'antergos_grub’
      Please help, should I use rEFInd?
  • @paoloc68 said in Black screen of DEATH, plain install.:

    Created a first 256Mb fat32 partition on the SSD and mounted it to /boot

    This is the wrong part…

    You need to mount the 256Mb fat32 partition (EFI-Boot) to /boot/efi

    /boot is the folder or partition where grub2 have its files + the kernel images place, and it can not be a fat32 partition imho it is an ext* filesystem…

    Grub will install to /boot/grub

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • how-to-dual-boot-antergos-windows-uefi

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • No luck, same as before, I have repartitioned created a ext2 256mb partition for /boot, mounted as /boot/efi the 105mb windows 10 EFI partition and I have the same black screen.
    My feelings tell me that this sentence in this article is pointing towards the problem:
    Unfortunately with the introduction of Intel Atom based mini PCs and tablets the issue of requiring a 32-bit bootloader to boot a 64-bit OS arose.
    It seems that I have to configure Grub to use a 32bit bootloader. Is t?

  • It seems that the only option is rEFInd, now the setup it is working by using it, maybe this issue should better analyzed so the setup process becomes easier for Apollo Lake processors owners.

  • @paoloc68 said in Black screen of DEATH, plain install.:

    Beelink AP34 Intel Apollo Lake N3450

    but if you can boot the liveISO… there will be a way… may you can add a boot entry out from windows…
    I find this Forum Post:

    https://bbs.archlinux.org/viewtopic.php?id=195027

    And this ne should do the job also after installation:

    https://wiki.archlinux.org/index.php/REFInd#Manual_installation

    Can you boot when you using LiveIso and choose “boot from harddisk” instead of “livesystem” ?

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

plain2 death2 black41 install78 Posts 6Views 154
Log in to reply