• Sudden loss of audio output


    I have been using Antergos continuously for the last 6 months. I listen to a lot of podcasts and watch videos every day. Until this morning audio output worked flawlessly. When I booted up this morning, suddenly there is no audio output. The volume control applet (I use plasma) indicates “no output or input devices found”. No mute or volume controls are available. I ran alsamixer in terminal and set all available volume controls to 100. The modules for my Intel soundcard are apparently loaded properly. I get “0 snd_hda_intel” when entering “cat /proc/asound/modules”. I reinstalled all alsa and pulseaudio packages, but there is still no audio even after rebooting. Attempting to manually start pulseaudio produces the follwing result:

    $ pulseaudio --start
    E: [pulseaudio] main.c: Daemon startup failed.

    I ran a speaker test

    speaker-test -c 2

    and noise is emitted from the left and right speakers as it should. I also booted another operating system
    and sound works normally. The problem is specific to my Antergos installation.

    The sudden occurrence of this problem is perplexing. Everything was working normally just a few hours earlier (before the last shutdown). I would be grateful for any suggestions.

  • try to remove all per-user pulse settings under ~/.config/pulse (rm -R ~/.config/pulse)

    $ pulseaudio --start
    E: [pulseaudio] main.c: Daemon startup failed.

    Is not used here, pulseaudio is started as per-user service:

    So as normal user:

    systemctl --user status pulseaudio.socket
    

    for status, and to stop start or restart replace status by thisones…

    Auto-Mute Mode is may be enabled, this is causing such problems at the moment for multiple users:

    It can be disabled using alsamixer.

    See http://superuser.com/questions/431079/how-to-disable-auto-mute-mode for more.

    To save your current settings as the default options, run alsactl store as root.

    more here:

    https://antergos.com/wiki/hardware/getting-informations-on-soundproblems/

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • Thanks for replying. It appears that pulseaudio is failing to start:

    $ systemctl --user status pulseaudio.socket
    ● pulseaudio.socket - Sound System
       Loaded: loaded (/usr/lib/systemd/user/pulseaudio.so
       Active: failed (Result: service-start-limit-hit) si
       Listen: /run/user/1000/pulse/native (Stream)
    
    Sep 08 00:18:05 DL-7370 systemd[634]: Listening on Sou
    Sep 08 00:18:10 DL-7370 systemd[634]: pulseaudio.socke
    lines 1-7/7 (END)
    

    After manually starting pulseaudio and checking the status again I get this:

    $ systemctl --user start pulseaudio.socket
    $ systemctl --user status pulseaudio.socket
    ● pulseaudio.socket - Sound System
       Loaded: loaded (/usr/lib/systemd/user/pulseaudio.so
       Active: active (listening) since Fri 2017-09-08 00:
       Listen: /run/user/1000/pulse/native (Stream)
    
    Sep 08 00:28:07 DL-7370 systemd[634]: Listening on Sou
    lines 1-6/6 (END)``````
    

    But there is still no sound and the applet still indicates “no output or input devices found”

    Automute is disabled.

    Removing ~/.config/pulse/ and logging out and back in as normal user has not solved the problem.

  • @DCB said in Sudden loss of audio output:

    speaker-test -c 2
    and noise is emitted from the left and right speakers as it should.

    Thats strange then… if i mute output-device (Asgabegeräte) with pavucontrol and start speaker-test -c 2 it is muted.
    And i can see alsa-plugin [speaker-test] as playback (Wiedergabe) with a level…
    1_1504812927471_Bildschirmfoto vom 2017-09-07 21-33-53.png
    0_1504812927470_Bildschirmfoto vom 2017-09-07 21-33-35.png

    So your problem is something else… where do you play audio and have no output? all methods or only Browser, Mediaplayer e.t.c.

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • So I have checked a few applications that play audio and discovered that the problem is limited to Firefox. Youtube videos play with audio in Chromium and Qupzilla. A downloaded mp4 file plays with audio in VLC. And as previously noted, speaker-test works as expected. There are two problems:

    1. Audio no longer plays in Firefox, although I had been playing videos and podcasts in Firefox without any issue until the day before yesterday.

    2. Even when audio plays in VLC, Chromium or Qupzilla, there are no audio output indicators or controls in the Plasma desktop applet or audio volume settings dialog. Normally there would be separate volume and mute controls for each currently active audio stream, but now there are none at all. I cannot alter the volume settings because the volume controls have vanished. The keyboard volume buttons also do not work. I cannot mute or unmute the audio either. If I open Audio Volume Settings in the system settings menu, everything under devices and applications is greyed out as if the computer had no audio devices. The audio volume applet in the desktop panel shows “No output or input devices found” even when audio is actually being played!

    Another thing I noticed: I normally have all system notification sounds disabled, but all my sound settings in the notification section of the Plasma system settings menu were mysteriously reverted to the defaults. I therefore suddenly started hearing system notification sounds again.

  • do you have plasma-pa installed?
    i have KDE installed too but onto another HD, i will take a look now…

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • journalctl -b -0 | grep pulse | curl -F [email protected] https://ptpb.pw/?u=1
    

    but looking into my journal … there is an issue with pulse and plasma lotsa errors…
    but here it is shown up and sound works in firefox too.

    What is the backend you are using?
    0_1504823161904_Screenshot_20170908_002427.png

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • plasma-pa is installed.

    I am using phonon gstreamer as backend. (Isn’t that the default in Antergos?)

    The strangest thing is that sound was working perfectly in Firefox until 2 days ago. The problem happened suddenly after a reboot. I did not consciously alter any configs or install any software or updates just before the problem happened.

  • If you put this in terminal and open the link it gives you, you will see what happens…

    journalctl -b -0 | grep pulse | curl -F [email protected] https://ptpb.pw/?u=1
    

    Are you dualbooting with another OS?

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • For testing purposes I do have some other operating systems (Linux and Windows) installed on the same computer. Antergos is my main operating system which I use almost exclusively. When I started having audio problems in Antergos, I did boot into Ubuntu to check if it was a hardware problem. In Ubuntu, audio works normally (even in Firefox).

    $ journalctl -b -0 | grep pulse | curl -F [email protected] https://ptpb.pw/?u=1
    https://ptpb.pw/wkjh
    $
    

    Sep 09 00:13:50 DL-7370 plasmashell[632]: org.kde.plasma.pulseaudio: context kaput

  • @DCB said in Sudden loss of audio output:

    https://ptpb.pw/wkjh

    was needed here only :man_cartwheeling_tone2:
    I just have a look…

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • Try this workaround: edit /etc/pulse/default.pa and replace:
    load-module module-native-protocol-unix
    with:
    load-module module-native-protocol-unix srbchannel=no

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • I edited /etc/pulse/default.pa as suggested and rebooted, but there is no change. No sound in Firefox and no volume controls or indicators.

  • as i do not use kde regular i am not specialist to it…

    But can you try to add a new user and login to plasma-kde with this one?

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • I created a new user account and logged into it. Audio works normally in the new user account. Sound works in Firefox and audio settings controls are restored.

    Is there any way to fix audio in my original user account or will I have to set up everything from scratch again in the new user account?

  • depending on the applications you are using you can restore their settings by copy paste… or you try to find out which settings are causing the problem and erase them from your original account…

    may it is only:

    mv ~/.config/kmixrc  ~/.config/kmixrc.old
    

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

Posts 16Views 540
Log in to reply