• Antergos Boots Directly to Kodi

    When I start-up or reboot Antergos is bypassed and goes directly into Kodi. (It just started to do that recently - I think it happened after I performed a “shut down” from Kodi rather than an “exit”.)
    On start-up I can hit “E” and go to edit GRUB, Where to go from there?

  • @monk13
    Probably this link can help you: https://kodi.tv/

  • But kodi is installed as standalone Distro? or inside Antergos aside with another DE?
    If 2. it looks like you have autologin enabled and it bypass the DM (lightdm) where you can choose your DE…
    You will need to logout from Kodi then and change login to the other DE inside lightdm.
    Or disable autologin inside config.

    in /etc/lightdm/lightdm.conf change the line:
    to disabled:

    If you can not reach a terminal or TTY3 you can bootup like discribed here:


  • Hey Guys,
    Thanks for the quick response. I am brand new to the Linux Universe, and this is my first time asking for assistance from a forum.
    SO - I don’t think I gave you guys all of the necessary information.
    (And I am about to give you more than you need.)
    BACKSTORY - I have run more than a couple of dedicated Kodi installs (OpenELEC, OSMC, LibreELEC) on R.Pi 2B and now on 3B (got more than a few SD cards).
    BUT - I decided I wanted something with a wider base so I could also do some other things from the living room TV-media set-up.
    AND - I have wanted to explore the Linux Universe for quite some time.
    SO NOW (for the past couple of months) I have been trying on Linux distros and DEs (Raspbian, xbian, Mint, UbuntuMATE, and more) to see what fits.
    WHAT I WANT is a lightweight distro that will serve as a host for Kodi and provide a few other services - BUT NOT a “full service” desktop computer with all the junk that comes along with it.
    I HAVE DECIDED that I prefer xfce as a DE.
    AND I think Arch Linux can provide a bare bones distro to suit my needs.
    Antergos is my first step into the Arch Linux Universe.
    I have installed it on a Dell Studio Hybrid, 64-bit, 4GB RAM PC.
    I have chosen xfce as DE - and so far I does everything I want (and more than I expected) from a DE.
    THE QUESTION I should have originally asked is this:
    How do I get back to having xfce show up when I fire up the Hybrid?

  • There are two “loaders” on ausual Linux system Bootloader to boot the System itself and the DM that loads your DE (XFCE, Kodi KDE GNOME, whatever) This DM; is LIGHTDM under Antergos standard installation…
    Usually you will boot to the DM and choose user + DE and give your password… then you login to XFCE if you choose this one, you can also logout from this DE Session back to the DM and choose a different DE Kodi Session maybe… So if you logout from Kodi instead of choosing reboot or power off you will come to Lightdm and can choose XFCE again, the last choosed DE will be stored for the next login…

    But if you choose autologin without a password on installation of Antergos, DM do not show up and system starts directly to DE (Kodi in Your Case).

    So to get away from autologin you need to edit the configuration file from your DM (Lightdm) as i discribed in my last post

    in /etc/lightdm/lightdm.conf change the line:
    to disabled:
    If you do not have a terminal inside Kodi you can press [Ctrl+Alt+F3] and will get a prompt where you give your username and password… then you can open this file by typing:

    sudo nano /etc/lightdm/lightdm.conf

    now search with the arrow keys to find the line

    change this to disabled with putting a #-sign in front of the line, it has to look likr this then:

    Now save the file by pressing [Ctrl+X]

    next bootup will bring you back to lightDM Loginscreen…

    type sudo reboot to reboot system…

    I followed your last set of instructions to the letter, and that was what it took to get it handled.
    Now, when I fire up the Hybrid, instead of loading directly into the xfce DE, I get a log-in page and a choice between loading into xfce or Kodi - AFTER I enter my password. Works for me.
    I appreciate it that you spelled it out IN DETAIL for this “newbie” on the steep edge of the Linux learning curve.
    I also appreciate it that you provided a bit of the underlying technical foundation to increase my understanding of how the different parts of the Arch Linux system fit/work together.
    When I was doing my background searches on Arch Linux I came across an article on the Lifehacker site that said that the Arch Linux support community had a reputation for being the best around. My experience with you confirms that observation.
    Thanks again,

  • Glad to help you!
    And we are warmly welcome rookies!

  • @monk13 welcome to Antergos 👍

    just wanted to let you know im a huge kodi user and my current setup i use openbox with antergos and its very lightweight. simply add kodi to the autostart config file and you are set.

  • Hey Megaman,
    Thanks for the suggestion. I took a look at openbox and what it does, and it appeals to me -but- I think it’s a bit early in my Arch education for me to take a run at that. But later on - for sure.
    My next little project is to get an Arch install on my R.PI 3B (alARM) to see if I can duplicate some of the Arch and Kodi services I have running on the old Dell Studio Hybrid.
    If I have any problems with that you’ll probably find me asking questions on some other Arch forum.
    I’m in - no question about that. And I think I’m only going to dig deeper as time goes on.
    I do feel welcome here - and I’m not much of a joiner - as my 'handle" indicates.

  • @monk13 yes i also have kodi on a raspberry using https://libreelec.tv runs great. i take it on road trips and amazing what you can do with a $25 device.


boots13 kodi7 directly1 Posts 10Views 1751
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.