• Issue with openvpn after suspend


    maybe someone know how to fix issue with openvpn after suspend? my openvpn start with system and works very good but when i use suspend after i back to computer vpn drop connection and cant reconnect i try this solution from wiki:
    https://wiki.archlinux.org/index.php/OpenVPN#Client_daemon_not_reconnecting_after_suspend

    but it dosent help i have in logs that after suspend there is a problem with auth probably user/password

    wrz 05 17:51:28 lenovo openvpn[11021]: VERIFY KU OK
    wrz 05 17:51:28 lenovo openvpn[11021]: Validating certificate extended key usage
    wrz 05 17:51:28 lenovo openvpn[11021]: ++ Certificate has EKU (str) TLS Web Server Authentication, expects TLS Web Server Authentication
    wrz 05 17:51:28 lenovo openvpn[11021]: VERIFY EKU OK
    wrz 05 17:51:28 lenovo openvpn[11021]: VERIFY OK: depth=0, CN=nl-117.protonvpn.com
    wrz 05 17:51:29 lenovo openvpn[11021]: Control Channel: TLSv1.2, cipher TLSv1.2 ECDHE-RSA-AES256-GCM-SHA384, 2048 bit RSA
    wrz 05 17:51:29 lenovo openvpn[11021]: [nl-117.protonvpn.com] Peer Connection Initiated with [AF_INET]89.39.107.190:1194
    wrz 05 17:51:30 lenovo openvpn[11021]: SENT CONTROL [nl-117.protonvpn.com]: 'PUSH_REQUEST' (status=1)
    wrz 05 17:51:30 lenovo openvpn[11021]: AUTH: Received control message: AUTH_FAILED
    wrz 05 17:51:30 lenovo openvpn[11021]: SIGTERM[soft,auth-failure] received, process exiting
    
  • @joksik split you post from old theme to make it more visible, no one will take a look to your issue inside an old theme…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • I always d/c the vpn before sleeping or shutting down – otherwise nm hangs and you get a “waiting on stop job” screen for 1.5 minutes.

    https://wiki.archlinux.org/index.php/OpenVPN#Client_daemon_not_reconnecting_after_suspend

    That simply kills openvpn on sleep and then restarts it without --config options…that would explain your auth failure? Just terminate (ctrl+c) and restart it manually after waking up. (:arrow_up: arrow in terminal works great to retrieve your recent command.)

Posts 3Views 90
Log in to reply