• Missing the NVidia xconfig program?


    Been bouncing around between Mint, Debian and Antergos. With Mint and Debian, I remember installing the proprietary Nvidia drivers and after that was done, there was an Nvidia Xconfig type program I could launch to see additional properties about my card. With Antergos, it doesn’t look like that program exists. It’s not in the ‘start’ menu. I’m using the proprietary driver:

    01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GK104 [GeForce GTX 670] [10de:1189] (rev a1)
    Subsystem: Gigabyte Technology Co., Ltd Device [1458:354b]
    Kernel driver in use: nvidia

    And when I launch ‘nvidia-xconfig’, I get:

    Using X configuration file: “/etc/X11/xorg.conf”.
    Backed up file ‘/etc/X11/xorg.conf’ as '/etc/X11/xorg.conf.backup’
    New X configuration file written to ‘/etc/X11/xorg.conf’

    So it looks like the program is maybe/sorta/kinda there? This is the program I’m trying to get to:

    0_1504535759182_nVidia-FreeBSD-Display-Driver-x86-x64_1.png

  • @RoadHazard
    sudo pacman -S nvidia-settings
    J.

  • You aren’t specify whether the hardware in use is a laptop or a desktop. It is not clear whether your system is an Optimus or not. The post is rather generic.

    If you’re on Optimus laptop, you’re lucky to NOT have nvidia-xconfig utility. Antergos cares about Optimus laptops users and doesn’t install it on Optimus. Read more here.

    On Optimus laptops Nvidia cards may be fine tuned as described here.

  • @RoadHazard said in Missing the NVidia xconfig program?:

    And when I launch ‘nvidia-xconfig’, I get:
    Using X configuration file: “/etc/X11/xorg.conf”.
    Backed up file ‘/etc/X11/xorg.conf’ as '/etc/X11/xorg.conf.backup’
    New X configuration file written to ‘/etc/X11/xorg.conf’

    nvidia-xconfig is a commandline tool to generate an xorg.conf file, but surely not usable for Archbased systems!

    what you are searching for is this what @Jeannie____ gives you already: nvidia-settings

    01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GK104 [GeForce GTX 670] [10de:1189] (rev a1)

    looks like a desktop Nvidia Card? should show GTX 670M on Notebooks?

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • @Jeannie____ Will give that a shot here in a bit and report back.

    @just Sorry, desktop computer. It’s a GTX 670.

    @joekamprad In the future, I’ll try to remember to provide more info about my configuration. Will try Jeannie’s suggestion in a little bit.

    Thanks everyone!

  • @RoadHazard said in Missing the NVidia xconfig program?:

    …@just Sorry, desktop computer. It’s a GTX 670…

    I’m sorry, can’t help with desktops. Had to deal wth them many years ago.

  • @Jeannie____ FTW! That was it, thanks!

  • If you want to have your nvidia settings loaded at startup, you can create a startup programme that calls
    nvidia-settings -l
    This will only load your nvidia settings without starting the gui.
    J.

missing28 nvidia111 xconfig1 Posts 8Views 285
Log in to reply