• Disabling touchpad while typing


    I’ve got a Lenovo y510p laptop and I’m trying to get the touchpad to disable while typing.

    I’ve tried the “syndaemon -i 0.5 -t -K -R -D” command that others have had some luck with but that doesn’t seem to do anything on my system.

    xinput shows:

    Virtual core pointer id=2 [master pointer (3)]
    ⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
    ⎜ ↳ SynPS/2 Synaptics TouchPad id=13 [slave pointer (2)]
    ⎣ Virtual core keyboard id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
    ↳ Ideapad extra buttons id=11 [slave keyboard (3)]
    ↳ Sleep Button id=8 [slave keyboard (3)]
    ↳ Video Bus id=9 [slave keyboard (3)]
    ↳ Power Button id=6 [slave keyboard (3)]
    ↳ AT Translated Set 2 keyboard id=12 [slave keyboard (3)]
    ↳ Lenovo EasyCamera id=10 [slave keyboard (3)]
    ↳ Power Button

    If I’m reading that right, it’s not detecting two different devices to confuse syndaemon.

    Any advice?

    Running Gnome as my DE if that matters.

  • @nerrollus , I have actually got divorced to Gnome, but I know there s an extension for that. The common problem with Gnome is that you have to rely on any extension s dev if te said extension is maintained and compatible with uour Gnome shell version.
    I post it here for you (I m not using Gnome so I cannot check if it is maitained/compatible, myself.

    https://extensions.gnome.org/extension/131/touchpad-indicator/

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 18.04 64bit Gnome
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • This syndaemon -i 0.5 -t -K -R -D may not work if you use libinput, I believe that is default with Antergos-Gnome.

    For libinput you can edit /etc/X11/xorg.conf.d/??-libinput.conf to something like this:

    Section "InputClass"
        Identifier "libinput touchpad catchall"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
        Option "DisableWhileTyping" "True"
    EndSection
    

    Backup these files before you edit.

    Edit:

    https://extensions.gnome.org/extension/131/touchpad-indicator/

    This seems like doesn’t have palm detection feature.

  • @psscnp142 said in Disabling touchpad while typing:

    This syndaemon -i 0.5 -t -K -R -D may not work if you use libinput, I believe that is default with Antergos-Gnome.

    For libinput you can edit /etc/X11/xorg.conf.d/??-libinput.conf to something like this:

    Section "InputClass"
        Identifier "libinput touchpad catchall"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
        Option "DisableWhileTyping" "True"
    EndSection
    

    Backup these files before you edit.

    Edit:

    https://extensions.gnome.org/extension/131/touchpad-indicator/

    This seems like doesn’t have palm detection feature.

    I don’t have a libconf file in that folder. I’ve got a 00-keyboard, 50-synaptics, and 99-killX. Should I create one?

    I tried that touchpad indicator, but it doesn’t have any kind of palm detection setting.

  • Then, you are simply using synaptics, it is fine.

    You can try syndaemon -i .5 -t -K -R -v (-v for verbose), it should give you some output like this:

    $ syndaemon -i .5 -t -K -R -v
    X RECORD extension version 1.13
    Disable
    Enable
    Disable
    Enable
    Disable
    Enable
    Disable
    Enable
    

    Every time you push a key in keyboard, it will say ‘disable’. And 0.5 secs after you finish typing, it will say enable. See if this works. By the way, there is no -D option.

touchpad45 typing2 disabling1 Posts 5Views 1038
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.