• Printing problem with a laptop


    Hello everyone, here’s my situation. I’m trying to connect to a printer (HP M1212nf MFP) from my laptop (Dell XPS 13) with Antergos on it.

    The HP printer work fine with my desktop (NUC with Antergos also) connect via USB. The desktop is connected to my router.

    I was able to install the printer on my laptop but when I tried to print the test page, nothing happens. I got the message: ''unable to locate printer ‘‘martin-pc-local’’.

    So don’t know where to go from there, any suggestions?

    Thanks,

    Martin

  • @mchenier1 how do you install the printer on laptop?
    For HP-Printers there is the installer from HP:

    sudo hp-setup -i
    

    from terminal works like a charm, also for network printers.
    Make shure that cups and avahi services are running, and you have hplip installed.

    systemctl status org.cups.cupsd.service
    systemctl status avahi-daemon.service
    

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • Thanks for the answer, but still no success. Cups and Avahi are running and here’s what I got with sudo hp-setup -i:

    I choose: 1 net Network/Ethernet/Wireless (direct connection or JetDirect)

    And the answer is : error: No device selected/specified or that supports this functionality

  • Only to make it clear to me:
    The printer is directly connected via Networkcable to the Router, or is connected only via USb onto a PC inside local network?

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • The printer is connected via USB onto a PC inside local network and I’m trying to connect this printer to my laptop.

  • Then you need to configer sharing option on then PC with Cups first…
    open http://localhost:631 on the PC:
    go to administartion and enable Share Printers connected to this system restart cups

    Press Button change settings on the same side…

    and see if you can reach the printer from laptop…

    You can alsao use system-config-printer if you are on a gtk alike DE…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • The printer was already shared0_1504124765183_Printer.png

  • Yes as far as i know this setup is a bit tricky, it needs a bit to get the printer detected, and for hp-setup, it is not working at all, you can do a trick and connect the printer via usb to your laptop, and after installation you can just change from usb to ip… with cups web-admin or system-config-printer

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • I just try to do this with my HP-Printer and it works…
    configure with USB plugged in and using hp-setup -i then using system config printer and press change device-URI > Networkprinter wait-wait-wait and it find the Printer… as Cups-Printer via DNS-SD

    at the client it shows up as Connection: ipp:// ip-adress-of-the-server :631/printers/ HP-Printername-at-the-server

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • @joekamprad

    Just did what you recommended but sill ‘‘can’t locate the printer’’

    Something strange, when I open Cups it sees the Printer and the Fax related to my printer (Multifunction printer), but when I open the Hp device manager, it sees only the fax, no printer is installed…2_1504134853226_Capture du 2017-08-30 18-48-46.png 1_1504134853226_Capture du 2017-08-30 18-49-47.png 0_1504134853225_Capture du 2017-08-30 19-05-13.png

  • try modify the printer uri to what i give you the uri you have looks a bit “silly”

    ipp:// ip-adress-of-the-server :631/printers/ HP-Printername-at-the-server

    0_1504135455961_Bildschirmfoto vom 2017-08-31 01-23-41.png

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • Wich part of this URL that is not ‘‘silly’’?
    What is ipp:// ip-adress-of-the-server :631/printers/ HP-Printername-at-the-server

    I mean, the value of ipp:// is in the ‘‘silly’’ URL?

  • @judd Thanks for this answer, I looked at that thread but doesn’t represent my problem, Hp set-up ‘‘work’’ for me, it did install the right printer when I plugged my laptop with USB, my problem is the printer doesn’t work when the laptop is not plugged in the printer.

  • @mchenier1 said in Printing problem with a laptop:

    Wich part of this URL that is not ‘‘silly’’?
    What is ipp:// ip-adress-of-the-server :631/printers/ HP-Printername-at-the-server

    I mean, the value of ipp:// is in the ‘‘silly’’ URL?

    I do not know, as it is not shown complete…

    ip-adress-of-the-server should be replaced with the IP of your PC and HP-Printername-at-the-server with the name you have for the printer at the PC.

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • The full URL is:

    dnssd://Hewlett-Packard%20HP%20LaserJet%20Professional%20M1212nf%20MFP%20%40%20martin-p._ipp._tcp.local/cups?uuid=97dcb99b-01d9-3f34-70ba-918501172f40

    The IP address of my PC is 192.168.1.14

    And the printer address on my PC is : hp:/usb/HP_LaserJet_Professional_M1212nf_MFP?serial=000000000QJ70D5KPR1a

    This means that I should put : ipp:// 192.168.1.14 :631/printers/ hp:/usb/HP_LaserJet_Professional_M1212nf_MFP?serial=000000000QJ70D5KPR1a

    ??

  • @mchenier1 said in Printing problem with a laptop:
    ipp://192.168.1.14 :631/printers/HP_LaserJet_Professional_M1212nf_MFP

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • There is something wrong with this address.0_1504140665703_Capture du 2017-08-30 20-49-52.png

  • yes you have a space between 14 and : sorry…

    ipp://192.168.1.14:631/printers/HP_LaserJet_Professional_M1212nf_MFP

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • Well, it didn’t do it. The IP address seem working but it still didn’t resolve the problem.2_1504141732277_Capture du 2017-08-30 21-06-41.png 1_1504141732277_Capture du 2017-08-30 21-00-53.png 0_1504141732277_Capture du 2017-08-30 21-00-21.png

laptop35 printing5 Posts 32Views 835
Log in to reply