• Sound coming out of earphones, not speakers?


    Hi!

    This is my first time experimenting with Antergos, I used to use Ubuntu before.

    I have a strange bug. Usually speakers work well and issues happen with earphones but now it’s the opposite. I have no sound in speakers but when I plug my earphones in, they work fine.

    Stranger than that, the only audio output on my system is for the headphones. (I took a screenshot but I don’t have enough privilege to upload it so you’ll have to take my word for it).

    I haven’t found an answer yet (as it’s usually the opposite that happens).

    What can I do?

    I also noticed that, in Volume Control the Speakers are listed as “Speakers (Unavailable)”.

    The system was installed this morning and uses pulseaudio (I haven’t installed anything else).

    Thanks!

  • @dlalonde
    First check that no output channels for your sound card are muted with alsamixer. https://wiki.archlinux.org/index.php/Advanced_Linux_Sound_Architecture

    $ alsamixer
    
  • @triode13 said in Sound coming out of earphones, not speakers?:

    @dlalonde
    First check that no output channels for your sound card are muted with alsamixer. https://wiki.archlinux.org/index.php/Advanced_Linux_Sound_Architecture

    $ alsamixer
    

    There were some that were muted but I unmuted and rebooted and it’s still not working. I also tried to change default soundcard using asoundconf-gtk (there’s an HDMI one on my system as well) but that didn’t work either.

  • @dlalonde open alsamixer from terminal and unmute speaker channel will help, after this you can type:

    sudo alsactl store
    

    to save this settings.

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @joekamprad said in Sound coming out of earphones, not speakers?:

    @dlalonde open alsamixer from terminal and unmute speaker channel will help, after this you can type:

    sudo alsactl store
    

    to save this settings.

    Thank worked! Thanks a lot! 🙂

  • I had exactly the same problem, it seems the channels twisted, at least somewhere in the automatic presets.
    I have this for month… and try a lot of things with pulseaudio till i go back to what i would have tried in times prior pulseaudio 😉

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @joekamprad said in Sound coming out of earphones, not speakers?:

    I had exactly the same problem, it seems the channels twisted, at least somewhere in the automatic presets.
    I have this for month… and try a lot of things with pulseaudio till i go back to what i would have tried in times prior pulseaudio 😉

    Ha ha! It’s a bit confusing that some channels would be muted by default. Thanks for sharing your solutions! 😄

Posts 7Views 677
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.