• Bind "Show All Applications" to Super/Windows Key only? (Start Menu)


    Pressing the Super key (otherwise known as the Windows key) shows all my current running apps.

    The way to get the All Applications menu open is Super + A.

    How do I switch these two keybinds? I can’t register a single-key shortcut in Antergos’ general settings. I’m on the GNOME desktop.

    bababooey

  • @RobotUnderscore said in Tie "Show All Applications" to Windows/Super Key only? (Start Menu):

    single-key

    only works if that key is not used for another one.
    0_1503584472517_Bildschirmfoto vom 2017-08-24 16-21-01.png

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • @joekamprad said in Tie "Show All Applications" to Windows/Super Key only? (Start Menu):

    only works if that key is not used for another one.

    That’s the problem. The keyboard shortcut for the Show All Windows shortcut is not listed in the keyboard settings, not the one that uses just the Super key anyway. There’s no way for me to change it so I can set the Show All Applications shortcut to Super.

    bababooey

  • http://i.imgur.com/HZGjpVk.png

    I actually found it in the Keyboard settings but it has Alt + F1 as the shortcut, not Super. Both keyboard shortcuts show all windows.

    Changing the Alt + F1 shortcut doesn’t let me set Show All Applications to Super…

    Still stuck but at least that’s some progress…

    bababooey

  • http://i.imgur.com/9H9vJ8G.png

    Getting warmer! I scoured dconf-editor and found the option to override the Show All Applications control!

    Under /org/gnome/shell/keybindings, set toggle-application-view to [’<Super>’].

    Now it’s just a matter of finding and disabling the shortcut that opens the pesky Activities menu…

    bababooey

  • good job!

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • Is there a terminal command for the Activities menu? I want to see if I can override its current shortcut by assigning a custom one in the Keyboard section of Antergos’ general settings.

    bababooey

  • Okay this is ridiculously difficult, but it’s clear this is a GNOME issue and not specifically a problem with Antergos.

    I disabled the Activities keybinding (in dconf-editor go to /org/gnome/mutter and change overlay-key to anything but Super_L) but now Super and Super+A both do nothing.

    I’m gonna ask this question on the Unix & Linux StackExchange and see what happens.

    bababooey

  • @Noctem yes better to take a look to extensions before tinkering to much into Dark-GNOME-intestines ;)

    https://extensions.gnome.org/

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • You are almost there. Now install ksuperkey. Have it autostart in your gnome session. This utility redirects the super key. By default, it maps to Alt+F1. It will probably be easiest if you just map /org/gnome/shell/keybindings/toggle-application-view from ‘<super>a’ to ‘<alt>F1’>.

    In summary

    • have ksuperkey start through autostart
      ksuperkey
    • Reset the overlay-key (<super>) to nothing:
      gsettings set org.gnome.mutter overlay-key ‘’
    • Reset the main panel key (<Alt>F1) to nothing
      gsettings set org.gnome.desktop.wm.keybindings panel-main-menu []
    • Change toggle application view from [’<Super>a’] to [’<Alt>F1’]

    This works. I had the launcher Albert bound to my super key for a while.

    If you do not want to loose the Super+a binding, you could directly have ksuperkey redirect the super key to Super+a. Not sure of the syntax required nor of whether it will work.

  • Thanks for all the help everyone, although @Noctem’s answer is the winner here.

    I went back and set all the stuff I messed around in dconf-editor back to their defaults before installing this plugin and it works like a charm.

    Hopefully the extension will be maintained for a while…

    (NOTE: For anyone using a browser that isn’t Chrome that keeps getting this “missing connector” error on the webpage after installing an extension: http://i.imgur.com/30iFKwm.png, you’re supposed to do sudo pacman -S chrome-gnome-shell. I know it has chrome in the name but it’s the “connector” that the error refers to. It works for all browsers so it just has a misleading name.)

    bababooey

  • I start making a Gnome Howto here:

    https://antergos.com/wiki/desktops/gnome/gnome-desktop-environment/

    adding the extension already there!

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • @RobotUnderscore Glad to be of help! GNOME can be tricky, but the extensions help a lot.

Posts 14Views 321
Log in to reply