• google chrome default browser


    Every time I open google chrome I’m getting following notification
    0_1503492385048_Selection_001.png
    After clicking Set as default next time I open browser it is displayed again
    How can I help chrome to understand that it is already default browser

    I have noticed strange behavior.
    When I modify .config/mimeapps.list and open chrome with clicking set by default content of this file is always reset to

    [Default Applications]
    text/html=firefox.desktop
    

    Some additional helpful information:

    ┌─[dzirt][DzirT-LT][~]
    └─▪ xdg-open http://google.com
    
    ┌─[dzirt][DzirT-LT][~]
    └─▪ xdg-open http://google.com
    Google chrome starting
    [8541:8596:0823/154853.443157:ERROR:browser_gpu_channel_host_factory.cc(103)] Failed to launch GPU process.
    Created new window in existing browser session.
    
    ┌─[dzirt][DzirT-LT][~]
    └─▪ cat .config/mimeapps.list 
    
    [Default Applications]
    text/html=firefox.desktop
    
    
  • Do you change default browser inside settings?
    0_1503493431938_Bildschirmfoto vom 2017-08-23 15-03-37.png

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • Yes, I’ve played with this window

    0_1503493695132_Default Applications — System Settings Module_002.png

  • what gives you:

    cat /etc/environment
    
    cat /etc/profile
    
    env|grep BROWSER
    

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • ┌─[dzirt][DzirT-LT][~]
    └─▪ cat /etc/environment
    #
    # This file is parsed by pam_env module
    #
    # Syntax: simple "KEY=VAL" pairs on separate lines
    #
    # >>> BEGIN ADDED BY CNCHI INSTALLER
    BROWSER=/usr/bin/chromium
    EDITOR=/usr/bin/nano
    # <<< END ADDED BY CNCHI INSTALLER
    
    ┌─[dzirt][DzirT-LT][~]
    └─▪ cat /etc/profile
    # /etc/profile
    
    #Set our umask
    umask 022
    
    # Set our default path
    PATH="/usr/local/sbin:/usr/local/bin:/usr/bin"
    export PATH
    
    # Load profiles from /etc/profile.d
    if test -d /etc/profile.d/; then
    	for profile in /etc/profile.d/*.sh; do
    		test -r "$profile" && . "$profile"
    	done
    	unset profile
    fi
    
    # Source global bash config
    if test "$PS1" && test "$BASH" && test -z ${POSIXLY_CORRECT+x} && test -r /etc/bash.bashrc; then
    	. /etc/bash.bashrc
    fi
    
    # Termcap is outdated, old, and crusty, kill it.
    unset TERMCAP
    
    # Man is much better than us at figuring this out
    unset MANPATH
    
    export SSH_ASKPASS="/usr/bin/ksshaskpass"
    
    ┌─[dzirt][DzirT-LT][~]
    └─▪ env|grep BROWSER
    BROWSER=/usr/bin/chromium
    
  • @TaurohtaR What do you want to do, exactly?

    • Chrome is already set and work as a default broser, and all you want to do is to get rid of annoyng “Set as default” request
    • set a different default browser
  • @just
    I want to get rid of that annoying “Set as default”.
    But I think it is possible if I really set it as default in all places where chrome is reading this information

  • @TaurohtaR said in google chrome default browser:

    I want to get rid of that annoying “Set as default”.

    Ok, it’s clear now.

    But I think it is possible if I really set it as default in all places where chrome is reading this information

    Yes, it is possible - theorically. Practically, and for unknown reason, it’s not an easy job. One time it didn’t work for me too, and a spent a day trying to fix it, without getting a result.

    I use Chromium, but it should work exactly the same way also for Chrome. The workaround consists in removing Chromium’s check whether it is set as a default browser. Clearly, it makes sense only if Chromium already works as a default browser.

    Modify menu entriy and .desktop files, which invoke Chromium. Add the –no-default-browser-check parameter to the command.

    For menu entry, change the command from

    chromium %U
    

    to

    chromium --no-default-browser-check %U
    

    For /usr/share/applications/Chromium.desktop, change the Exec= line from

    Exec=chromium %U
    

    to

    Exec=chromium --no-default-browser-check %U
    

    But now Chromium works as a default browser and without repeating “Set as default” request without all these tricks.

  • @just
    Thanks, the trick with modification of launchers with --no-default-browser-check helped.
    But I think it will be reset on next chrome update.
    Sure, I’ll create script to replace execution command but it would be nice have some more persistent solution to this problem.

Posts 9Views 192
Log in to reply