• Random keystrokes happening


    My problem has been happening on all linux distros, so far, but currently I’m using Antergos, since it’s the one that suits me the best.
    I started noticing the problem while scrolling on a code on the text editor, while scrolling the text editor started to zoom in and out, then I noticed while using the web browser that while typing some shortcuts activated, like those to save the page, to open the browsing history and such stuff. So, the problem seems to happen with the Ctrl and Alt keys, I’m using a laptop, and It is not a hardware problem, since I tried running windows, and the problem didn’t even happen.
    I think it’s related to the trackpad on the laptop, probably some conflict with the gestures, and it thinks it must send those keystrokes. Thanks to anyone willing to help.

    **Edit 1: @Keegan
    I’m currently using Gnome3

    **Edit 2: @bpoerwo
    The hardware I’m currently using is a laptop hp 14 ab-110la, which has an apu amd A10 with a graphic procesor amd R7 360m, 8gb ram.

  • Hi there and welcome to the Antergos community:grinning:.

    I don’t know how much I can really help you solve this issue, but it might be helpful for others to know what DE you’re using. I think they all handle gestures and trackpads differently ;).

    Keep trying, never give up. In the end, you will find that it was all worth it

    Community ISO: https://antergoscommunityeditions.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • @Crashk
    Does the problem exist if you disable the trackpad?

  • Have you tried slowing down the cursor speed? I know it sounds silly, but my father’s old laptop had the same problem and after adjusting the speed ( you must experiment with the setting, it might not work the first time) the problem was gone.

    Thinkpad E570 Intel core i5 (Kaby lake)
    8 GB RAM
    256 GB SSD + 1 TB HDD
    Intel HD Graphics

  • Thanks for replying.
    @manuel I tried by disabling the touch pad, and the problem persisted.
    @bpoerwo Also tried by varying the speed, but the problem was still present.

    Not sure about what to do now. Can’t even write code without the problem happening.

  • Do you, by chance, have a usb hub or wireless mouse connected to your computer?

    Thinkpad E570 Intel core i5 (Kaby lake)
    8 GB RAM
    256 GB SSD + 1 TB HDD
    Intel HD Graphics

  • Nothing at all, not even a secondary keyboard, since the majority of the time I work at a cafe, I can’t carry my keyboard, nor my mouse.

  • What hardware are you using?

    Thinkpad E570 Intel core i5 (Kaby lake)
    8 GB RAM
    256 GB SSD + 1 TB HDD
    Intel HD Graphics

  • Try it with disabling natural scrolling (I don’t know if it’s the correct English term, but it’s the one that comes after enabling/disabling touchpad)

    Thinkpad E570 Intel core i5 (Kaby lake)
    8 GB RAM
    256 GB SSD + 1 TB HDD
    Intel HD Graphics

  • Did you already try the mouse & touchpad settings:

    • disable while writing
    • disable scrolling
    • disable touchpad for clicking

    (The translations above may be incorrect since I don’t have English system.)

  • I tried all the options mentioned @manuel , but the problem persists, although, the problem is not only related to scrolling, it’s related to the use of the power keys (alt, ctrl, shift), although, with shift is almost unnoticeable.

  • @Crashk said

    My problem has been happening on all linux distros, so far

    Hi! Do you also have windows on your machine? If , yes, do you get the same behavor?
    To eliminate the posibility that the problem lies with your keyboard. Can you connect an external one and see if the issue persists?

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • I used to have windows while using ubuntu, and the problem didn’t happen over there, while it was happening on ubuntu.
    I tried using 2 external keyboards, a membrane one, and a mechanical one. The problem persisted.

  • @Crashk problem can be the Touchpad, if it is a HP Imagepad with Multigesture Support?
    Same like this one inside HP Chromebooks?

    sensitivity configuration should be a problem…https://wiki.archlinux.org/index.php/HP_Chromebook_14#/search
    To see if this is true you can provide hardware information like this:

    lspci > log.txt && lsusb >> log.txt && dmesg >> log.txt && cat log.txt | curl -F [email protected] https://ptpb.pw/?u=1
    

    and give us the link it put out for the pastebin…

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • It is indeed an HP, but it’s not a chromebook. The trackpad does support multi-gestures.

    I did as you said, and this is the result:
    https://ptpb.pw/0bhD

    Thanks for replying.

  • @Crashk
    I’m not an expert on these, but noticed the following problem:

    [ 11.762981] psmouse serio1: synaptics: Your touchpad (PNP: SYN1ef0 PNP0f13) says it can support a different bus. If i2c-hid and hid-rmi are not used, you might want to try setting psmouse.synaptics_intertouch to 1 and report this to [email protected].

    Maybe that gives you something to work on.

  • Hi,
    To everyone.

    This post is quite old, but I found a way to fix the problem after trying for a while.

    I will describe the problem itself, so maybe it will help other people with the same problem.

    I started noticing the problem while using text editors, all of the sudden Zoom was happening while scrolling, and Key Function actions where happening, like if I was pressing the ctrl or alt key, it was getting really frustrating cause I wasn’t able to work as fast as I would normally do.

    The problem happened on an HP Notebook, referenced as HP 15 ab-110la, but the problem can happen on certain computers that have a chip related to the i8042 controller.

    To fix it, I tried a bunch of stuff by reading the documentation, and as you can see, took me about a month of pure reading.

    Finally, after getting to understand the way the laptop’s keyboard interacts with the trackpad, I discovered that on certain models, the chip mentioned above, tries to update the status from the keyboard, so, I found out a way to avoid the system from trying to modify the keyboard status.

    If you have the same problem, all you have to do is this:

    Open a terminal and execute

    sudo gedit /etc/default/grub
    

    We use the sudo command because we need to save what we edit.

    Once in there, you will see a line that says something like

    GRUB_CMDLINE_LINUX_DEFAULT="quiet iommu=soft resume=UUID=7f3b359d-7d89-4b38-8dd7-03376b86d986"
    

    Or something similar, at the end of that specific line, add the following

    i8042.dumbkbd=1
    

    a function from the i8042 controller that -As said by the i8042.c file-

    static bool i8042_dumbkbd;
    module_param_named(dumbkbd, i8042_dumbkbd, bool, 0);
    MODULE_PARM_DESC(dumbkbd, "Pretend that controller can only read data from keyboard");
    

    that being said, what the function does, is to force the controller to only read what the keyboard sends, and not try to update the keyboard status itself, the bad side to it is that now, none of the signal LEDs work, so, if you turn the caps lock and it has a LED, you won’t be able to see it.

    Anyways,

    Now, save the document you just edited, and run the following command

    sudo grub-mkconfig -o /boot/grub/grub.cfg
    

    what this does, is generate a new grub.cfg file, so the boot parameters will work from start.

    I hope this helps anyone with the same problem.

  • @Crashk
    Now that’s some nice work you’ve made!
    Actually I’ve had a similar problem with my laptop but gave up all hope long time ago…
    Testing your solution as we speek. So far so good. I’ll report here of any findings.
    Thanks!

    EDIT:
    by the way, adding kernel parameters to grub can be made slightly easier by writing a new file /boot/grub/custom.cfg. There you can put grub entries, and modify them any time later. When you have created or modified that file, the good part is that you don’t have to run grub-mkconfig at all, and you don’t have to modify /etc/default/grub.
    Example:

    menuentry "Antergos LTS kernel" {
      set kernel=linux-lts
      set label=Antergos    # partition identified by a LABEL
      savedefault
      linux /boot/vmlinuz-"$kernel" root=LABEL="$label" rw quiet i8042.dumbkbd=1
      initrd /boot/intel-ucode.img /boot/initramfs-"$kernel".img
    }
    
    

    Note the i8042 parameter in the end of the “linux” line.

    EDIT2:
    Now I’ve tested it for a while, and it seems to have fixed those laptop problems while editing text. So thanks a lot @Crashk!

  • This seems like sonething that should be put on the wiki if anyone has time! It could saeve many a future user:grinning:.

    Keep trying, never give up. In the end, you will find that it was all worth it

    Community ISO: https://antergoscommunityeditions.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

Posts 19Views 614
Log in to reply