• Black screen after boot into live system :(


    System-Information:
    GPU: GPU: GeForce GTX 1060 6GB
    CPU: Intel Core i5-7600K CPU @ 3.8GHz
    RAM: 16GB

    Hey everyone,
    I’m new at antergos (but use already linux since 4 months) and would install antergos between Windows 10. I created an boot stick with the ISO, after that I rebooted my computer and booted (EFI-Mode) from the usb. I choosed the first option and pressed ENTER.

    — What I do —
    It show’s me first the kernel output (with out any error message) and after that the GNOME desktop. But after 1-2 seconds it turned to black, and turned on (I can only see the mouse for 3 sec.) and this keep repeating.
    I have try to go to session 2 (Strg+Alt+2) and pressed ENTER in the login promt, after that I returned to session(Strg+Alt+7) and can see the login manager from antergos, I clicked on the time to login and BOOM black screen.

    — What I try to fix it —
    I booted again from usb and choosed “Antergos x64_86 (Nvidia Fallback)” (or so) BUT I get an error message that he can’t the linux kernel and a other file :c

    Can somebody help me to fix this problem?
    Thanks for reading :penguin:
    – Mondei1

  • @Mondei1 said in Black screen after boot into live system :(:

    GeForce GTX 1060 6GB

    If this is a dedicated card you should read here:
    https://antergos.com/wiki/uncategorized/install-from-newest-nvidia-card/#Use_the_nvidia_enabled_installer_ISO

    And welcome a board!

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • @Mondei1 Your problem is due to the fact that the graphics controller drivers are not working properly when starting up (and probably some other drivers). To solve this problem at the start-up, you must force the system to not check the memory, it’s a common issue on linux-distros, particularly on those that have somewhat-new kernels. Anyways.
    To the issue, the best thing to do is to add

    iommu-soft
    

    to the grub parameters, since it’s gonna be hard to do it inside (because yours doesn’t boot) we’ll do it by as soon as the antergos grub starts -the place that allows you to pick the options to start up- press e and search until you find something that says

    quiet **UUID=//some stuff
    

    I don’t quite remember everything, but search for the “quiet” part, then, insert “iommu=soft” in between, like this

    quiet iommu=soft **UUID=//some stuff
    

    This is gonna force the system to startup without checking for the drivers, or at least it seams like so.

    after that, press ctrl+x, and it should boot up.
    Now, we need to fix the issue, so that it doesn’t happen again.
    To do so, you need to go to

    /etc/default
    

    and edit the file called grub

    You’ll find a line that says:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet resume=UUID=7f3b359d-7d89-4b38-8dd7-03376b86d986"
    

    Here, we’ll do the same as we did on the startup part, adding the iommu thing, like this

    GRUB_CMDLINE_LINUX_DEFAULT="quiet iommu=soft resume=UUID=7f3b359d-7d89-4b38-8dd7-03376b86d986"
    

    Save the changes, and now, we need to generate a new grub config file, to do so, run the next code:

    sudo grub-mkconfig -o /boot/grub/grub.cfg
    

    And that should do it. After that, just install whichever drivers you need.

    Hope that helps, if you need something else, I’ll try to help with all I know.

  • @Crashk user try to start the Installer Iso, and due the fact that his graphic card: GeForce GTX 1060 can not start with the nouveau driver, the only suitable on the standard ISO imho, the only way to get the Installer Liveenvironment getting started is to use an ISO with nvidia drivers on it.

    Unfortunately the latest NVIDIA cards are not supported by the opensource drivers yet as the developers don’t have access to the data they need to implement support. However, there appears to be a workaround for now.

    So as i think iommu=soft option does not help here, as it does not help making nouveau driver work for a GTX 1060 card, or i am wrong and this is a option here???

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • @joekamprad I have try the ISO and get the following error:

    Failed to start loader.efi: (14) Not Found
    

    I get this error on the normal ISO by entering the “NVIDIA Fallback” too.

  • do you disabling secure boot option in UEFI (BIOS) ?

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • I recently installed an Antegros Nvidia iso on my new Laptop ( i7-7700, GTX 1060) I disabled hybrid graphics and uefi boot in the uefi/bios settings before installing. Everything worked without major problems.
    J.

  • @Jeannie____ Thanks!

    @Mondei1 this error is may caused by EFI-Bios settings, not working USB-ISO or misunderstanding between Efi and the usb-iso…

    Misunderstanding can be that EFI identify the ISO-USB-Installer as a CD/DVD and so it can not boot properly, you can try to choose “boot from CD/DVD/usb-cd” in EFI-Bios…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • You could…

    Take out your Nvidia Card.
    Install antergos
    then install nvidia and lib32-nvidia-utils for steam.

    sudo pacman -S nvidia lib32-nvidia-utils
    

    Turn off, insert the card, voila…

    I make things work…
    My humble wiki: https://anotherlinux.com/

  • @izznogooood
    That would only work on desktop machines.
    But nevertheless, there is the Antergos Nvidia Iso, that works well.
    J.

  • @joekamprad I have looked into my UEFI settings under “Boot” and there wasn’t a secure boot option. Proof

  • @Mondei1 looks like it is disabled by default on your board…

    https://forum-en.msi.com/index.php?topic=272698.0

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • But as i can see here:
    0_1503603115371_Bildschirmfoto vom 2017-08-24 21-31-36.png
    There is an Bios update for your Board ;)

    Version
    7977v1E
    Erscheinungsdatum
    2017-05-16
    Dateigröße
    7.3 MB
    

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • @joekamprad Nice. I think I will use my computer over the integrated graphics card. (Intel Graphics)
    Install Antergos with it, install the nvidia drivers and put the DVI cable back to my Nvidia card ^^.

    That’s the plan now. I think I will do it at weekend.

  • Hope this will work for you!

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

black40 system60 live34 boot159 Posts 15Views 350
Log in to reply