• One jack headset not working as intended in Linux


    I have a laptop with one jack and I have IEMs with one jack, I can use both the speakers and the microphone thanks to Realtek HD Audio in Windows.

    In Linux, however, I cannot use the microphone of my IEMs. Are there any packages that I can install that could help me, or is this impossible on Linux?

    (I don’t know if this should go on Multimedia and Gaming or Kernel & Hardware, so I’ll just put it here.)

  • it is multimedia so right place…

    Realtek HD Audio is not enough info here:
    https://antergos.com/wiki/hardware/getting-informations-on-soundproblems/

    pactl list sinks
    
    wget http://www.alsa-project.org/alsa-info.sh && sh alsa-info.sh
    

    This will give you a link with pasted advanced informations.

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • @ensarkilincxo said in One jack headset not working as intended in Linux:

    I can use both the speakers and the microphone thanks to Realtek HD Audio.

    (I meant on Windows)

    Sink #1
    State: SUSPENDED
    Name: alsa_output.pci-0000_00_1b.0.analog-stereo
    Description: Built-in Audio Analog Stereo
    Driver: module-alsa-card.c
    Sample Specification: s16le 2ch 44100Hz
    Channel Map: front-left,front-right
    Owner Module: 7
    Mute: no
    Volume: front-left: 65536 / 100% / 0.00 dB,   front-right: 65536 / 100% / 0.00 dB
            balance 0.00
    Base Volume: 65536 / 100% / 0.00 dB
    Monitor Source: alsa_output.pci-0000_00_1b.0.analog-stereo.monitor
    Latency: 0 usec, configured 0 usec
    Flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY 
    Properties:
    	alsa.resolution_bits = "16"
    	device.api = "alsa"
    	device.class = "sound"
    	alsa.class = "generic"
    	alsa.subclass = "generic-mix"
    	alsa.name = "ALC3236 Analog"
    	alsa.id = "ALC3236 Analog"
    	alsa.subdevice = "0"
    	alsa.subdevice_name = "subdevice #0"
    	alsa.device = "0"
    	alsa.card = "1"
    	alsa.card_name = "HDA Intel PCH"
    	alsa.long_card_name = "HDA Intel PCH at 0x9b318000 irq 51"
    	alsa.driver_name = "snd_hda_intel"
    	device.bus_path = "pci-0000:00:1b.0"
    	sysfs.path = "/devices/pci0000:00/0000:00:1b.0/sound/card1"
    	device.bus = "pci"
    	device.vendor.id = "8086"
    	device.vendor.name = "Intel Corporation"
    	device.product.id = "9ca0"
    	device.product.name = "Wildcat Point-LP High Definition Audio Controller"
    	device.form_factor = "internal"
    	device.string = "front:1"
    	device.buffering.buffer_size = "352800"
    	device.buffering.fragment_size = "176400"
    	device.access_mode = "mmap+timer"
    	device.profile.name = "analog-stereo"
    	device.profile.description = "Analog Stereo"
    	device.description = "Built-in Audio Analog Stereo"
    	alsa.mixer_name = "Realtek ALC3236"
    	alsa.components = "HDA:10ec0233,104319ad,00100003"
    	module-udev-detect.discovered = "1"
    	device.icon_name = "audio-card-pci"
    Ports:
    	analog-output-speaker: Speakers (priority: 10000, not available)
    	analog-output-headphones: Headphones (priority: 9000, available)
    Active Port: analog-output-headphones
    Formats:
    	pcm
    

    (I deleted Sink #0 because it’s just my monitor.)

    http://www.alsa-project.org/db/?f=4999d6150d42127408543166032e28c802db3579

  • @ensarkilincxo

    Simple mixer control ‘Mic’,0
    Capabilities: pvolume pswitch
    Playback channels: Front Left - Front Right
    Limits: Playback 0 - 31
    Mono:
    Front Left: Playback 0 [0%] [-34.50dB] [off]
    Front Right: Playback 0 [0%] [-34.50dB] [off]
    Simple mixer control ‘Mic Boost’,0
    Capabilities: volume
    Playback channels: Front Left - Front Right
    Capture channels: Front Left - Front Right
    Limits: 0 - 3
    Front Left: 0 [0%] [0.00dB]
    Front Right: 0 [0%] [0.00dB]

    Oh i was on the wrong boat here…

    You want to use mic from headset?
    can you try open alsamixer inside terminal, press [F6] choose your card and unmute [M] the mic, and play with mic boost also.

    https://youtu.be/LAspViAl9Hs

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • Well, it still uses the laptop’s integrated microphone :P
    I don’t think I will ever find a way to use the headset’s microphone in Linux. I have been waiting for years for the feature and finally decided to ask about it. Doesn’t seem like I’m going to have any luck with this though.

  • do you try pavucontrol to enable the right mic?
    and possible to use paprefs to enable multicast ?

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • The other recording devices on pavucontrol do nothing.
    Tried a few combinations in paprefs, also to no avail.

  • can you give me the exact model of your notebook?

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • @joekamprad said in One jack headset not working as intended in Linux:

    can you give me the exact model of your notebook?

    ASUS X555LB (I actually have an ASUS K555LB which is a slightly downgraded version (1366x766 display instead of 1920x1080, the outer shell’s design is less attractive). But Windows and Linux recognize it as an ASUS X555LB as it uses the X555LB board. So, let’s go with that, I guess.)

  • @ensarkilincxo said in One jack headset not working as intended in Linux:

    ASUS X555LB

    sudo nano /etc/modprobe.d/snd-hda-intel.conf
    

    and add the following line:

    options snd-hda-intel index=0 model=laptop-dmic
    

    save with [ctrl+X] and reboot

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • Still the same, uses the notebook’s integrated microphone.

Posts 11Views 237
Log in to reply