• Steam Multilib Issues


    Hi all,

    I’m having an issue with “Error: You are missing the following 32-bit libraries, and Steam may not run: libc.so.6” when running Steam.

    I have gone through the relevant sections of the Arch Steam Installation and Troubleshooting wikis, as well as a bit of other faffing. From what I can see the packages are there and installed in /usr/lib32, but the problem lies in the linking.

    Examining the steam executable in ~/.local/share/Steam/ubuntu12_32 has shown some odd things.

    file steam
    

    returns:

    steam: ELF 32-bit LSB shared object, Intel 80386, version 1 (SYSV), dynamically linked, interpreter /lib/ld-linux.so.2, for GNU/Linux 2.6.24, BuildID[sha1]=63f8ea4d3536d0ba5abd1b0c2e215b860032e000, not stripped
    

    while

    ldd steam
    

    returns:

    
    /usr/bin/ldd: line 117: ./steam: No such file or directory
    

    As far as I’m aware (and can achieve on another of my Antergos systems), that command should return something like this:

    linux-gate.so.1 (0xf7765000)
    	libX11.so.6 => /usr/lib32/libX11.so.6 (0xf75da000)
    	librt.so.1 => /usr/lib32/librt.so.1 (0xf75d1000)
    	libdl.so.2 => /usr/lib32/libdl.so.2 (0xf75cc000)
    	libstdc++.so.6 => /usr/lib32/libstdc++.so.6 (0xf7448000)
    	libpthread.so.0 => /usr/lib32/libpthread.so.0 (0xf742a000)
    	libm.so.6 => /usr/lib32/libm.so.6 (0xf73ce000)
    	libc.so.6 => /usr/lib32/libc.so.6 (0xf720f000)
    	libxcb.so.1 => /usr/lib32/libxcb.so.1 (0xf71e4000)
    	/lib/ld-linux.so.2 (0xf7767000)
    	libgcc_s.so.1 => /usr/lib32/libgcc_s.so.1 (0xf71c8000)
    	libXau.so.6 => /usr/lib32/libXau.so.6 (0xf71c4000)
    	libXdmcp.so.6 => /usr/lib32/libXdmcp.so.6 (0xf71bb000)
    

    I did notice that in the return of the file command there is a pointer to /lib/ld-linux.so.2, however on this install /lib does not contain anything but a few directories, certainly no actual libraries. Is this an issue with a missing symlink? I’m reluctant to start sporadically symlink system directories so I figured I would ask first.

    As far as I can see the dynamic linking isn’t properly pointing Steam to the installed 32-bit libraries.

    Any help on this would be greatly appreciated.

  • You failed to post the crucial thing. What actually happens when you try to start steam? From a terminal …

    I make things work…
    My humble wiki: https://anotherlinux.com/

  • Yes, of course!

    [email protected] ~> steam
    /home/tom/.local/share/Steam/steam.sh: line 154: VERSION_ID: unbound variable
    /home/tom/.local/share/Steam/steam.sh: line 154: VERSION_ID: unbound variable
    Running Steam on antergos  64-bit
    /home/tom/.local/share/Steam/steam.sh: line 154: VERSION_ID: unbound variable
    STEAM_RUNTIME is enabled automatically
    Error: You are missing the following 32-bit libraries, and Steam may not run:
    libc.so.6
    /home/tom/.local/share/Steam/steam.sh: line 712: /home/tom/.local/share/Steam/ubuntu12_32/steam: No such file or directory
    /home/tom/.local/share/Steam/steam.sh: line 444: no match: ssfn
    
  • Seems like you need to install lib32-glibc. I get the same error when this package is not installed.

    Edit: Also make sure your system is up-to-date. sudo pacman -Syyu

  • Thanks for the suggestion.

    I’m getting the same behaviour after lib32-glibc install/reinstall and a full system update.

    I’ve also tried out disabling the multilib repo, uninstalling the packages and then re-enabling it and reinstalling them, to no avail.

  • @atompm said in Steam Multilib Issues:

    Error: You are missing the following 32-bit libraries, and Steam may not run

    Hm strange, how do you install steam? I am trying to replicate this in a vm but have no issues…

    (You are running an xorg session right? Not wayland?)

    This might point you in the ringt way: https://askubuntu.com/questions/260813/trying-to-install-steam-error-you-are-missing-the-following-32-bit-libraries-a

    I make things work…
    My humble wiki: https://anotherlinux.com/

  • Nevermind. I took the nuclear option in the end and just did a clean Antergos install, something about that last install just broke multilib completely.

    Thanks for your help regardless.

issues74 steam62 multilib2 Posts 7Views 828
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.