• LibreOffice fails to start


    Have been using Antregos for a few months with no problems. Suddenly LibreOffice will not load. Have removed and re-installed but no luck. If I start from terminal I get the following-:
    javaldx: Could not find a Java Runtime Environment!
    Warning: failed to read path from javaldx
    /usr/lib/libreoffice/program/soffice.bin: error while loading shared libraries: libicuuc.so.59: cannot open shared object file: No such file or directory. Any suggestions welcome

  • @SteveConlan said in LibreOffice fails to start:

    javaldx: Could not find a Java Runtime Environment

    jre7-openjdk jdk7-openjdk
    

    are optional dependencies…

    icu is missing or do you have it installed? (/usr/lib/libicuuc.so is owned by the icu package)

    pacman -Qs icu
    

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • Thanks for the fast reply, output of pacman is
    [[email protected] ~]$ pacman -Qs icu
    local/harfbuzz-icu 1.4.5-1
    OpenType text shaping engine (ICU integration)
    local/icu 58.2-2
    International Components for Unicode library
    [[email protected] ~]$
    I have also installed jre7 and rebooted but still have the same message

  • @SteveConlan i can run without java and icu installed… i use:

    libreoffice-fresh
    

    But local/icu 58.2-2 is not the current version…it should be:
    icu 59.1-1 and harfbuzz-icu 1.4.8-1

    So simple update your system will solve your issue…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • @joekamprad Tried that but no response
    [[email protected] ~]$ java -version
    java version "1.7.0_151"
    OpenJDK Runtime Environment (IcedTea 2.6.11) (Arch Linux build 7.u151_2.6.11-1-x86_64)
    OpenJDK 64-Bit Server VM (build 24.151-b01, mixed mode)
    [[email protected] ~]$ libreoffice-fresh
    bash: libreoffice-fresh: command not found
    [[email protected] ~]$

  • read ahead…

    and libreoffice-fresh is the name of the package i use, the program still starts with libreoffice

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • Apologies if I am asking a stupid question but how do I update these, I am using Package Manager but it only lists the older versions

  • @joekamprad said in LibreOffice fails to start:

    harfbuzz-icu

    last update is 12 days ago…
    Your Version is from 2017-03-11…

    you can manually update system, but this can produce more problems…
    As your last update was around 5 month ago…

    sudo pacman -Syu
    

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • But it do not have to be a problem, but it is the only way to get libre-office running and use your system as you like.

    Do you have any AUR packages installed? or simple standard installation? Change a lot of stuff related to the system or use what you get on installing Antergos?

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • @SteveConlan

    Probably you should update your system and repos, too.

    sudo pacman -Syyu
    

    (note the double y).
    If this doesn’t help, maybe try to check missing packages:

    pacman -Qk | grep -v "0 missing files"
    

    (the ‘missing files’ wording above may be translated wrong, I have no English system here).

  • @manuel said in LibreOffice fails to start:

    sudo pacman -Syyu
    

    (note the double y)
    Thanks this is what i want to write before…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • @joekamprad You’re welcome!

  • Gentlemen, I tried the sudo pacman -Syyu and it all started well until it appears the checksum proved incorrect or corrupt. Perhaps I made a wrong choice at the start. I paste the start and end of the process to see if you can kindly tell me what might be wrong.
    [[email protected] ~]$ sudo pacman -Syyu
    [sudo] password for steve:
    :: Synchronising package databases…
    antergos 158.1 KiB 1477K/s 00:00 [############################] 100%
    core 124.4 KiB 1447K/s 00:00 [############################] 100%
    extra 1684.6 KiB 1702K/s 00:01 [############################] 100%
    community 4.0 MiB 1706K/s 00:02 [############################] 100%
    multilib 173.3 KiB 1733K/s 00:00 [############################] 100%
    :: Starting full system upgrade…
    :: Replace antergos-repo-priority with antergos/antergos-alerts? [Y/n] Y
    warning: pepper-flash: local (1:25.0.0.148-1) is newer than extra (26.0.0.151-1)
    :: Replace wxgtk with extra/wxgtk2? [Y/n] Y
    resolving dependencies…
    :: There are 2 providers available for phonon-qt5-backend:
    :: Repository extra

    1. phonon-qt5-gstreamer 2) phonon-qt5-vlc

    Enter a number (default=1): 1
    :: There are 2 providers available for phonon-qt4-backend:
    :: Repository extra

    1. phonon-qt4-gstreamer 2) phonon-qt4-vlc

    Enter a number (default=1): 1
    looking for conflicting packages…
    warning: dependency cycle detected:
    warning: harfbuzz will be installed before its freetype2 dependency
    warning: dependency cycle detected:
    warning: phonon-qt5-gstreamer will be installed before its phonon-qt5 dependency
    warning: dependency cycle detected:
    warning: kinit will be installed before its kio dependency
    warning: dependency cycle detected:
    warning: phonon-qt4-gstreamer will be installed before its phonon-qt4 dependency
    warning: dependency cycle detected:
    warning: lib32-harfbuzz will be installed before its lib32-freetype2 dependency

    Packages (551) acl-2.2.52-4 akonadi-17.08.0-1 akonadi-calendar-17.08.0-1
    XXXXXXXXX------------------------------------------------XXXXXXXXXXXX
    (549/549) checking keys in keyring [################################################################] 100%
    downloading required keys…
    :: Import PGP key 4096R/BFA1ECFEF1524EE4099CDE971F0CD4921ECAA030, “Baptiste Jonglez [email protected]”, created: 2015-02-08? [Y/n] Y
    :: Import PGP key 2048R/69DA34D78FE0EFD596AC6D049D893EC4DAAF9129, “Bruno Pagani [email protected]”, created: 2011-08-22? [Y/n] Y
    (549/549) checking package integrity [################################################################] 100%
    error: pamac: signature from “Antergos Build Server (Automated Package Build System) [email protected]” is unknown trust
    :: File /var/cache/pacman/pkg/pamac-5.0.0-2-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] n
    error: pamac-tray-appindicator: signature from “Antergos Build Server (Automated Package Build System) [email protected]” is unknown trust
    :: File /var/cache/pacman/pkg/pamac-tray-appindicator-5.0.0-2-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] n
    error: numix-icon-theme: signature from “Antergos Build Server (Automated Package Build System) [email protected]” is unknown trust
    :: File /var/cache/pacman/pkg/numix-icon-theme-1:0.r1945-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] n
    error: antergos-kde-setup: signature from “Antergos Build Server (Automated Package Build System) [email protected]” is unknown trust
    :: File /var/cache/pacman/pkg/antergos-kde-setup-0.1.9-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] n
    error: antergos-keyring: signature from “Antergos Build Server (Automated Package Build System) [email protected]” is unknown trust
    :: File /var/cache/pacman/pkg/antergos-keyring-20170524-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] n
    error: antergos-alerts: signature from “Antergos Build Server (Automated Package Build System) [email protected]” is unknown trust
    :: File /var/cache/pacman/pkg/antergos-alerts-17.7.23-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] n
    error: antergos-mirrorlist: signature from “Antergos Build Server (Automated Package Build System) [email protected]” is unknown trust
    :: File /var/cache/pacman/pkg/antergos-mirrorlist-20170527-2-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] n
    error: antergos-welcome: signature from “Antergos Build Server (Automated Package Build System) [email protected]” is unknown trust
    :: File /var/cache/pacman/pkg/antergos-welcome-0.0.3-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] n
    error: dropbox: signature from “Antergos Build Server (Automated Package Build System) [email protected]” is unknown trust
    :: File /var/cache/pacman/pkg/dropbox-32.4.23-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] n
    error: package-query: signature from “Antergos Build Server (Automated Package Build System) [email protected]” is unknown trust
    :: File /var/cache/pacman/pkg/package-query-1.9.r380-2-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] n
    error: yaourt: signature from “Antergos Build Server (Automated Package Build System) [email protected]” is unknown trust
    :: File /var/cache/pacman/pkg/yaourt-1.9-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] n
    error: failed to commit transaction (invalid or corrupted package (PGP signature))
    Errors occurred, no packages were upgraded.

  • @SteveConlan said in LibreOffice fails to start:

    PGP signature

    this issue is often solved very easily with two simple commands:

    sudo pacman -Scc
    

    and then

    sudo pacman-key --refresh-keys
    

    after that, try to update again using

    sudo pacman -Syu
    

    WIKI

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • Problem solved. Thank you for your patience. Had one small conflict but removing the package it referred to solved the issue. Now all running as normal. Much appreciated. Steve

  • It pleased me to help!

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

fails11 libreoffice12 Posts 16Views 381
Log in to reply