• Error: GPGME


    Having database issues. Here is the error im recieving:

    [[email protected] ~]$ sudo pacman -Syy  
    error: GPGME error: No data  
    error: GPGME error: No data  
    error: GPGME error: No data  
    error: GPGME error: No data  
    error: GPGME error: No data  
    :: Synchronizing package databases...  
    core 103.8 KiB 427K/s 00:00 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    error: GPGME error: No data  
    error: failed to update core (invalid or corrupted database (PGP signature))  
    extra 1428.7 KiB 1282K/s 00:01 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    error: GPGME error: No data  
    error: failed to update extra (invalid or corrupted database (PGP signature))  
    community 1943.4 KiB 1460K/s 00:01 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    error: GPGME error: No data  
    error: failed to update community (invalid or corrupted database (PGP signature))  
    antergos 38.4 KiB 179K/s 00:00 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    multilib 105.4 KiB 425K/s 00:00 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    error: GPGME error: No data  
    error: failed to update multilib (invalid or corrupted database (PGP signature))  
    multilib 105.4 KiB 450K/s 00:00 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    error: GPGME error: No data  
    error: failed to update multilib (invalid or corrupted database (PGP signature))  
    archlinuxfr 14.7 KiB 95.8K/s 00:00 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    error: database 'core' is not valid (invalid or corrupted database (PGP signature))  
    error: database 'extra' is not valid (invalid or corrupted database (PGP signature))  
    error: database 'community' is not valid (invalid or corrupted database (PGP signature))  
    error: database 'multilib' is not valid (invalid or corrupted database (PGP signature))  
    error: database 'multilib' is not valid (invalid or corrupted database (PGP signature))  
    [[email protected] ~]$ sudo pacman -Syu  
    error: GPGME error: No data  
    error: GPGME error: No data  
    error: GPGME error: No data  
    error: GPGME error: No data  
    error: GPGME error: No data  
    :: Synchronizing package databases...  
    core is up to date  
    extra is up to date  
    community is up to date  
    antergos is up to date  
    multilib is up to date  
    multilib is up to date  
    archlinuxfr is up to date  
    error: database 'core' is not valid (invalid or corrupted database (PGP signature))  
    error: database 'extra' is not valid (invalid or corrupted database (PGP signature))  
    error: database 'community' is not valid (invalid or corrupted database (PGP signature))  
    error: database 'multilib' is not valid (invalid or corrupted database (PGP signature))  
    error: database 'multilib' is not valid (invalid or corrupted database (PGP signature))  
    [[email protected] ~]$   
    
    

    and here is my pacman.conf:

    \#  
    \# /etc/pacman.conf  
    \#  
    \# See the pacman.conf(5) manpage for option and repository directives  
      
    \#  
    \# GENERAL OPTIONS  
    \#  
    [options]  
    \# The following paths are commented out with their default values listed.  
    \# If you wish to use different paths, uncomment and update the paths.  
    \#RootDir = /  
    \#DBPath = /var/lib/pacman/  
    \#CacheDir = /var/cache/pacman/pkg/  
    \#LogFile = /var/log/pacman.log  
    \#GPGDir = /etc/pacman.d/gnupg/  
    HoldPkg = pacman glibc  
      
    \#XferCommand = /usr/bin/curl -C - -f %u \> %o  
    \#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u  
    \#CleanMethod = KeepInstalled  
    Architecture = auto  
      
    \# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup  
    \#IgnorePkg =  
    \#IgnoreGroup =  
      
    \#NoUpgrade =  
    \#NoExtract =  
      
    \# Misc options  
    \#UseSyslog  
    \#UseDelta  
    \#TotalDownload  
    Color  
    \# We cannot check disk space from within a chroot environment  
    CheckSpace  
    \#VerbosePkgLists  
      
    \# By default, pacman accepts packages signed by keys that its local keyring  
    \# trusts (see pacman-key and its man page), as well as unsigned packages.  
    SigLevel = Optional  
    LocalFileSigLevel = Optional  
      
    \# NOTE: You must run \`pacman-key --init\` before first using pacman; the local  
    \# keyring can then be populated with the keys of all official Arch Linux  
    \# packagers with \`pacman-key --populate archlinux\`.  
      
    \#  
    \# REPOSITORIES  
    \# - can be defined here or included from another file  
    \# - pacman will search repositories in the order defined here  
    \# - local/custom mirrors can be added here or in separate files  
    \# - repositories listed first will take precedence when packages  
    \# have identical names, regardless of version number  
    \# - URLs will have $repo replaced by the name of the current repo  
    \# - URLs will have $arch replaced by the name of the architecture  
    \#  
    \# Repository entries are of the format:  
    \# [repo-name]  
    \# Server = ServerName  
    \# Include = IncludePath  
    \#  
    \# The header [repo-name] is crucial - it must be present and  
    \# uncommented to enable the repo.  
    \#  
      
    \# The testing repositories are disabled by default. To enable, uncomment the  
    \# repo name header and Include lines. You can add preferred servers immediately  
    \# after the header, and they will be used before the default mirrors.  
      
      
    \#[testing]  
    \#SigLevel = PackageRequired  
    \#Include = /etc/pacman.d/mirrorlist  
      
    [core]  
    SigLevel = PackageRequired  
    Include = /etc/pacman.d/mirrorlist  
      
    [extra]  
    SigLevel = PackageRequired  
    Include = /etc/pacman.d/mirrorlist  
      
    \#[community-testing]  
    \#SigLevel = PackageRequired  
    \#Include = /etc/pacman.d/mirrorlist  
      
    [community]  
    SigLevel = PackageRequired  
    Include = /etc/pacman.d/mirrorlist  
      
      
    \# An example of a custom package repository. See the pacman manpage for  
    \# tips on creating your own repositories.  
    \#[custom]  
    \#SigLevel = Optional TrustAll  
    \#Server = file:///home/custompkgs  
      
    [antergos]  
    SigLevel = PackageRequired  
    Include = /etc/pacman.d/antergos-mirrorlist  
    [multilib]  
    SigLevel = PackageRequired  
    Include = /etc/pacman.d/mirrorlist  
      
    [multilib]  
    SigLevel = PackageRequired  
    Include = /etc/pacman.d/mirrorlist  
      
    [archlinuxfr]  
    SigLevel = Never  
    Server = http://repo.archlinux.fr/$arch
    

    after fresh install again using gnome instead of cinnamon since cinnamon is seeming to have issues with me now. it was working havent done anything but pacman -Syy and -Syu.

    gmail: [email protected]
    irc: [email protected]

  • Having database issues. Here is the error im recieving:

    [[email protected] ~]$ sudo pacman -Syy  
    error: GPGME error: No data  
    error: GPGME error: No data  
    error: GPGME error: No data  
    error: GPGME error: No data  
    error: GPGME error: No data  
    :: Synchronizing package databases...  
    core 103.8 KiB 427K/s 00:00 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    error: GPGME error: No data  
    error: failed to update core (invalid or corrupted database (PGP signature))  
    extra 1428.7 KiB 1282K/s 00:01 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    error: GPGME error: No data  
    error: failed to update extra (invalid or corrupted database (PGP signature))  
    community 1943.4 KiB 1460K/s 00:01 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    error: GPGME error: No data  
    error: failed to update community (invalid or corrupted database (PGP signature))  
    antergos 38.4 KiB 179K/s 00:00 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    multilib 105.4 KiB 425K/s 00:00 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    error: GPGME error: No data  
    error: failed to update multilib (invalid or corrupted database (PGP signature))  
    multilib 105.4 KiB 450K/s 00:00 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    error: GPGME error: No data  
    error: failed to update multilib (invalid or corrupted database (PGP signature))  
    archlinuxfr 14.7 KiB 95.8K/s 00:00 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    error: database 'core' is not valid (invalid or corrupted database (PGP signature))  
    error: database 'extra' is not valid (invalid or corrupted database (PGP signature))  
    error: database 'community' is not valid (invalid or corrupted database (PGP signature))  
    error: database 'multilib' is not valid (invalid or corrupted database (PGP signature))  
    error: database 'multilib' is not valid (invalid or corrupted database (PGP signature))  
    [[email protected] ~]$ sudo pacman -Syu  
    error: GPGME error: No data  
    error: GPGME error: No data  
    error: GPGME error: No data  
    error: GPGME error: No data  
    error: GPGME error: No data  
    :: Synchronizing package databases...  
    core is up to date  
    extra is up to date  
    community is up to date  
    antergos is up to date  
    multilib is up to date  
    multilib is up to date  
    archlinuxfr is up to date  
    error: database 'core' is not valid (invalid or corrupted database (PGP signature))  
    error: database 'extra' is not valid (invalid or corrupted database (PGP signature))  
    error: database 'community' is not valid (invalid or corrupted database (PGP signature))  
    error: database 'multilib' is not valid (invalid or corrupted database (PGP signature))  
    error: database 'multilib' is not valid (invalid or corrupted database (PGP signature))  
    [[email protected] ~]$   
    
    

    and here is my pacman.conf:

    \#  
    \# /etc/pacman.conf  
    \#  
    \# See the pacman.conf(5) manpage for option and repository directives  
      
    \#  
    \# GENERAL OPTIONS  
    \#  
    [options]  
    \# The following paths are commented out with their default values listed.  
    \# If you wish to use different paths, uncomment and update the paths.  
    \#RootDir = /  
    \#DBPath = /var/lib/pacman/  
    \#CacheDir = /var/cache/pacman/pkg/  
    \#LogFile = /var/log/pacman.log  
    \#GPGDir = /etc/pacman.d/gnupg/  
    HoldPkg = pacman glibc  
      
    \#XferCommand = /usr/bin/curl -C - -f %u \> %o  
    \#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u  
    \#CleanMethod = KeepInstalled  
    Architecture = auto  
      
    \# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup  
    \#IgnorePkg =  
    \#IgnoreGroup =  
      
    \#NoUpgrade =  
    \#NoExtract =  
      
    \# Misc options  
    \#UseSyslog  
    \#UseDelta  
    \#TotalDownload  
    Color  
    \# We cannot check disk space from within a chroot environment  
    CheckSpace  
    \#VerbosePkgLists  
      
    \# By default, pacman accepts packages signed by keys that its local keyring  
    \# trusts (see pacman-key and its man page), as well as unsigned packages.  
    SigLevel = Optional  
    LocalFileSigLevel = Optional  
      
    \# NOTE: You must run \`pacman-key --init\` before first using pacman; the local  
    \# keyring can then be populated with the keys of all official Arch Linux  
    \# packagers with \`pacman-key --populate archlinux\`.  
      
    \#  
    \# REPOSITORIES  
    \# - can be defined here or included from another file  
    \# - pacman will search repositories in the order defined here  
    \# - local/custom mirrors can be added here or in separate files  
    \# - repositories listed first will take precedence when packages  
    \# have identical names, regardless of version number  
    \# - URLs will have $repo replaced by the name of the current repo  
    \# - URLs will have $arch replaced by the name of the architecture  
    \#  
    \# Repository entries are of the format:  
    \# [repo-name]  
    \# Server = ServerName  
    \# Include = IncludePath  
    \#  
    \# The header [repo-name] is crucial - it must be present and  
    \# uncommented to enable the repo.  
    \#  
      
    \# The testing repositories are disabled by default. To enable, uncomment the  
    \# repo name header and Include lines. You can add preferred servers immediately  
    \# after the header, and they will be used before the default mirrors.  
      
      
    \#[testing]  
    \#SigLevel = PackageRequired  
    \#Include = /etc/pacman.d/mirrorlist  
      
    [core]  
    SigLevel = PackageRequired  
    Include = /etc/pacman.d/mirrorlist  
      
    [extra]  
    SigLevel = PackageRequired  
    Include = /etc/pacman.d/mirrorlist  
      
    \#[community-testing]  
    \#SigLevel = PackageRequired  
    \#Include = /etc/pacman.d/mirrorlist  
      
    [community]  
    SigLevel = PackageRequired  
    Include = /etc/pacman.d/mirrorlist  
      
      
    \# An example of a custom package repository. See the pacman manpage for  
    \# tips on creating your own repositories.  
    \#[custom]  
    \#SigLevel = Optional TrustAll  
    \#Server = file:///home/custompkgs  
      
    [antergos]  
    SigLevel = PackageRequired  
    Include = /etc/pacman.d/antergos-mirrorlist  
    [multilib]  
    SigLevel = PackageRequired  
    Include = /etc/pacman.d/mirrorlist  
      
    [multilib]  
    SigLevel = PackageRequired  
    Include = /etc/pacman.d/mirrorlist  
      
    [archlinuxfr]  
    SigLevel = Never  
    Server = http://repo.archlinux.fr/$arch
    

    after fresh install again using gnome instead of cinnamon since cinnamon is seeming to have issues with me now. it was working havent done anything but pacman -Syy and -Syu.

    gmail: [email protected]
    irc: [email protected]

  • Did you try to delete your keys and reset them as shown here: [https://wiki.archlinux.org/index.php/Pacman-key#Resetting_all_the_keys][0]">[https://wiki.archlinux.org/index.php/Pa][1] … l_the_keys That’s the only thing I can think of, I am running cinnamon on top of gnome and haven’t had any problems.

    [0]: <a href=
    [1]: https://wiki.archlinux.org/index.php/Pa

  • I tried everything i changed siglevel to never and it works. temporary fix.

    gmail: [email protected]
    irc: [email protected]

  • I shouldnt have said anything about cinnamon working fine b/c no sooner did I write that message than I had the pleasure of falling down one of those good ole’ linux rabbit holes. I spent 3 hours to get back where I am now LOL.

Posts 5Views 2663
Log in to reply