• How to install on Pure Legacy Systems


    Re: How to install on MBR instead of EFI?
    Hi,
    I have an old fujitsu laptop running Windows 7, in which I had previously dual booted ArchLinux without any issue. Now I’m trying to install antergos, but I’m stuck at providing the /efi/vars directory, as I don’t have one. I’m attaching screenshots of my boot screen and my bios setup.
    Boot Screen
    Bios Boot Options

    Please help in fixing this. Should I go for command line mode(is there any?)?

    [EDIT]
    I think I was unclear in what the problem is. I am choosing the first option on the boot screen and then following the install to disk procedure. Since I am dual booting, I chose the advanced option during partitioning of hard drive. In that windows, there are three checks which need to be completed to go ahead. One of the check is for EFI which my system doesn’t support. Hope this clarifies the problem.

  • Hm, im not sure what you mean?

    What happens if you choose the first option?

    I make things work…
    My humble wiki: https://anotherlinux.com/

  • @katphlab Sounds a bit strange. My main computer is pure legacy, never had a problem to install Antergos - or any other Linux - on it. Though I never allow any installer to install a boot loader. And, as any other computer here, it doesn’t have WindOS.

    Edit: Your boot screen photo looks unfamiliar. What ISO do you use, is it a regular Antergos, a minimal Antergos, or Nvidia-oriented Antergos installer?

  • @izznogooood I have edited the question to more clearly state the problem.
    @just I used regular iso, then used rufus to make a bootable usb using the option “MBR partition for Legacy/UEFI”. From the boot menu, I selected the first option.

  • @katphlab said in How to install on Pure Legacy Systems:

    I used regular iso,…

    Good, it’s the best choice.

    then used rufus to make a bootable usb…

    Can’t help with rufus, as I don’t have WindOS since 2005. Using dd in Linux would be the best way to prepare a bootable LiveUSB. Maybe, on some friend’s computer.

    Until 2005 I was using dd for windows to prepare bootable Linux media. It always worked better than any other image writer under WindOS. Dd for windows simply tries to simulate Linux dd command.

  • @just I have another system with Arch installed. Will try using dd to make the bootable usb and update.

  • @katphlab If you prefer graphical tools, then in Arch install SUSE Studio ImageWriter from AUR. It’s the only reliable image writer. Works perfectly.

  • @just said in How to install on Pure Legacy Systems:

    @katphlab If you prefer graphical tools, then in Arch install SUSE Studio ImageWriter from AUR. It’s the only reliable image writer. Works perfectly.

    I disagree, Etcher from Resin : https://etcher.io

    I make things work…
    My humble wiki: https://anotherlinux.com/

  • @katphlab said in How to install on Pure Legacy Systems:

    Boot Screen

    looks like ISO starts with EFI mode as legacy Bios will show the fancy blue Grub menu…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • @just tried with dd, same problem
    @izznogooood I had used Etcher on my first try, same result though
    @joekamprad yes
    Anything else that I can try?
    Btw on my second system which had Arch, I just installed antergos successfully, and damn it was worth it, but that system is UEFI.
    I am going to try and update the bios and see if it helps, will update then.

    Thanks all for helping, will keep seeing you here :smile:

  • @izznogooood said in How to install on Pure Legacy Systems:

    I disagree, Etcher from Resin…

    When I tested it, Etcher didn’t distinguish between hybrid and non-hybrid ISOs. As a result, it was writing to USB even ISOs which cannot be booted from USB.

    SUSE ImageWriter does this check prior to write anything. If an ISO cannot be booted from USB, ImageWriter clearly informs about it.

  • There is one thing you can do:

    Find your boot selection key on startup. If you press this key during startup it will present you with a list of options. From that list you can see whats EFI and not. Boot your usb in legacy.

    This whole situation is kind of odd though. Are you sure your system does not support EFI? There is no EFI or Legacy (or both) option in your BIOS? And if so, is safemode turned off?

    I make things work…
    My humble wiki: https://anotherlinux.com/

  • @izznogooood When I press the boot selection key, there is no list for EFI separately, it looks like this.
    Also as mentioned in the screenshot in my question, there is no "Boot option " in Boot menu or anywhere else in BIOS setup. Also I don’t know how to find “safemode” status as there is no such entry in my bios menu.
    Just to mention, I have installed a lot of distros and also Arch on the same system and never faced such issues. Is it not possible to force legacy system, like during Arch installation where I select what kind of BIOS system I’m using.
    Should I try the installation through command line?
    Also is it possible for me to install the antergos gnome package, if I install ArchLinux, if yes, I think that method seems less painful.
    Just to add more info, and apologies for not mentioning this before, I had a custom bios installed because I messed up my original one, but this BIOS was then upgraded using official Fujitsu utilities, so I don’t think it matters anyways as the current BIOS was updated from official source.

  • Got it installed. I selected Antergos (Non-Graphical Fallback) option from the menu, the setup tried to find efi, failed and then went to the legacy bootscreen as mentioned by @joekamprad . After that installation went without any problem.
    Thanks everyone for helping.

  • magically! Nice that it works for you!

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • I’m happy you hung in there!

    I make things work…
    My humble wiki: https://anotherlinux.com/

Posts 16Views 359
Log in to reply