Hello is there any other that have a problem with the wifi.
This have started after a couple of updates and it freezes the environment.
I’m able to interact with the windows that are open, but unable to reboot and shutdown, with the exception of holding the powerbutton down.

iwlwifi 0000:0c:00.0: Microcode SW error detected.  Restarting 0x20000
iwlwifi 0000:0c:00.0: Loaded firmware version: 8.83.5.1 build 33692
iwlwifi 0000:0c:00.0: Start IWL Error Log Dump:
iwlwifi 0000:0c:00.0: Status: 0x0000004C, count: 5
iwlwifi 0000:0c:00.0: 0x00000004 | NMI_INTERRUPT_WDG           
iwlwifi 0000:0c:00.0: 0x000006E4 | uPc
iwlwifi 0000:0c:00.0: 0x000005AA | branchlink1
iwlwifi 0000:0c:00.0: 0x00000820 | branchlink2
iwlwifi 0000:0c:00.0: 0x00000916 | interruptlink1
iwlwifi 0000:0c:00.0: 0x000027A2 | interruptlink2
iwlwifi 0000:0c:00.0: 0x00000002 | data1
iwlwifi 0000:0c:00.0: 0x07030000 | data2
iwlwifi 0000:0c:00.0: 0x000067C6 | line
iwlwifi 0000:0c:00.0: 0x68C16E3A | beacon time
iwlwifi 0000:0c:00.0: 0x526AE1C6 | tsf low
iwlwifi 0000:0c:00.0: 0x00000014 | tsf hi
iwlwifi 0000:0c:00.0: 0x00000000 | time gp1
iwlwifi 0000:0c:00.0: 0x028F64B0 | time gp2
iwlwifi 0000:0c:00.0: 0x00000000 | time gp3
iwlwifi 0000:0c:00.0: 0x00010853 | uCode version
iwlwifi 0000:0c:00.0: 0x00000054 | hw version
iwlwifi 0000:0c:00.0: 0x00488704 | board version
iwlwifi 0000:0c:00.0: 0x045300A8 | hcmd
iwlwifi 0000:0c:00.0: 0x27F63000 | isr0
iwlwifi 0000:0c:00.0: 0x010BE000 | isr1
iwlwifi 0000:0c:00.0: 0x0000001A | isr2
iwlwifi 0000:0c:00.0: 0x1443FCC0 | isr3
iwlwifi 0000:0c:00.0: 0x10800112 | isr4
iwlwifi 0000:0c:00.0: 0x000067C6 | isr_pref
iwlwifi 0000:0c:00.0: 0x00004A88 | wait_event
iwlwifi 0000:0c:00.0: 0x0000013A | l2p_control
iwlwifi 0000:0c:00.0: 0x000003BF | l2p_duration
iwlwifi 0000:0c:00.0: 0x00101042 | l2p_mhvalid
iwlwifi 0000:0c:00.0: 0x00000007 | l2p_addr_match
iwlwifi 0000:0c:00.0: 0x02121704 | lmpm_pmg_sel
iwlwifi 0000:0c:00.0: 0x0000E800 | timestamp
iwlwifi 0000:0c:00.0: 0x00000100 | flow_handler
iwlwifi 0000:0c:00.0: Start IWL Event Log Dump: display last 20 entrie
iwlwifi 0000:0c:00.0: EVT_LOGT:0042921106:0x00000000:0301
iwlwifi 0000:0c:00.0: EVT_LOGT:0042921423:0x000000b4:0303
iwlwifi 0000:0c:00.0: EVT_LOGT:0042921457:0x0000000e:0322
iwlwifi 0000:0c:00.0: EVT_LOGT:0042921458:0x0000013a:0322
iwlwifi 0000:0c:00.0: EVT_LOGT:0042921461:0x000000c4:0322
iwlwifi 0000:0c:00.0: EVT_LOGT:0042921784:0x00000000:0301
iwlwifi 0000:0c:00.0: EVT_LOGT:0042934608:0x00000000:0301
iwlwifi 0000:0c:00.0: EVT_LOGT:0042934924:0x000000b4:0303
iwlwifi 0000:0c:00.0: EVT_LOGT:0042934959:0x0000000e:0322
iwlwifi 0000:0c:00.0: EVT_LOGT:0042934959:0x0000013a:0322
iwlwifi 0000:0c:00.0: EVT_LOGT:0042934963:0x000000c4:0322
iwlwifi 0000:0c:00.0: EVT_LOGT:0042935285:0x00000000:0301
iwlwifi 0000:0c:00.0: EVT_LOGT:0042948091:0x00000000:0301
iwlwifi 0000:0c:00.0: EVT_LOGT:0042948408:0x000000b4:0303
iwlwifi 0000:0c:00.0: EVT_LOGT:0042948442:0x0000000e:0322
iwlwifi 0000:0c:00.0: EVT_LOGT:0042948443:0x0000013a:0322
iwlwifi 0000:0c:00.0: EVT_LOGT:0042948446:0x000000c4:0322
iwlwifi 0000:0c:00.0: EVT_LOGT:0042948769:0x00000000:0301
iwlwifi 0000:0c:00.0: EVT_LOGT:0042951840:0x000000d7:0123
iwlwifi 0000:0c:00.0: EVT_LOGT:0042951878:0x00000000:0125

Have found that it might have something to do with an linux firmware update.
have read this thread https://bugzilla.kernel.org/show_bug.cgi?id=195299, but didn’t get any thing out of it.

Is there any body that can help me??