• Help: Can't save my locale.gen after un-commenting


    Hello,

    I’ve been trying to switch language (from German to English, since it used German when I said I lived here) on my Antergos installation, however, with no luck.

    I know the guide states that I need to un-comment the language in the locale.gen file. However, when I un-comment something in the locale.gen file it does not let me save it again. I have no clue what I have done wrong. Has anyone else had this issue, or can someone help me why?

    I’m logged in on the account I created in the installation, so I should be the root user, but it seems to be an issue permissions since it tells me when I try so save over the file that I’m not allowed.

    I tried re-installing from scratch and I still have the same issue, so not sure what I need to do.

    Thanks,
    Tobias

  • @TobiasDev
    Hi!
    You need to open with super user right.
    Not sure what text editor you’re using, so you can do that with sudo nano /etc/locale.gen type your password edit what you need, then save with Ctrl+o and exit with Ctrl+x

    You may also check if you /etc/locale.conf and /etc/vconsole.conf are set as you wish.
    then you need to generate the file with sudo locale-gen

    Portergos site
    https://github.com/Portergos/portergos-iso

    Still in love with Antergos (default OS)
    I3wm

    Linux newbie since 06/2016

  • Thanks! That solved it. 🙂 Thought I already was a super user when I logged in.

  • @TobiasDev you need root permission to write to this file.
    I would prefere to use non graphical editor like nano:

    sudo nano /etc/locale.gen
    

    and [ctrl+X] to save.

    Then generating by:

    sudo locale-gen
    

    On Antergos installation the root user is created with the same password as the main user you create on installation.

    sudo - what the hell is this?

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

save3 un-commenting1 locale.gen1 Posts 4Views 279
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.