• A few repo questions


    I am assuming that the Antergos repo’s are not exactly the same as the Arch repo’s right?

    Thanks for including alsa-firmware in the Antergos repo’s, but there are some extras I need for more control over my sound card (EMU 0404pci) that are in the Arch repo’s. I can also see that there are other programs I like not found in the Antergos repo’s. For instance the “games” category has mostly KDE games.

    Being used to APT, I don’t know how to add repo’s to pamac, and would like to know how to add the Arch repo’s, and also if that is a bad idea.

    The flazzum you spizz, the zoider you splat!

  • @Zoidmo
    Hi!

    Antergos uses Archlinux repositories + Antergos repositories

    Antergos repos contains:
    customized configs for Desktops
    themes
    own tools (like cnchi)
    some packages compiled from AUR, like pamac, abiword etc, to allow you to have a quick access to packages that would take a lot of time to compile by your own.

    Yes there are wasy to add new UNOFFICIAL repos check here if you’re interested https://wiki.archlinux.org/index.php/Unofficial_user_repositories

    Yet i must say that i’m not familiar wit any Games’s repositories; i’d be interested in knowing too…

    OBS: If you’re using pamac (the graphical way to install packages) you can go to preferences and enable AUR repos there, then you’ll have more programs to check.

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • Hi @fernandomaroto, and thanks for the link.

    I must be missing something here, I thought that the Arch repo’s and the AUR are two separate things IOW: Arch is official for the Arch Linux OS, and AUR (Arch User Repository) is an addition with user made software’s, forks etc.

    The Arch repositories are supposed to have the largest selection of all repo’s, but there are already a number of things I can’t find in a search, and when looking through the groups, I would expect way more choices and categories too for that matter. I remember having more choices on Debian based systems.

    “Antergos mirrors” really doesn’t say anything about the actual repositories behind them.

    I will read the article you provided a link to; google searches never seam to come up with the most relevant answers, even though “By Relevance” is the default search criteria!

    Oh, and I did not mean that I ever saw a specific “Game repo”, but there are lot’s of games besides those by KDE, and few (if any) of those are listed in the “games” category in pamac on Antergos.

    The flazzum you spizz, the zoider you splat!

  • @Zoidmo Did you just install your system? if so, the first time you install you should refresh keys, database etc (otherwise you won’t find the packages in the repos). I recommend you to use the commands bellow:

    sudo pacman-key --init; sudo pacman-key --populate archlinux antergos; sudo pacman-key --refresh-keys; sudo pacman -Syy

    then search again the package and see if will appear…

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • Will do, thanks again. It may take a while though, so busy with other stuff.

    The flazzum you spizz, the zoider you splat!

  • Just tried that, but since I am not in the sudoers list, I am going to be reported!!! If it reports me to the system administrator (Also me) I will have to scold myself!

    I also have to find out how to administer users and groups “The Arch way”. The kuser app is pathetic in that respect!

    The flazzum you spizz, the zoider you splat!

  • @Zoidmo said in A few repo questions:

    Just tried that, but since I am not in the sudoers list, I am going to be reported!!! If it reports me to the system administrator (Also me) I will have to scold myself!

    hehehehe
    are you sure you’re not in the sudoers? i guess you just have to type your password. The first time you use sudo a message like that appear

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • Well, I set up a super user account to use when stuff goes wrong, and user accounts for daily use. The account I am in, is for daily use but with administrator privileges, and I have done administrative tasks (sudo) before without problems. This time it just wouldn’t let me do it, so I logged in as super user and that did the trick.

    Strangely, there was no message like:
    :exclamation: WARNING: User 1001 tried to use sudo WARNING :exclamation:
    waiting for me, so I don’t know who my mischievousness was reported to and when or how they are going to pounce on me!

    I will check the repo’s for stuff I was looking for and see if it is there now.

    The flazzum you spizz, the zoider you splat!

repo14 Posts 8Views 246
Log in to reply