• Mixed folders in a fresh installation


    Fresh Installation, My /Home folder is full of dozens of other folders (seems like /root mixed with /home folder), Tried 2 different modes: selecting partitions by hand /, /home & swap, and selecting /home separated automatically by the installer. both methods with same results. Any clue? thanks![

  • Fresh Installation, My /Home folder is full of dozens of other folders (seems like /root mixed with /home folder), Tried 2 different modes: selecting partitions by hand /, /home & swap, and selecting /home separated automatically by the installer. both methods with same results. Any clue? thanks![

  • I have the same thing josharg, they’re actually copies of /etc. There’s a few posts on the Antergos G+ page about it too, so we’re not alone. They are copies though, not needed so they can be deleted. It is something that needs to be fixed before release of the final iso however.

  • Hi guys,

    That’s odd. We have not stumped with this bug ourselves. I’ll ask some information so I can reproduce it here.

    Did you use the 32bit or 64bit iso?

    Which desktop did you try? (it may seem it’s not important, but it is).

    Did you select any “features”? (I don’t think this is relevant, but just in case… if you don’t remember don’t worry).

    Did you use automatic or advanced installation? (this one is for Dutchman)

    It seems that having home separated is the issue… and that’s odd as I specifically tested this option before releasing this RC. Dutchman, did you install /home in a different partition as josharg?

    Thanks!

  • Hi Karasu,

    I have been successful installing Manjaro and Chakra using almost the same methods. I have a 1TB SATA HD partitioned as follows: /, /home & swap. My PC has UEFI disabled and “other OS” enabled in order to install GNU/Linux, “Secure boot” is also disabled.

    Using the last Antergos iso published on Antergos site, I use advanced method in cnchi (Cli never load) to select the partitions created by hand. I tried the latest (0.6.4) cnchi version to start the installation and works till the latest stage and get stuck during “system configuration” so it get aborted there. For some odd reason the iso before the last one worked without any problem using advanced method and selecting partitions by hand. now I cant pass thru that part of the installation. it looks like cnchi does not recognize my partitions and “continue” button become greyed.

    I always use 64bits. The choosen desktop is KDE (My favourite).

    I select all the features in Cnachi installer (enabled).

    By the way Im Spanish speaker so if you prefer I can post this in Spanish too.

  • Hi,

    Would you mind posting the output of the following command from the live system? Thanks!

    ls -l /sys/firmware/efi
    

    Cheers!

  • Sure, here you go

    [[email protected] ~]$ ls -l /sys/firmware/efi  
    total 0  
    -r--r--r-- 1 root root 4096 May 22 18:35 config\_table  
    drwxr-xr-x 2 root root 0 May 22 17:45 efivars  
    -r--r--r-- 1 root root 4096 May 22 18:35 fw\_vendor  
    -r--r--r-- 1 root root 4096 May 22 18:35 runtime  
    drwxr-xr-x 12 root root 0 May 22 18:35 runtime-map  
    -r-------- 1 root root 4096 May 22 18:35 systab  
    [[email protected] ~]$   
    
    
  • Same problem in a fresh KDE instalation, ISO RC 64 bits

    I use cnchi install

    Antergos (Gnome)

  • @“josharg”:3okqs6ka said:

    Sure, here you go

    [/quote:3okqs6ka]Are you sure you disabled UEFI? That folder should be empty on a system that is in legacy boot mode. What’s happening is Cnchi detects UEFI and won’t let you continue without mounted /boot as your EFI partition.

  • Sorry for some reason UEFI wasnt disable at all, I have “discovered” that there are 5 more options in my Asus M5A97 Evo R2.0 Mobo (you must disable “Windows boot mode” in boot sequence besides “secure boot” & stuff) checked to be sure it is in “legacy” mode. Now I am installing Antergos and see what is next. thanks. Once installed I will tell you if folders are mixed up again.

  • I confirm after a new fresh install folders are mixed in my home folder, so I have deleted all them.

  • Sorry I couldn’t get right back. In answer to the questions, I tried both methods, but always with a separate /home and swap. It’s how I have my boxes set up so I always try to duplicate that. Using the advanced partition it never finished, as with josharg, click to continue and nothing happens, the button grays out but there’s no disk activity.

    I also tried it with all the different desktops, thinking that may have been the problem (chose KDE initially). No difference.

    I tried initially with the extra codecs, etc., and AUR selected, then tried with nothing beyond the default settings. Made no difference. In the last attempt I left everything at default, even Gnome desktop choice, only choosing separate /home. Same result.

    I had on all attempts first run ‘cnchi-dev’ to update Cnchi before trying. Bad habit, I usually scan the forums and read any relevent info before trying to install anything. I’m old fashioned that way.

    I’m installing in a VM, 64-bit iso in Virtualbox 4.3.10, Kubuntu 14.04 host, on a System76 Wild-Dog 64-bit. On each attempt I would spin up a new VM, allocating it a 10Gb .vhd (pre-sized), 2Gb memory and 2 of the 4 cores. I still have the KDE VM installed, and have not run any updates on it since installation if you’d like me to run any tests.

  • Tried to see if doing a straight install, not changing any of the defaults would produce any errors, but now it seems that it hangs at the end of it. No more disk activity, but Gnome Shell is using a lot of cpu. Figured it would be helpful to take some snapshots and copy the logs, etc. I’ve uploaded everything I thought might be helpful to a shared folder in my Google Drive.

    [https://drive.google.com/folderview?id=0B0bwgRkdvlOnUGp2dDRVM2J3YUU&usp=sharing][0]">[https://drive.google.com/folderview?id][1]= … sp=sharing

    There are two screenshots from the latest attempt at installing Gnome, one showing how the installer saw the VM layout, and the other at the point where the install froze. Before attempting the actual install I once again ran ‘cnchi-dev’ and left the terminal open to catch any messages. When it froze I copied all the output from the terminal, that’s also in the folder and named "cnchi-dev output failed Gnome’.

    All the log files are from the successful KDE install done the other day, thought they may give some clues as to why the /etc folder was copied to /home. Unfortunately I wasn’t able to get anything from the failed Gnome install as the system wasn’t bootable.

    Hope it helps. If you’d like me to try something else, let me know.

    [0]: <a href=
    [1]: https://drive.google.com/folderview?id

  • Hi Dutchman,

    First thanks for your patience… I know this can be frustrating.

    OK, let’s see…

    An error in the post install script copied /etc files to the home folder. Fixed in 0.6.5

    [url:2mdrzhz3]https://github.com/Antergos/Cnchi/commit/25e2c41a910d3f6c9fc15f454368bbae6846a5f6[/url:2mdrzhz3]

    A package has changed names: kdeutils-kwallet to kdeutils-kwalletmanager in KDE 4.13 - Also fixed in 0.6.5

    Installation froze one time because you catch a bug that Dustin introduced and fixed himself (he’s quick):

    [url:2mdrzhz3]https://github.com/Antergos/Cnchi/commit/d4138e4357771ae28dc32c50055e0c24492ac2a2[/url:2mdrzhz3]

    And finally, it seems there’s a problem when copying the grub theme… which is strange. Maybe is something that happens just after that.

    Let me try it here just once more and I’ll get back to you with my findings.

    Thanks a lot!

  • No problem karasu. If things look good, let me know if it’s available and if I can pull the fixed version with cnchi-dev. Then I can test it myself and let you know the results. More people testing it, the better.

  • Hi,

    Cnchi version 0.6.9 does not have this mixed folders issue in KDE.

    You can test it when you have the time to confirm it.

    Cheers!

  • hehe I already sent him the iso links

  • Success people! Works fine, I only still had a problem with the default Antergos mirror. I think thats my location though, must be something with the route. Quick edit of the mirror to point it to another here and everything went flawlessly. No extra icons, no quirky anything. Great job everyone!

  • Thanks for the report!!

    Cheers!

  • There is a problem after all, but it’s not something with Antergos. The mesa libs in the Arch repos are newer than what Cinnamon can use, so it defaults to fallback 2-D when run in a VM. The fix for it from the Arch forums is to downgrade the mesa libs, mesa-libgl-10.1.0-5 and mesa-10.1.0-5. Trying it last night, pacman couldn’t find them. I don’t know if it would have the same problem when tried natively on the machine, someone else would need to test that.

    With Cinnamon basically frozen by Clem and the Mint team on the Gnome 3.10 libs, and Arch following Gnome, perhaps it might be better to remove it from the install iso? Just to avoid problems with new users who may not know how to work around something like that. Again, my test are only in a VM, it may work on native iron, but with Cinnamon falling behind the Gnome libs, well it could get ugly.

Posts 23Views 3107
Log in to reply