• [Solved] Firefox sqlite update issue


    I posted about this issue on the Mozilla support forums already, and they said it could be a packaging issue, so I’m hoping someone here can help…I’m copying pretty much the same post below, and you can see it at:
    https://support.mozilla.org/en-US/questions/1170956

    I’m receiving the following error when trying to launch firefox:

    “The application has been updated, but the SQLite library wasn’t updated properly and the application cannot run. Please try to launch the application again. If that should still fail, please try reinstalling it, or visit https://support.mozilla.org

    This is while launching Firefox 55 on Antergos. The issue seems to have started when I tried to install the flashplugin 26.0.0.151-1 package from the ‘extra’ repository and updated Firefox, after which I tried to restart Firefox and received this error. I tried uninstalling this plugin using the package manager, which did not change anything, and the same after I then tried reinstalling it. Tried uninstalling and reinstalling Firefox too. I’ve also tried deleted my .mozilla folder, and a reboot, but I’m still getting the same error.

    I was not able to find any mention of this error message with a web search or on the Firefox support pages; I also followed the troubleshooting guide, although didn’t actually find any steps I’m able to do, because they all require launching Firefox, and even safe mode isn’t working.

  • should you then try to investigate in the sqlite direction?
    Firefox is running without problem here.

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • Ohh…yup, upgrading sqlite from 3.18.0-1 to 3.20.0-1 fixed it…I was misreading that error message and thinking a sqlite database used by Firefox had become corrupted. Thanks!

  • Fine! Great! Hurray!

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

Posts 4Views 270
Log in to reply