• How do I change to linux-lts?


    Hello,
    i’ve installed linux-lts and lts-headers. Now i can’t find instructions to how correctly change the grub.

  • @burt_93 , you have to update your grub. Run
    sudo grub-mkconfig -o /boot/grub/grub.cfg
    and reboot. You can choose the lts kernel from within the “Advanced Options” of the GRUB.

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch I want to start every time on LTS, how do i do it?

    Edit: it doesn’t boot, all i see is a blinking underscore on a blasck screen.
    I choose Advanced option for antergos-> antergos lts kernel

  • If you installed the lts kernel after installing the OS, I can remember the lts kernel becomes default. If you selected it to be installed during installation of the OS (from the additional list of Cnchi) then the current kernel is your default. I don t know (not tried) if this can be re-ordered with grub-customizer. But I can see a discussion going on here:
    https://forum.antergos.com/topic/7590/always-boot-to-lts-instructions-or-option/16

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • I just installed Antergos a few days ago with the LTS installed by the option in Cnchi. You just made me wonder if the LTS would boot or not, and it turns out it also hung on boot for me. Turns out Cnchi failed to install the video drivers for the LTS kernel. After installing them it now boots fine so checking that lts driver versions are installed might help.

    Like anarch said its pretty easy to use grub-customizer to change the default boot option to LTS.

  • @hughdahand Yes i too installed lts from cnchi.

    How do install video driver for lts kernel?

  • It’s really going to depend on what your GPU is.

    I have a newer nvidia card using proprietary drivers, which uses the NVIDIA package for drivers and installing the NVIDIA-LTS package worked like a charm.

    what is your gpu?

  • @hughdahand said in How do I change to linux-lts?:

    grub-customizer

    Yes as it is a GUI it should be easy, but on the other hand very easy to do something wrong here, what makes system not booting ;)

    So my advice do nothing else here then using the first shown (Bootmenu Configuration) and click save if you do your changes here. (to move entry rightclick and move to…)

    Also if you have a multiboot system you will need to mount all other partions before starting grub-customizer, or it will take forever to startup…

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • @joekamprad
    Hey!
    I didn’t have time to test these:
    https://askubuntu.com/questions/216398/set-older-kernel-as-default-grub-entry

    https://unix.stackexchange.com/questions/198003/set-default-kernel-in-grub

    OBS: Interesting that one of them you can set the advanced options like a path until the kernel

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • @burt_93
    You can write a new file (as root): /boot/grub/custom.cfg, with the following contents:

    menuentry "Antergos LTS" {
      savedefault
      linux  /boot/vmlinuz-linux-lts root=LABEL=Antergos rw quiet splash
      initrd /boot/initramfs-linux-lts.img
    }
    
    

    This assumes the LABEL name of the Antergos partition is ‘Antergos’, but you may change that if you wish (e.g. with gparted).

    When this is done, just reboot.

  • @manuel said in How do I change to linux-lts?:

    @burt_93
    You can write a new file (as root): /boot/grub/custom.cfg, with the following contents:

    menuentry "Antergos LTS" {
      savedefault
      linux  /boot/vmlinuz-linux-lts root=LABEL=Antergos rw quiet splash
      initrd /boot/initramfs-linux-lts.img
    }
    
    

    This assumes the LABEL name of the Antergos partition is ‘Antergos’, but you may change that if you wish (e.g. with gparted).

    When this is done, just reboot.

    that’s very nice, is it possible to use UUID insted of LABEL or full path like /dev/sdXy etc?

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • @hughdahand Thank you this solved the blank screen on startup.

  • Old thread but i just discovered that is possible to “split” the advanced options at grub adding the line

    #To split the "Advanced Options"
    GRUB_DISABLE_SUBMENU=y
    

    to /etc/default/grub
    then regenerate grub with:
    grub-mkconfig -o /boot/grub/grub.cfg

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

linux-lts4 Posts 14Views 784
Log in to reply