• Antergos is eating my RAM like cake


    Hi!

    I’ve been using Antergos for a couple of years now.

    I started facing a RAM eating issue and I have no clue what’s causing it and how to fix it up.

    My system is using Antergos with Gnome and has 16Gb of RAM.

    Whenever I boot, with nothing running, I get like 1.6Gb already filled.

    When I run a browser, Chromium, with a couple of tabs, I easily hit 5Gb RAM and more.

    So, when I use a couple of additional programs, like Sublime Text, occasionally Gimp, and similar web design and development tools, I easily hit the 16Gb bar.

    I’m pretty sure all the things I run shouldn’t take that much RAM. I’ve been using a 4Gb - 8Gb for years without never filling them totally.

    Any thoughts are welcome.

    Thanks!

  • @DahmaniAdame Wow!!!

    1- How do you check your free ram?
    2- Maybe, use a task manager to check which applications are causing it?

    I am pretty sure Antergos is not to blame. In fact, Antergos gnome is the most lightweight Gnome I have ever used.

  • @psscnp142 I use both the System Monitor and the command “free” to check the RAM’s status.

    Both give the same result.

    For example, I got 11Gb loaded for running:

    • Chrome with like 15 tabs opened
    • Sublime Text
    • One Open Office document (5 pages of text)
    • Inkscape with a visual with no heavy or complicated design

    Here’s what free returns:

    total used free shared buff/cache available
    Mem: 16386956 11168604 365596 410744 4852756

    I need to investigate further, but I’m not sure where to start.

  • That’s strange behaviour… I have 16GB too and I don’t hit it nearly at all!

    Do you run virtualisation in the meantime?
    What is your filesystem technology? ZFS?
    Do you use ramdisks?
    Also which processes use most of your RAM?

  • You can take a look with:: gnome-system-monitor and click on memory to get sorted by Ram usage…there should be a program/task/ or something causing the high mem use…
    Can you provide also a bootup log for us?

    lspci > log.txt && lsusb >> log.txt && dmesg >> log.txt && cat log.txt | curl -F [email protected] https://ptpb.pw/?u=1
    

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • @EarthMind

    Do you run virtualisation in the meantime?

    Nope.

    What is your filesystem technology? ZFS?

    I’m not sure which one. I used the default setting on the install.

    Also which processes use most of your RAM?

    Chromium and/or Firefox. But it’s not normal to get half of the RAM going to the browser only. I’m quite sure that I used to do the same on 4Gb/8Gb RAM too, but it never took as much as it does now.

  • @joekamprad Here’s the result of the command: https://ptpb.pw/3jwm

    Chromium and its subprocesses take a lot. Here’s a screenshot of my System Monitor:

    http://i.imgur.com/wZOcK1P.png

  • @DahmaniAdame logs show nothing unusual, and no error or fails at all…

    But can you sort system monitor by emory use? to see all heavy load apps?
    0_1502313717195_systemmonitor.png

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • @DahmaniAdame If I’m not mistaken, for Chromium it can be normal to have such memory usage because it opens every tab in a separate process. Firefox bundles it together, like 4 a process or something.

    Are you using an adblocker? It can surely help to increase performance.

    I think the reports of your memory use is quite strange though. It shows 100MB+ each process, but the total not going over 700MB. H4cks?

  • Please read the following: https://serverfault.com/questions/449296/why-is-linux-reporting-free-memory-strangely

    I think it should clear out your confusing and show there’s nothing to worry about.

  • @EarthMind Same happens with Firefox. It eats a bit less, but still, I can’t see a browser with like a dozen of windows locking 5Gb of RAM.

    Yes, I use Adblock, but I think it’s unrelated to the RAM usage.

    And yes, I don’t understand why Chromium loads each tab on +200Mb average.

  • If was is explained on the website of the link I posted, it’s actually good behaviour. One rather would want to prefer RAM to be used to the full, rather than there should be more load on the filesystems.

ram7 cake1 eating1 Posts 13Views 354
Log in to reply