• Optimus card


    Hi,
    Newbie in the area.

    I have a probelm, the processor sometimes speeds up to 90% and temperature also rises.

    lspci -v shows:

    01:00.0 VGA compatible controller: NVIDIA Corporation GF119M [GeForce 610M] (rev ff) (prog-if ff)
    !!! Unknown header type 7f
    Kernel modules: nouveau, nvidia_drm, nvidia

    I’ve searched and nothing.

    Can anyone help?

  • Try to take a look at this article in Antergos Wiki. It’s about Nvidia Optimus. Yours seems to be a typical Optimus card and should work perfectly in Antergos.

    Edit

    If you’re sure to have an Optimus card and don’t want to waste time reading about its technical details, use the excellent nvidia-installer utility by @karasu. It does exactly the same installation job described in Antergos Wiki. Currently it doesn’t uninstall Bumblebee.

    Install the package. It’s very small (4 K when installed), light, doesn’t have dependencies:

    sudo pacman -Syu nvidia-installer
    

    Take a look at main features:

    nvidia-installer --help
    

    Do a dry run (simulates an installation, doesn’t install anything, doesn’t change the system in any way):

    nvidia-installer --test --bumblebee
    

    Install Bumblebee and proprietary Nvidia driver:

    nvidia-installer --bumblebee
    

    nvidia-installer may be removed at any moment, without damaging a system in any way:

    sudo pacman -Rcnsu nvidia-installer
    
  • @just

    Hi, thanks for the help.

    Did that but the message with

    lspci -v
    

    Is still the same.

    But i figured out my problem with the processor.

    The turbo mode or turbo boost (don’t exactly remember the name) was causing the problem of high usage and heat. I disabled in tlp conf and gonig to see if it’s really solved.

    Going to marked solved.

  • I have no idea what a “turbo mode” could be, but glad to help somehow. Thanks for reading Antergos forum.

  • @proftug4 said in Optimus card:

    …I disabled in tlp conf…

    Beside tlp, I’d suggest to use also thermald. It made literally a miracle on my hardware, Dells and Acers. When you believe that the system is in a perfect state and is cooled well, add thermald. The system will work even better.

    To install thermald:

    sudo pacman -Syu thermald
    sudo systemctl enable thermald
    sudo systemctl reboot
    

    To uninstall thermald:

    sudo systemctl stop thermald
    sudo systemctl disable thermald
    sudo pacman -Rcnsu thermald
    sudo systemctl reboot
    
optimus24 Posts 6Views 157
Log in to reply