• VirtualBox does not boot into Kernel LTS


    @judd i didn’t do that, why would i do that if i’m calling for help ? was just asking a question, maybe not to well formulate, sorry for that

  • @p.garzaro said in VirtualBox does not boot into Kernel LTS:

    @judd i didn’t do that, why would i do that if i’m calling for help ? was just asking a question, maybe not to well formulate, sorry for that

    Ok, Okay, I understand, it’s misinterpreted by the translator …
    Sorry

  • @p.garzaro plz uninstall virtualbox-guest-dkms and reboot

  • Done that, still the same ! 0_1502134920964_Capture d’écran_2017-08-07_21-41-23.png

  • So it looks like that the module is not provided by the virtualbox-host-dkms … e.g. not build.
    check pacman -Qs dkms

    sudo dkms status
    

    to show aviable modules

    sudo dkms autoinstall
    

    to rebuild modules for current loaded kernel

  • Done that, still the same, don’t understand why modules not there while i have virtual-host-dkms

    0_1502194662621_Capture d’écran_2017-08-08_14-17-27.png

  • installing virtualbox-host-dkms (5.1.26-1)...
    Start Post-Transaction-Hooks...
    Install DKMS modules
    ==> dkms install vboxhost/5.1.26_OSE -k 4.12.4-1-ARCH
    ==> dkms install vboxhost/5.1.26_OSE -k 4.9.40-1-lts
    Arming ConditionNeedsUpdate...
    
    sudo dkms status
    vboxhost, 5.1.26_OSE, 4.12.4-1-ARCH, x86_64: installed
    vboxhost, 5.1.26_OSE, 4.9.40-1-lts, x86_64: installed
    

    try uninstalling virtualbox-host-dkms and reinstall it again…

  • done, and it gave me the same result as the previous picture i send… i’m gonna give up soon i guess

  • how do you reinstall?

    may you uninstall then clean cache (to download the package new, and do not use the same one) and the reinstall…

    sudo pacman -Rsc virtualbox-host-dkms
    sudo pacman -Scc
    sudo pacman -S virtualbox virtualbox-host-dkms
    
  • I reinstall it with yaourt, manually !
    i did all the command line you gave to me and reboot to be sure, also dkms autoinstall, but still same thing

    0_1502208270485_Capture d’écran_2017-08-08_18-04-10.png

  • last try is to use --force option:

    sudo pacman -S --force  virtualbox-host-dkms
    

    -f, --force
    Bypass file conflict checks and overwrite conflicting files. If the package that is about to be installed contains files that are already
    installed, this option will cause all those files to be overwritten. This option should be used with care, ideally not at all.

  • @joekamprad said in VirtualBox does not boot into Kernel LTS:

    sudo pacman -S --force virtualbox-host-dkms

    Yep didn’t work once again, still got that error message …
    “modprobe: FATAL: Module vboxdrv not found in directory /lib/modules/4.9.41-1-lts”

    i’m loosing hope

  • Well thanks a lot for trying to help me, my experience on antergos and linux in general was good, but i got to many problems that i cant figure out how to fix (virtualbox, nvidia didn’t want to work well with linux and other things) maybe it’s my hardware which is the problem, i dunno but i’m going back to windows, with regrets but if that the only way to get my computer working … and will do a virtual machine for the needs until i change my pc, so that close the subject, and again sorry for wasting your time

  • No wasted time here on my side, i get allways learning more on helpout!
    Last you can check if you are in the wheel group?

    groups inside a terminal will give you the groups of your user…

  • Yes, but this time we didn’t learn how to fix the problem …

  • do you put yourself inside vboxusers group? as it is not necessary, wheel is enaugh…

  • i’ve done yes

  • gpasswd -d user group
    

    and you create the group manually or not?

  • Nope, the group was created automatically

Posts 60Views 7354
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.