• Gparted - Merging Partitions


    Hi everyone😀.

    So yesterday I was trying to build an updated ISO for the Community Edition, but apparently ran out of disc space part way through on my root partition😞.
    In response, I booted into the Antergos Live ISO and opened Gparted. From here I shrunk my /Home partition (/dev/sda8) in order to then expand my / partition (/dev/sda7). However, when I try to expand it, I find I cannot. Here’s a screenshot:
    0_1501860233738_DeepinScreenshot20170804152329.png
    This is what is shown when trying to expand my / partition:
    0_1501860357569_DeepinScreenshot20170804152543.png

    So how can I merge my unallocated partition with my / partition? (neither are mounted currently).

    Thanks in advance!

  • You have to format the allocated space into ext 4, otherwise the system won’t recognize it.

  • Thank you for the help, @bpoerwo😀. It turns out that I just had to move my unallocated partition closer to my other one I was trying to extend (found that one out here)

    THnak you for your time and thoughtful response though!

  • Ah, learned something new!! A few months ago I had the same problem and I thought it was because of the space not being formatted. After I did that it merged. I guess there are many roads to solve a problem😊

  • @bpoerwo said in Gparted - Merging Partitions:

    After I did that it merged.

    Interesting… I guess we both learned something today! That’s the great thing about Linux I guess, it’s so flexible😀.

  • So apparently the issue is not as solved as I thought😞. In the process of merging my root and unallocated partitions together, I had to delete my swap and recreate it as another partition. However, whenever I boot up I now get this:
    link 1
    link 2
    As you can see, the start job fails, referencing a failure to load swap. However, I can manually enable swap with no problem in Gparted by enabling Swap On.

    Any help would be greatly appreciated! Thank you in advance.

  • swap needs to be changed inside /etc/fstab also afaik!

    to get the uuid:

    lsblk -f
    or
    ls -l /dev/disk/by-uuid

    and change the UUID to fit with the new swap …

    UUID="newuuid-nr." swap swap defaults 0 0
    
  • Thank you for the help @joekamprad! However, I can’t seem to get that last command right. I have tried both UUID="743739b1-2b04-4865-8c65-813e7aea17f6-nr." swap swap defaults 0 0 and UUID="743739b1-2b04-4865-8c65-813e7aea17f6" swap swap defaults 0 0 but they both just reply that bash: swap: command not found. What am I doing wrong?

  • hey @Keegan sorry to be kinda short shaped again ;)

    you need to edit /etc/fstab and change the line for your new swap partition:

    sudo nano /etc/fstab
    

    and change the line with your old swap uuid to your new uuid:

    UUID="743739b1-2b04-4865-8c65-813e7aea17f6" swap swap defaults 0 0
    
  • Thank you! I think it worked, but I won’t fully know until I reboot😀. I’ll let you all know then!

  • @joekamprad said in Gparted - Merging Partitions:

    sorry to be kinda short shaped again

    Really? I’m just glad to have someone helping me🙂. Plus, it provides an opportunity to learn. Thanks again!

  • hehehe… so it turns out that I messed something up in fstab and now I cannot boot up😄. Here’s my fstab file:

    # /etc/fstab: static file system information.
    #
    # Use 'blkid' to print the universally unique identifier for a
    # device; this may be used with UUID= as a more robust way to name devices
    # that works even if disks are added and removed. See fstab(5).
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    #
    UUID=BC18-4BBE /boot/efi vfat defaults,relatime 0 0
    UUID=4f920bf1-e738-4e62-afcc-6cf59261b022 / ext4 defaults,relatime,data=ordered 0 1
    UUID=743739b1-2b04-4865-8c65-813e7aea17f6 swap swap defaults 0 0
    UUID=0c34b2a3-a0a6-4b7d-b2c5-3f64d34f330c /home ext4 defaults,relatime,data=ordered 0 0
    

    And now whenever I try to boot into Antergos, it tells me that “no working init was found”, as shown below:
    link2screenshot
    Any ideas?

    Thanks!

  • @Keegan I’m shocked! 💀

    No backup of your old fstab file? ;)

    So what exactly do you change inside?

    relatime,data=ordered > this options?

  • @joekamprad said in Gparted - Merging Partitions:

    @Keegan I’m shocked!

    😄

    So what exactly do you change inside?

    Just the UUID for swap. Nothing else.

    No backup of your old fstab file? ;)

    Already thought of that, but unfortunately it was too late😞. Sadly, I didn’t even think of doing that when I changed it, but it definitely sprang to mind this morning when I booted up with the error😀.

  • @joekamprad said in Gparted - Merging Partitions:

    relatime,data=ordered > this options?

    ???

  • @Keegan said in Gparted - Merging Partitions:

    Just the UUID for swap. Nothing else.

    So then may need to rewrite init and grub.cfg will help:

    chroot into the fucked-up-system and do so:

    sudo mkinitcpio -p linux
    sudo grub-mkconfig -o /boot/grub/grub.cfg
    
  • This sounds silly, but how do I chroot into it? Sadly, I’m stuck on Solus Budgie right now, in case that makes a difference.

  • @Keegan said in Gparted - Merging Partitions:

    @joekamprad said in Gparted - Merging Partitions:

    relatime,data=ordered > this options?

    ???

    i was diggin in the dark here …

  • @joekamprad said in Gparted - Merging Partitions:

    i was diggin in the dark here …

    Ahhh… makes more sense now😄.

partitions11 gparted5 merging1 Posts 39Views 3004
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.