• No TUN module found


    Hi All Antergos Heroes !

    I have tried setting up OpenVPN.
    It runs great until I get the following error:

    ...
    ERROR: Cannot open TUN/TAP dev /dev/net/tun: No such device (errno=19)
    

    Being an Arch-Novice I resort to blindly follow advice on the internet:

    [[email protected] openvpn]$ sudo modprobe tun
    modprobe: FATAL: Module tun not found in directory /lib/modules/4.11.9-1-ARCH
    [[email protected] openvpn]$ find /lib/modules/ -iname 'tun.ko.gz'
    /lib/modules/4.12.3-1-ARCH/kernel/drivers/net/tun.ko.gz
    /lib/modules/4.9.40-1-lts/kernel/drivers/net/tun.ko.gz
    [[email protected] openvpn]$ sudo insmod /lib/modules/4.12.3-1-ARCH/kernel/drivers/net/tun.ko.gz
    insmod: ERROR: could not insert module /lib/modules/4.12.3-1-ARCH/kernel/drivers/net/tun.ko.gz: Invalid module format
    

    In summary it looks like I have the tun module on my machine but I am too incompetent to get it working :(

    Anyone knows what to do ??
    I greatly appreciate any help !

    Lenovo Ideapad 310S
    CPU: Intel® Core™ i7-7500U CPU @ 2.70GHz × 4
    GPU: Intel® HD Graphics 620 (Kabylake GT2)
    HDD: 242,9 GB (SSD)

  • @Janus after kernel upgrades, you need to reboot.

  • @psscnp142 Thank you !
    I feel a bit stupid not trying out this first myself.

    alt text

    Lenovo Ideapad 310S
    CPU: Intel® Core™ i7-7500U CPU @ 2.70GHz × 4
    GPU: Intel® HD Graphics 620 (Kabylake GT2)
    HDD: 242,9 GB (SSD)

Posts 3Views 316
Log in to reply