• How to switch keyboard language during installation


    Hi,

    I am trying to install Antergos for the first time. I am using the GUI installer. I selected Hebrew on the keyboard layout screen, and now I have reached the screen to enter a user name and password, and I can ONLY enter Hebrew! I choose Hebrew because my keyboard has also Hebrew, not because I want to use it exclusively! How do I switch to English on the setup screens? Or for that matter, how would I switch languages after I installed?

    Thanks

  • @psscnp142 said in How to switch keyboard language during installation:

    @bmburstein See here,

    https://wiki.archlinux.org/index.php/Keyboard_configuration_in_Xorg

    @psscnp142 That link explains how to switch keyboard layouts from the terminal, or how to set a key-combo for switching layouts. That is not the problem I am having. Let me explain in detail:
    I started the live desktop from the usb. It starts with only one language (English), so no configuration needed. I immediately started the installer. I chose English as the installer language, English, Hebrew (IL) as the location, set my timezone, chose Hebrew as my keyboard layout (that means I have a keyboard with both English and Hebrew), chose a DE, chose which apps to install, chose a partitioning scheme and finally reached the screen where I need to enter my name, username and password. This is where I have a problem! I can only type in Hebrew at this screen. I can’t figure out how to switch the language here! I wan’t my username and password in English.

    I hope this explains the problem.

  • Hi bmburstein,

    You can set your keyboard-layouts in the gnome-control-center if you are using the non-minimal-iso.
    In the settings window click on “Region and Language” and add two Input Sources with the + button. In your case that would be Hebrew and English.
    After that, an input selector appears in the panel with which you can change your keyboard-layout at any time.

    Edit: okay, I tested it in a VM, but it seems like cnchi ignores these settings… maybe it will be easier to install antergos in english and change the keyboard layout later.

  • @Talvi said in How to switch keyboard language during installation:

    Edit: okay, I tested it in a VM, but it seems like cnchi ignores these settings… maybe it will be easier to install antergos in english and change the keyboard layout later.

    That is what I ended up doing. It is very counter-intuitive, though, and should probably be fixed (I don’t know where to suggest this for fixing)

  • On accident you can change all this manual after installation:

    Uncomment needed localizations in /etc/locale.gen, and generate them with:

    # sudo locale-gen
    

    Set the LANG variable in locale.conf(5) accordingly, for example:

    /etc/locale.conf
    LANG=en_US.UTF-8
    

    If you set the keyboard layout, make the changes persistent in vconsole.conf(5):

    /etc/vconsole.conf
    KEYMAP=de-latin1
    

    This can be done from TTY2 without any DE running or from terminal too

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

Posts 6Views 232
Log in to reply