Recently (2017-07-28) kernel was upgraded to 4.12.3 and Nvidia was upgraded to 384.59. It may cause problems on Nvidia Optimus laptops.

Problem

Nvidia GPU does not automatically powered off when optirun terminates. It leads to overheating and constantly spinning cooling fans. Nvidia GPU should be always switched Off by default = unpowered during normal Optimus laptops operation under Bumblebee control.

Antergos Wiki explains how to check whether Nvidia GPU is switched On or Off here.

Solution 1

  1. Stop running bumblebeed service
    sudo systemctl stop bumblebeed
    
  2. Disable bumblebeed service
    sudo systemctl disable bumblebeed
    
  3. Reboot. Simple logout-login is not enough
    sudo systemctl reboot
    
  4. Enable bumblebeed service again
    sudo systemctl enable bumblebeed
    
  5. Reboot the 2nd time. Logout-login is not enough
    sudo systemctl reboot
    
  6. Done

When optirun terminates, Nvidia GPU is switched off now.

Solution 2

  1. Uninstall Bumblebee, as described in Antergos Wiki

  2. Install Bumblebee again, as described in Antergos Wiki

  3. Done

Nvidia GPU is now switched off upon optirun termination.

On behalf of @just and from father’s computer.