• Volume Controls Unresponsive, Top Bar Empty, and Right Click Disabled)


    I screwed up my sound and volume controls lately in KDE, in that now no matter what I do I cannot change the default, preset volume. I think this happened after enabling “Automatically switch all running streams when a new output becomes available” setting. Now however, that option is grayed out and I cannot disable it within settings. I don’t really know if this means anything or not, but if there is another way to disable it, that would also be greatly appreciated.

    Thanks!

    Keep trying, never give up. In the end, you will find that it was all worth it

    My ISO:
    https://rebornos.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • Well, I finally fixed my volume issues:grinning:, but now I have introduced other problems apparently. I uninstalled and then reinstalled Plasma and the sound was fixed, but now the top bar is completely empty. When I press the Super key, nothing happens, and such is the story whenever I try to use a widget. In addition, right clicking on the desktop does nothing, but thankfully I can still get to all my applications due to the fact that I already had an alternative, DE independent, menu to search from (panther_launcher). If anyone has any help or suggestions to offer, that would be fabulous!

    Thanks!

    Keep trying, never give up. In the end, you will find that it was all worth it

    My ISO:
    https://rebornos.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • As for this issue, I believe it is due to trying to add the widget Battery percent (or something like that, but it’s a widget that is supposed to display the current battery percentage). Immediately after adding it, all of these problems happened at once. My panel became unresponsive, as did all of my widgets. In addition, right clicking on the desktop now does nothing.

    Just thought I would throw some more info. out there! and PLEASE HELP !!!

    Thanks!

    Keep trying, never give up. In the end, you will find that it was all worth it

    My ISO:
    https://rebornos.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • @Keegan Hi!
    Well as you already know i don’t use KDE/plasma.

    1. When you reinstalled you used the --force option with pacman? (that could explain how your panels are empty)

    2. Can you remove this battery widget you think is breaking your panel? (what happens when you do it?)

    3. Can you totally remove your panel and make a new one? (not sure how much work you put into it, but sometimes is necessary)

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • Maybe you can delete configs, reboot and hope for the best.

    https://lists.archlinux.org/pipermail/arch-general/2014-October/037597.html

  • @fernandomaroto said in Volume Controls Unresponsive, Top Bar Empty, and Right Click Disabled):

    When you reinstalled you used the --force option with pacman? (that could explain how your panels are empty)

    Sadly, no. I just uninstalled every Plasma package. However, I think I found the source of the problem. I missed a few packages in other categories such as the qt5 category.

    Can you remove this battery widget you think is breaking your panel? (what happens when you do it?)

    Can you totally remove your panel and make a new one? (not sure how much work you put into it, but sometimes is necessary)

    Sadly, no. My first idea was to try those options. However, to add a widget I need to be able to right click on the screen, which I cannot do. the same sadly goes for creating another panel.

    So then I thought I could just reinstall KDE, which I now realize includes packages from the qt5 category. So I uninstalled everything and just installed the antergos-kde-setup package. This installed everything I need, but now I think it messed up Lightlocker because I cannot login anymore. When I boot up, I just get an error about being unable to display lightlocker. If anyone knows how to resolve this, that would be great!

    And thank you everyone for helping.

    Keep trying, never give up. In the end, you will find that it was all worth it

    My ISO:
    https://rebornos.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • @psscnp142 said in Volume Controls Unresponsive, Top Bar Empty, and Right Click Disabled):

    Maybe you can delete configs, reboot and hope for the best.

    Already tried that, but thank you anyways:slight_smile:. As mentioned in my recent post above, I have uninstalled everything (and deleted the .kde config files in Home) but now cannot login.

    Thank you!

    Keep trying, never give up. In the end, you will find that it was all worth it

    My ISO:
    https://rebornos.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • Hey there! I finally fixed everything… sort of:smile:. I ended up having to uninstall lightdm and install sddm. Everything seems to be working correctly now, although it would be helpful if I could switch back to lightdm.

    Thank you for all of your help:grinning:.

    Keep trying, never give up. In the end, you will find that it was all worth it

    My ISO:
    https://rebornos.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • So now that everything is fixed, I am starting to notice some strange things. For instance, whenever I log in to any DE, I get this notice:
    0_1501202213653_login keyring.png
    Does anyone know how I can get rid of this annoing thing?

    Thanks!

    Keep trying, never give up. In the end, you will find that it was all worth it

    My ISO:
    https://rebornos.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • And another problem solved! It turns out I just had to remove the “login key”. However, lightdm is not working for me no matter what I seem to try. I have uninstalled and reinstalled it, disabled and re-enabled it, but nothing is working.

    Thank you for everyone’s help already:grinning:.

    Keep trying, never give up. In the end, you will find that it was all worth it

    My ISO:
    https://rebornos.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • Good to see you solved most of your problems. :slight_smile:

    Maybe systemctl status lightdm can show you some logs why it fails.

  • @psscnp142 said in Volume Controls Unresponsive, Top Bar Empty, and Right Click Disabled):

    Maybe systemctl status lightdm can show you some logs why it fails.

    Thank you, @psscnp142:grinning:. Her’es the output. Please keep in mind however, that I currently have it disabled in favor of SDDM (so that I can actually log in and out for now:smile:).

    systemctl status lightdm
    ● lightdm.service - Light Display Manager
      Loaded: loaded (/usr/lib/systemd/system/lightdm.service; disabled; vendor pre
      Active: inactive (dead)
        Docs: man:lightdm(1)
    lines 1-4/4 (END)
    

    Keep trying, never give up. In the end, you will find that it was all worth it

    My ISO:
    https://rebornos.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • In addition, when I boot up and try to start lightdm, it always complains (or mentions) lightdm.service, so I thought I might provide mine here for you to have a look at:

    [Unit]
    Description=Light Display Manager
    Documentation=man:lightdm(1)
    [email protected]
    [email protected] systemd-user-sessions.service plymouth-quit.service acpid.service
    
    [Service]
    ExecStart=/usr/bin/lightdm
    Restart=always
    IgnoreSIGPIPE=no
    BusName=org.freedesktop.DisplayManager
    
    [Install]
    Alias=display-manager.service
    

    It’s located at usr/lib/systemd/system/lightdm.service if you were wondering. And thank you for all of your help!

    Keep trying, never give up. In the end, you will find that it was all worth it

    My ISO:
    https://rebornos.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • @Keegan I believe you still need to configure the greeter in lightdm.conf. If you check the arch-wiki for ligthdm it should guide you in the right direction. There is a default greeter you can start with as well but idk how Antergos gets to the magic they have for the default lightdm setup they have but it’s nice.

    Sys01: Antergos + Mate; GTX 1070 + nvidia package :)
    Sys02: Antergos + Mate on Surface Pro 3

  • Hi again!

    Turns out somehow a few necessary dependencies had been deleted:confused:. I just installed web-greeter-next, light-locker, and lightdm-settings. Now, everything is back to normal:grinning:.

    Thank you everyone!

    Keep trying, never give up. In the end, you will find that it was all worth it

    My ISO:
    https://rebornos.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • @Keegan
    Nice!
    Next time you think you removed many dependencies of a package you can use:

    pacman -Si lightdm
    the command above don’t need sudo and will show mandatory and optional dependencies

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • @fernandomaroto said in Volume Controls Unresponsive, Top Bar Empty, and Right Click Disabled):

    pacman -Si lightdm

    Thank you! That is such a useful command for me:grinning:. I’ll keep it in mind for the future.

    Keep trying, never give up. In the end, you will find that it was all worth it

    My ISO:
    https://rebornos.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • @Keegan that’s good! Ya it helps to know what things needs sometimes by seeing how they would be setup from scratch in Arch

    Sys01: Antergos + Mate; GTX 1070 + nvidia package :)
    Sys02: Antergos + Mate on Surface Pro 3

  • I do have one more minor issue when booting up, but I don’t remember exactly what the error line says right now:smile:. I’ll post it here and let you guys know the next time I reboot. And thank you again for all of your help. I really appreciate it!

    Keep trying, never give up. In the end, you will find that it was all worth it

    My ISO:
    https://rebornos.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • Sorry about the delay here, life just got in the way:smile:. Had dinner after posting, ran some unexpected errands, got home and went to bed. But now it’s the morning! I’ll have some screenshots and details posted very soon:slight_smile:.

    And thank you for all of your patience.

    Keep trying, never give up. In the end, you will find that it was all worth it

    My ISO:
    https://rebornos.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

Posts 25Views 1069
Log in to reply