• 0 AD Crashes


    I recently installed 0AD (just today actually) but whenever I try to launch it, it crashes before even loading. I have already tried using the LTS kernel and various DE’s such as Gnome and KDE, but nothing seems to make a difference. If anyone has any suggestions, advice, or solutions, that would be greatly appreciated😀.

    Thank you all in advance!

  • In addition, this is what I get when executing 0ad in the terminal:

    [[email protected] ~]$ 0ad
    Cache: 400 (total: 5882) MiB
    TIMER| InitVfs: 1.85978 ms
    TIMER| CONFIG_Init: 1.44059 ms
    ALSA lib pcm_dmix.c:1099:(snd_pcm_dmix_open) unable to open slave
    AL lib: (EE) ALCplaybackAlsa_open: Could not open playback device 'default': No such file or directory
    ERROR: Sound: AlcInit failed, m_Device=0x0 m_Context=0x0 dev_name=OpenAL Soft err=a005
    
    TIMER| shutdown ConfigDB: 0.458 us
    ERROR: OpenAL error: (null); called from ~CSoundManager (line 277)
    
    TIMER| resource modules: 172.843 us
    TIMER TOTALS (9 clients)
    -----------------------------------------------------
      tc_png_decode: 0 c (0x)
      tc_dds_transform: 0 c (0x)
      tc_pool_alloc: 41.184 kc (3x)
      tc_transform: 0 c (0x)
      tc_plain_transform: 0 c (0x)
      tc_ShaderGLSLLink: 0 c (0x)
      tc_ShaderGLSLCompile: 0 c (0x)
      tc_ShaderValidation: 0 c (0x)
      xml_validation: 0 c (0x)
    -----------------------------------------------------
    TIMER| shutdown misc: 205.773 us
    Cache: 400 (total: 5882) MiB
    TIMER| InitVfs: 143.725 ms
    TIMER| CONFIG_Init: 1.46548 ms
    ALSA lib pcm_dmix.c:1099:(snd_pcm_dmix_open) unable to open slave
    AL lib: (EE) ALCplaybackAlsa_open: Could not open playback device 'default': No such file or directory
    ERROR: Sound: AlcInit failed, m_Device=0x0 m_Context=0x0 dev_name=OpenAL Soft err=a005
    
    Unknown cache/TLB descriptor 0xc3
    TIMER| RunHardwareDetection: 38.0096 ms
    /usr/bin/0ad: line 9:  3410 Segmentation fault      (core dumped) "$pyrogenesis" "[email protected]"
    

    Hope this helps!

  • I know that I screwed up my sound and volume controls lately in KDE, in that now no matter what I do I cannot change the default, preset volume. I think this happened after enabling “Automatically switch all running streams when a new output becomes available” setting. Now however, that option is grayed out and I cannot disable it within settings. I don’t really know if this means anything or not, but if there is another way to disable it, that would also be greatly appreciated.

    Thanks!

  • Turns out my problem was related to my other problem. As you can see from that thread, I got my sound issues fixed and now 0AD is working fine. However, a plethora of other issues have now surfaced. If you would be so kind as to take a look at them (from the link above) that would be highly appreciated.

    Thank you😀.

Posts 4Views 1082
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.