• System's language with gnome doesn't change


    I’m trying to change my system language to Japanese but it doesn’t work, I use gnome and changed the language in settings (already edited locale and generated), it says to log out.
    When I log out gdm is in Japanese,but when I log in all the system continues in English and nothing changes, everything in English, I type locale in a terminal and:

    LANG=ja_JP.UTF-8
    LC_CTYPE="ja_JP.UTF-8"
    LC_NUMERIC=ja_JP.UTF-8
    LC_TIME=ja_JP.UTF-8
    LC_COLLATE="ja_JP.UTF-8"
    LC_MONETARY=ja_JP.UTF-8
    LC_MESSAGES="ja_JP.UTF-8"
    LC_PAPER=ja_JP.UTF-8
    LC_NAME=es_CO.UTF-8
    LC_ADDRESS=es_CO.UTF-8
    LC_TELEPHONE=es_CO.UTF-8
    LC_MEASUREMENT=ja_JP.UTF-8
    LC_IDENTIFICATION=es_CO.UTF-8
    LC_ALL=
    

    It should be in Japanese I don’t get it
    Pretty thankful if you can help me

  • @AlejandroC90
    Hi!
    I’m not sure, but after changing the system i guess you must run locale-gen
    See if it works please.

    Portergos site
    https://github.com/Portergos/portergos-iso

    Still in love with Antergos (default OS)
    I3wm

    Linux newbie since 06/2016

  • @fernandomaroto I just solved it, in the locale.conf file I added another part:

    LANGUAGE=ja_JP.UTF-8
    

    According to the wiki is the fallback for LANG so I gave it a try and then restart and it works, thank you.

gnome268 language23 systems3 Posts 3Views 332
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.