• Update Manager non-functional: Antergos-mirrorlist


    Hello all,

    This problem has persisted for some time now but as I have tried several of the solutions given to other posters about similar problems and none have worked, I feel I need to make one for myself.

    Initially I was having problems with the upgrade manager given that all the Antergos repository updates were being rejected due to invalid PGP key. I tried to update everything else except the corrupted packages until I found a solution, which was working for some time, but now if I uncheck all the Antergos updates it states:

    “could not satisfy dependencies: antergos-mirrorlist: removing antergos-repo-priority breaks dependency 'antergos-repo-priority”.

    If I try to include the Antergos packages in all of my 390 available updates, it tells me that “kinit will be installed before its kio dependency”, taking around 3-4 minutes before saying “invalid or corrupted package:” (and there’s nothing after the colon to indicate what is corrupted or why).

    Would greatly appreciate some help with this matter! Thank you in advance!

  • Hi there and welcome to the Forum😀.

    could not satisfy dependencies: antergos-mirrorlist

    I would attempt to uninstall and then reinstall antergos-mirrorlist and see if that helps. In addition, have you tried setting your ‘SigLevel’ to ‘Never’? (Take a look at this article for some help with the whole SigLevel thing).

    Hope this all helps and good luck!

  • @Keegan

    I believe this solved the bulk of the issue; the only issue now is

    “error: config file /etc/pacman.conf, line 1: All directives must belong to a section.
    ==> ERROR: ‘pacman’ returned a fatal error (1):” when trying to update something from AUR (spotify and another program).

    I only edited in pacman.conf what the article suggested so if there is something missing in “line 1” I’m not sure what that would be.

  • @acernal823 said in Update Manager non-functional: Antergos-mirrorlist:

    All directives must belong to a section.

    Did you accidentally delete the line that reads [antergos]? Anyways, here’s what the file should look like. The only difference in yours should be that ‘SigLevel=Never’


    #/etc/pacman.conf

    #See the pacman.conf(5) manpage for option and repository directives

    #GENERAL OPTIONS

    [options]
    #The following paths are commented out with their default values listed.
    #If you wish to use different paths, uncomment and update the paths.
    #RootDir = /
    #DBPath = /var/lib/pacman/
    #CacheDir = /var/cache/pacman/pkg/
    #LogFile = /var/log/pacman.log
    #GPGDir = /etc/pacman.d/gnupg/
    #HookDir = /etc/pacman.d/hooks/
    HoldPkg = pacman glibc
    #XferCommand = /usr/bin/curl -C - -f %u > %o
    #XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
    #CleanMethod = KeepInstalled
    #UseDelta = 0.7
    Architecture = auto

    #Pacman won’t upgrade packages listed in IgnorePkg and members of IgnoreGroup
    #IgnorePkg =
    #IgnoreGroup =

    #NoUpgrade =
    #NoExtract =

    #Misc options
    #UseSyslog
    #Color
    #TotalDownload
    CheckSpace
    #VerbosePkgLists

    #By default, pacman accepts packages signed by keys that its local keyring
    #trusts (see pacman-key and its man page), as well as unsigned packages.
    SigLevel = Required DatabaseOptional
    LocalFileSigLevel = Optional
    #RemoteFileSigLevel = Required

    #NOTE: You must run pacman-key --init before first using pacman; the local
    #keyring can then be populated with the keys of all official Arch Linux
    #packagers with pacman-key --populate archlinux.

    #REPOSITORIES
    #- can be defined here or included from another file
    #- pacman will search repositories in the order defined here
    #- local/custom mirrors can be added here or in separate files
    #- repositories listed first will take precedence when packages
    #have identical names, regardless of version number
    #- URLs will have $repo replaced by the name of the current repo
    #- URLs will have $arch replaced by the name of the architecture

    #Repository entries are of the format:
    #[repo-name]
    #Server = ServerName
    #Include = IncludePath

    #The header [repo-name] is crucial - it must be present and
    #uncommented to enable the repo.

    #The testing repositories are disabled by default. To enable, uncomment the
    #repo name header and Include lines. You can add preferred servers immediately
    #after the header, and they will be used before the default mirrors.

    #[antergos-staging]
    #SigLevel = PackageRequired
    #Server = http://mirrors.antergos.com/$repo/$arch/

    [antergos]
    SigLevel = PackageRequired
    Include = /etc/pacman.d/antergos-mirrorlist

    #[testing]
    #Include = /etc/pacman.d/mirrorlist

    [core]
    Include = /etc/pacman.d/mirrorlist

    [extra]
    Include = /etc/pacman.d/mirrorlist

    #[community-testing]
    #Include = /etc/pacman.d/mirrorlist

    [community]
    Include = /etc/pacman.d/mirrorlist

    #If you want to run 32 bit applications on your x86_64 system,
    #enable the multilib repositories as required here.

    #[multilib-testing]
    #Include = /etc/pacman.d/mirrorlist

    [multilib]
    Include = /etc/pacman.d/mirrorlist

    #An example of a custom package repository. See the pacman manpage for
    #tips on creating your own repositories.
    #[custom]
    #SigLevel = Optional TrustAll
    #Server = file:///home/custompkgs


  • Sorry for the late reply; I quadruple checked everything to be exactly as you listed it and even copied + pasted your text directly (with and without the SigLevel = Never vs going back to testing with PackageRequired), but nothing has made the following message go away

    “error: config file /etc/pacman.conf, line 1: All directives must belong to a section.
    ==> ERROR: ‘pacman’ returned a fatal error (1):”

    Is there something in “line 1” that I’m missing or need to add? Never had this issue in the past

  • Are you sure the first line of the file is completely empty? There may be a character you dont see even a tab can make difference…

    Maybe, you can put ‘#’ at the beginning of each line before [options] section. Even before empty lines.

  • @acernal823 mine has a comment (whithout the quotes) lol:

    “#”

  • I tried adding the comment before the document, after and with spaces in varying locations but I think at this point I’m guessing and/or causing more issues that I’m fixing. I’m still confused as to why if I just copied the exact pacman.conf text that was listed above it wouldn’t solve the issue, but I can’t download or install anything until I’m able to get this resolved

  • @acernal823
    Try this:
    sudo pacman -Sw archlinux-keyring antergos-keyring antergos-mirrorlist && sudo pacman -U /var/cache/pacman/pkg/antergos-m* --force && sudo pacman -U var/cache/pacman/pkg/antergos-k* --force && sudo pacman -U /var/cache/pacman/pkg/archlinux-k* --force

    OBS: if pacman refuses to even download then you’ll need to manually download them and then install

  • @fernandomaroto Tried this, but for some reason it yielded the exact same error message as when I try to update or download other software packages, namely this:

    error: config file /etc/pacman.conf, line 1: All directives must belong to a section.

    Is there a simple way for me to reinstall pacman or entirely refresh my pacman.conf file? I would paste what is in the file here, but I have simply copied and pasted exactly what was listed in an earlier post here

  • @acernal823 said in Update Manager non-functional: Antergos-mirrorlist:

    config file /etc/pacman.conf, line 1: All directives must belong to a section.

    check if you have /etc/pacman.conf.new

    if so follow the instructions from this forum
    http://bbs.archbang.org/viewtopic.php?pid=9866#p9866

    OBS: Trial and error method seems to be necessary here :(

  • @fernandomaroto I only have regular pacman.conf, no pacman.conf.new in my /etc folder

  • @acernal823 ok, let’s try something else:
    download pacman directly from archrepo
    https://www.archlinux.org/packages/core/x86_64/pacman/download/
    then you’ll need to extract the package, and extract it again (.pkg.tzr.xz > .pgk.tar > folder)
    open a terminal and type:
    sudo cp ~/Downloads/pacman-5.0.2-2-x86_64.pkg/etc/pacman.conf /etc
    OBS1: if you downloaded pacman.conf in Downloads folder
    OBS2: that procedure will remove antergos repos and comment multilib repo from pacman.conf, but if work we’ll fix it later

  • @fernandomaroto This seemed to work – the error no longer appears, and the programs that were not updating or downloading before are fixed now. Should I leave that folder I downloaded in the Downloads folder or is that safe to remove? And/or anything else I should fix?

  • @acernal823
    Ah that’s good, ok, now we have to add the Antergos repos and multilib (if you open /etc/pacman.conf you’ll se they are not there)

    Now can you open the conf with:
    gksudo gedit /etc/pacman.conf

    then add (right befor #[testing]:

    #[antergos-staging]
    #SigLevel = PackageRequired
    #Server = http://mirrors.antergos.com/$repo/$arch/

    [antergos]
    SigLevel = PackageRequired
    Include = /etc/pacman.d/antergos-mirrorlist

  • @acernal823 also uncomment this 2 lines by removing the #:

    [multilib]
    Include = /etc/pacman.d/mirrorlist

  • @fernandomaroto Everything looks to be there now, thank you very much for your help! Really appreciate it!

  • @acernal823 ok, now just update again to see if everything is fine:
    sudo pacman -Syyu

  • Hi

    My update-manager has been sleeping these last two weeks (or more?). Everything was quiet and it reported “Your system is up to date”. I became suspicious and tried:

    sudo pacman -Syyu
    

    I suddenly had to update 150 packages, about 650 MB. pacman did it without a hitch. All the major packages were updated (virtualbox, wine, dropbox, libreoffice, inkscape, glibc, etc.

    What do you advise to put my update-manager back on track?

  • If this can help, while I think at it, following archwiki advice, some days ago, I deleted a lot of orphans using this command:

    # pacman -Rns $(pacman -Qtdq)
    

    May be my update-manager problem is stemming from here?

manager71 non-functional1 Posts 23Views 2750
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.