• I broke it!!!


    For info … I tried re-installing antergos again whilst keeping the fat32 EFI partition labelled as SYSTEM rather than renaming it to ESP, doesn’t seem to have made much difference. Just some info:

    Output of fdisk -l:

    Device         Start       End   Sectors  Size Type
    /dev/sda1       2048    534527    532480  260M EFI System
    /dev/sda2     534528    567295     32768   16M Microsoft reserved
    /dev/sda3     567296 126167039 125599744 59.9G Microsoft basic data
    /dev/sda4  249047040 250068991   1021952  499M Windows recovery environment
    /dev/sda5  126167040 184760789  58593750   28G Linux filesystem
    /dev/sda6  184760790 192573289   7812500  3.7G Linux filesystem
    /dev/sda7  192573290 231635789  39062500 18.6G Linux filesystem
    
    [[email protected] ~]# cd /boot/efi
    [[email protected] efi]# df 
    Filesystem     1K-blocks    Used Available Use% Mounted on
    dev              4030048       0   4030048   0% /dev
    run              4035320    1684   4033636   1% /run
    /dev/sda5       28705932 6124000  22272580  22% /
    tmpfs            4035320   19932   4015388   1% /dev/shm
    tmpfs            4035320       0   4035320   0% /sys/fs/cgroup
    /dev/sda1         262144    1800    260344   1% /boot/efi
    /dev/sda7       19091540  131056  18748804   1% /home
    tmpfs            4035320    6176   4029144   1% /tmp
    tmpfs             807064      28    807036   1% /run/user/1000
    

    My bootmgfw.efi is a directory not a file…

    [[email protected] Boot]# pwd
    /boot/efi/EFI/Microsoft/Boot
    [[email protected] Boot]# ls -ltr | tail -1
    drwxr-xr-x 2 root root 4096 Aug  3 17:04 bootmgfw.efi
    

    So I tried finding it in /dev/sda3 (windows partition) and copying it into the bootmgfw.efi directory as above, but no luck:

    [[email protected] Boot]# ls -ltr /boot/efi/EFI/Microsoft/Boot/bootmgfw.efi
    total 1140
    -rwxr-xr-x 1 root root 1165152 Aug  3 17:04 bootmgfw.efi
    

    No os-prober, grub-update or mkconfig is picking up windows.

    I manually added my windows entry for grub after doing the above:

    [[email protected] grub.d]# cat /etc/grub.d/40_custom 
    #!/bin/sh
    exec tail -n +3 $0
    # This file provides an easy way to add custom menu entries.  Simply type the
    # menu entries you want to add after this comment.  Be careful not to change
    # the 'exec tail' line above.
    menuentry "Windows 10" {
        set root='(hd0,gpt1)'
        chainloader /EFI/microsoft/BOOT/bootmgfw.efi/bootmgfw.efi
    }
    

    Now when I press the windows 10 option in grub it says it can’t find the BCD (boot control data) under the same EFI partition.

    It is like I have completely messed it up somehow but I am really confused as to what has happened here!

  • Okay I think I have finally fixed it all!!! I had to download the windows 10 media tool and put it on my USB stick. From there I went into troubleshoot and the command prompt where I ran several bootrec commands in the dos prompt to fix my boot files. I then restarted and I can see both antergos and windows in my grub menu and both boot fine! So happy for things to finally be back to normal now… Thanks everyone for the help.

  • Yay! It’s finally fixed!!!

    Thanks everyone for the help.

    You’re welcome. It’s what we’re here for after all…

  • @pilnet123 great!! I love it when users can solve their problem themselves! ;)

broke25 Posts 44Views 3368
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.