• Reinstall antergos-keyring


    Hi,

    I’m having real trouble updating. I was getting persistent issues with marginal trust status. I tried to follow the guide to resolve. The front end for updates isn’t working so I removed the antergos-keyring via the command line however I now cannot reinstall it with this command:

    sudo pacman -U http://repo.antergos.info/antergos/x86\_64/antergos-keyring-20170524-1-any.pkg.tar.xz
    

    However when I try to install I’m getting a signature error. I can see the sig file on the above site however I’ve no idea how to import it through the command line. Here’s the error I’m now getting:

    error: '/var/cache/pacman/pkg/antergos-keyring-20170524-1-any.pkg.tar.xz': package missing required signature
    

    I’m stuck now as I can’t find out to import a specific sig file. I can only see references to run --refresh-keys however that only refreshes the arch keys and therefore antergos ones are never imported.

    Any help appreciated.

  • @Eamonn-Doyle Try to use this:

    https://wiki.archlinux.org/index.php/Pacman/Package_signing#Disabling_signature_checking

    Install antergos-keyring. Then,enable signature checking.

  • Hi,

    First download the file. This is the URL:

    http://repo.antergos.com/antergos/x86_64/antergos-keyring-20170524-1-any.pkg.tar.xz

    Then try installing it (as you did, but not using the url but the file):

    sudo pacman -U antergos-keyring-20170524-1-any.pkg.tar.xz

    If it still does not work, try to delete the pacman keyring and build it again:

    sudo rm -R /etc/pacman.d/gnupg
    sudo pacman-key --init
    sudo pacman-key --populate archlinux antergos
    

    Cheers!

  • @karasu Thanks that worked. However the update manager still doesn’t load. It comes up with an initial message to say it’s not responding and do I want to wait or force quit. I wait and it then opens however when it opens you cannot actually do anything. You can’t move the window or click any buttons. I’ve left it for several minutes now however it’s still not responding.

    Any idea how to get this back working again also?

    Thanks

  • A reboot sorted the the problem with the update manager gui.

  • @Eamonn-Doyle That would be the next thing @karasu would have suggested you ;)

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    how to add system logs

reinstall4 Posts 6Views 192
Log in to reply