• VirtualBox not launching guest OS after upgrade

    Hello Everyone,

    I was using Vbox ver.5.1.22 and it was working (though there were some other issues).
    So hoping this might get resolved in new version I updated to 5.1.24.
    I checked using terminal and the version upgrade was listed and went ahead with it,
    After that now I am getting error while lauching Guest OS. Tried both Win 7 and 10. Removed and added them again but still not lauching.

    **Failed to open a session for the virtual machine Win 7.

    The virtual machine ‘Win 7’ has terminated unexpectedly during startup with exit code 1 (0x1).

    Result Code: NS_ERROR_FAILURE (0x80004005)
    Component: MachineWrap
    Interface: IMachine {b2547866-a0a1-4391-8b86-6952d82efaa0}

    RTR3InitEx failed with rc=-1912 (rc=-1912)

    The VirtualBox kernel modules do not match this version of VirtualBox. The installation of VirtualBox was apparently not successful. Executing


    may correct this. Make sure that you do not mix the OSE version and the PUEL version of VirtualBox.

    where: supR3HardenedMainInitRuntime what: 4 VERR_VM_DRIVER_VERSION_MISMATCH (-1912) - The installed support driver doesn’t match the version of the user.**

  • I tried some of the steps mentioned in the forums but nothing worked so far. I was also getting a package upgrade error while software update in Antergos. It was fixed and was able to install all pending updates.

    Thanks in advance :)

  • @surfermj Hi!
    I just updated my system and everything is working fine.
    Ae you using virtualbox-guest-dkms AND virtualbox-dkms OR virtualbox-guest-modules-arch AND virtualbox-host-modules-arch?
    OBS: i use the dkms ones

    Can you try activate virtualbox drivers and then launch VB again?
    modprobe vboxdrv (maybe will need sudo).

  • btw, you need to install headers for dkms modules. For example, linux-headers , linux-lts-headers or their equivalent to kernel you are using.

  • Hi,

    If your kernel was updated, the easiest thing to do is reboot your machine ;)

  • @karasu Rebooted already but didnt work.
    Turned off the machine and using it now. Just checked and things are working again. All good now. Back to issues with full screen and usb. Thats a thing for another thread. Thanks guys

upgrade81 virtualbox47 launching7 guest4 Posts 6Views 2721
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.