• GRUB disappeared after booting into Windows 10


    hi there

    First of all i have 3 Storage devices in my PC.

    1. SSD Windows 10
    2. HDD for Data
    3. SSD Antergos

    So yesterday i installed Antergos successfully on my second ssd. Everything works fine, i was able to boot up antergos through grub. Today, after booting up windows 10, i wasn’t able anymore to boot up antergos - the grub record disappeared in my selection.

    The bootmenu and BIOS settings doesn’t have a record for grub anymore…
    Bootmenu picture

    “p4” is the SSD with antegros on it, which now shows a windows boot manager, which when clicked, shows the error: “Reboot and select prober boot device or insert boot media…

    Is it possible that this s**tty Windows overwrites grub?

    I already tryied the following: Antergos Forum
    I found the partitions but when i run

    mount /dev/sdc3 /mnt
    

    or

    mount /dev/sdc1 /mnt/boot/efi
    

    i get these errors “mount point /mnt/boot does not exist” & “mount point /mnt/boot/efi does not exist

    Anyone have an idea what i could try to get antergos back?

  • @mo.rauch111 mount /dev/sdXn /mnt/boot partition is only needed if you have an extra partition for /boot! If not then /boot exists after mounting the root device under /mnt (/mnt/boot) if you mount the wrong device under /mnt/boot then /mnt/boot/efi does not exist…

    Can you give us sudo fdisk -l
    to see how you install Antergos. because maybe /dev/sdc3 is your /home and sdc1 is / (root) and also if you have an EFI-BOOT partition from Windows this one should be used to mount under /mnt/boot/efi (this should be be existing on /dev/sda then)

    sudo su
    mount /dev/sdXn /mnt >> / root partition
    {mount /dev/sdXn /mnt/boot >>> /boot partition }
    mount /dev/sdXn /mnt/boot/efi >>>>> the EFI-boot (fat32) partition
    arch-chroot /mnt
    os-prober
    grub-mkconfig -o /boot/grub/grub.cfg
    grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=Antergos-grub
    

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • Hi there and welcome to Antergos! Glad to have you with us:grinning:. If you are interested, we have a section of this Forum dedicated to new users like you (A “Hello Antergos” section). Anyways, back to your problem!

    Is it possible that this s**tty Windows overwrites grub?

    It looks like it may have overwritten grub or something. Have you made sure to disable fast startup in Windows? This article could probably help with that if you have not done so already:slight_smile:.

    In addition, I would advise just reinstalling grub and starting fresh with it. To do so, just boot into your live ISO once again, mount all of your Antergos partitions, and then install grub. For specifics, details, and help, just take a look at this article on the Wiki.

    Hope this all helps!

    Keep trying, never give up. In the end, you will find that it was all worth it

    My ISO:
    https://rebornos.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • @joekamprad @Keegan Thank you guys for the help and the kind Welcome message! :)

    Yes, fastboot ist disabeled in the power options

    So i ran sudo fdisk -l for u to show the configured partitions

    link to image

    I may have to mention that i encrypted the installation with luks.

    So which sdc partition do i have to mount where? sorry for the confusion

  • 0_1500639838905_Bildschirmfoto vom 2017-07-21 14-23-32.png
    we can see that you have EFI-BOOT partition on both devices … so as i think the one on your /dev/sdc1 was created by Antergos installation… As every EFI-BIOS is different this is maybe needed or not i do not know here… If you are able to change EFI-BIOS to boot up from /dev/sdc directly, it should work for you, also adding windows to the boot-menu (grub)

    To get it work you need to open the Luks containers before as you might know…

    sudo su
    mount /dev/sdc3 /mnt
    mount /dev/sdc2 /mnt/boot
    mount /dev/sdc1 /mnt/boot/efi
    arch-chroot /mnt
    os-prober
    grub-mkconfig -o /boot/grub/grub.cfg
    grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=Antergos-grub
    

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • @joekamprad So i was now able to mount the threee partitions but ran into other errors - anyway at the end stays “Installation finished. No error reportet” ^^

    Link to Image

    After a reboot grub ist still not there in my boot menu :/

    Maybe i go into a full new installation and try to replace windows bootloader with grub so i can boot both os with it?
    is it even possible for grub to boot an os on another physical drive?

    Thanks alot for your support :)

  • Yea it does not detect your windows os…

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • Other try would be to mount the EFI-BOOT from the Windrive… but this needs some more configuration.

    If it is a new install i would reinstall Antergos and o a manual partition with help from this:
    https://antergos.com/wiki/install/how-to-dual-boot-antergos-windows-uefi-expanded-by-linuxhat/

    You do not need the first part, because your Antergos will be installed on another SSD but it shows up howto use the EFI-Boot from Windows and set grub up to have both OS aviable.

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • My Antergos finally works :dancer:

    What i did:

    1. Unplug the two other harddrives (windows and data)
    2. boot into antergos live and installed antergos new
    3. reboot into bios and set antergos hard drive as first boot option and start antergos
    4. poweroff the system and plugged back the other two harddrives

    now it boots into grub per default & when i want to boot windows i press f12 for bootoptions and can select windows bootloader. After booting into Windows 10, grub does not disappeard again :)

    Thanks for all the help and keep up the goos work! :)

  • @mo.rauch111 said in GRUB disappeared after booting into Windows 10:

    My Antergos finally works

    Yay!!! Good to hear:grinning:.

    Keep trying, never give up. In the end, you will find that it was all worth it

    My ISO:
    https://rebornos.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • Nice to see it works!
    And blame to stupid >System-EFI-Bios<! ;)

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

Posts 11Views 734
Log in to reply